Loading ...
Sorry, an error occurred while loading the content.

long classpath causing TestRunner to fail in DOS shell

Expand Messages
  • pudur
    I m not able to run a test which has long classpath from DOS command prompt (XP). Did any one encouner this issue? Any workaround suggestions greatly
    Message 1 of 4 , May 1, 2008
    • 0 Attachment
      I'm not able to run a test which has long classpath from DOS command
      prompt (XP).

      Did any one encouner this issue? Any workaround suggestions greatly
      apprecited.

      -p
    • Andy Dassing
      If the class path has embedded spaces, enclose the entire path in quotes ( ). Instead of supplying the classpath on the command line, set the CLASSPATH
      Message 2 of 4 , May 1, 2008
      • 0 Attachment
        If the class path has embedded spaces, enclose the entire path in
        quotes (").

        Instead of supplying the classpath on the command line, set the
        CLASSPATH environment variable appropriately. There's no need for the
        -cp command line argument then.

        Stay Fit,
        Andy

        --- In fitnesse@yahoogroups.com, "pudur" <pudur@...> wrote:
        >
        > I'm not able to run a test which has long classpath from DOS command
        > prompt (XP).
        >
        > Did any one encouner this issue? Any workaround suggestions greatly
        > apprecited.
        >
        > -p
        >
      • Pudur Ramaswamy
        We do not have spaces issue. so what you are suggesting is to use SET CLASSPATH= long clss path here in a BAT file and just run the TestRunnuer? -p ...
        Message 3 of 4 , May 2, 2008
        • 0 Attachment
          We do not have "spaces" issue.
          so what you are suggesting is to use SET
          CLASSPATH="long clss path here"
          in a BAT file and just run the TestRunnuer?

          -p

          --- Andy Dassing <andrew.dassing@...> wrote:

          > If the class path has embedded spaces, enclose the
          > entire path in
          > quotes (").
          >
          > Instead of supplying the classpath on the command
          > line, set the
          > CLASSPATH environment variable appropriately.
          > There's no need for the
          > -cp command line argument then.
          >
          > Stay Fit,
          > Andy
          >
          > --- In fitnesse@yahoogroups.com, "pudur" <pudur@...>
          > wrote:
          > >
          > > I'm not able to run a test which has long
          > classpath from DOS command
          > > prompt (XP).
          > >
          > > Did any one encouner this issue? Any workaround
          > suggestions greatly
          > > apprecited.
          > >
          > > -p
          > >
          >
          >
          >



          ____________________________________________________________________________________
          Be a better friend, newshound, and
          know-it-all with Yahoo! Mobile. Try it now. http://mobile.yahoo.com/;_ylt=Ahu06i62sR8HDtDypao8Wcj9tAcJ
        • Andy Dassing
          It depends on which BAT file is in question. Setting CLASSPATH in the run.bat only supplies FitNesse with that class path for subsequent test kick-offs in the
          Message 4 of 4 , May 2, 2008
          • 0 Attachment
            It depends on which BAT file is in question.

            Setting CLASSPATH in the run.bat only supplies FitNesse with that
            class path for subsequent test kick-offs in the wiki world.

            If you have another BAT file that executes TestRunner, put the
            CLASSPATH setting in that BAT file.


            --- In fitnesse@yahoogroups.com, Pudur Ramaswamy <pudur@...> wrote:
            >
            >
            > We do not have "spaces" issue.
            > so what you are suggesting is to use SET
            > CLASSPATH="long clss path here"
            > in a BAT file and just run the TestRunnuer?
            >
            > -p
            >
            > --- Andy Dassing <andrew.dassing@...> wrote:
            >
            > > If the class path has embedded spaces, enclose the
            > > entire path in
            > > quotes (").
            > >
            > > Instead of supplying the classpath on the command
            > > line, set the
            > > CLASSPATH environment variable appropriately.
            > > There's no need for the
            > > -cp command line argument then.
            > >
            > > Stay Fit,
            > > Andy
            > >
            > > --- In fitnesse@yahoogroups.com, "pudur" <pudur@>
            > > wrote:
            > > >
            > > > I'm not able to run a test which has long
            > > classpath from DOS command
            > > > prompt (XP).
            > > >
            > > > Did any one encouner this issue? Any workaround
            > > suggestions greatly
            > > > apprecited.
            > > >
            > > > -p
            > > >
            > >
            > >
            > >
            >
            >
            >
            >
            ____________________________________________________________________________________
            > Be a better friend, newshound, and
            > know-it-all with Yahoo! Mobile. Try it now.
            http://mobile.yahoo.com/;_ylt=Ahu06i62sR8HDtDypao8Wcj9tAcJ
            >
          Your message has been successfully submitted and would be delivered to recipients shortly.