Loading ...
Sorry, an error occurred while loading the content.

RE: [XP] Comments

Expand Messages
  • Bill dehOra
    ... Though it is a bit jarring, I can t see how this naming differentiates from other human-readable variable naming. Exceptions are not for expected
    Message 1 of 48 , Aug 1, 2000
    • 0 Attachment
      >> catch (InterruptedIOException ignoringNormalTimeOut)
      >>

      >I can't say I like that very much. It clouds the intent a
      >bit.

      Though it is a bit jarring, I can't see how this naming differentiates from
      other human-readable variable naming. Exceptions are not for expected
      behaviour. If there is an exception block that is not for exceptional
      behaviour (as above), then the naming above indicates the intent: the intent
      being that there isn't any.

      Of course it would be better if the try/catch block could be made to go away
      altogether, and java had cleaner exception objects.

      > I don't think a variable name should be solely a comment.

      But that's ok, it is a comment of sorts: this variable doesn't do anything
      at the programmers level of intent, other than get him or her out of a
      redundant contract.


      >Something that is solely
      >a comment should be a syntatic comment so that the reader knows you are
      >commenting on something.

      You're totally right, but redundant try/catch variables are an exception.

      -Bill de hÓra
    • Bill dehOra
      ... Though it is a bit jarring, I can t see how this naming differentiates from other human-readable variable naming. Exceptions are not for expected
      Message 48 of 48 , Aug 1, 2000
      • 0 Attachment
        >> catch (InterruptedIOException ignoringNormalTimeOut)
        >>

        >I can't say I like that very much. It clouds the intent a
        >bit.

        Though it is a bit jarring, I can't see how this naming differentiates from
        other human-readable variable naming. Exceptions are not for expected
        behaviour. If there is an exception block that is not for exceptional
        behaviour (as above), then the naming above indicates the intent: the intent
        being that there isn't any.

        Of course it would be better if the try/catch block could be made to go away
        altogether, and java had cleaner exception objects.

        > I don't think a variable name should be solely a comment.

        But that's ok, it is a comment of sorts: this variable doesn't do anything
        at the programmers level of intent, other than get him or her out of a
        redundant contract.


        >Something that is solely
        >a comment should be a syntatic comment so that the reader knows you are
        >commenting on something.

        You're totally right, but redundant try/catch variables are an exception.

        -Bill de hÓra
      Your message has been successfully submitted and would be delivered to recipients shortly.