Loading ...
Sorry, an error occurred while loading the content.

Re: [XP] UA

Expand Messages
  • Manuel Klimek
    so I m back at the beginning: why do people like to abuse acronyms and abrevations in code? Or think it s funny to name a scroll pane class ScrollPain? Perhaps
    Message 1 of 19 , Mar 1, 2008
    • 0 Attachment
      so I'm back at the beginning: why do people like to abuse acronyms and
      abrevations in code? Or think it's funny to name a scroll pane class
      ScrollPain?

      Perhaps a better question for this forum is: what do you do when you
      encounter such people?

      /Manuel

      On Sat, Mar 1, 2008 at 2:33 AM, Chris Wheeler
      <christopher.wheeler@...> wrote:
      >
      >
      >
      >
      >
      >
      > On Fri, Feb 29, 2008 at 4:20 PM, Manuel Klimek <klimek@...> wrote:
      >
      > > First: to be clear, I'm inquiring about acronyms in code, not in written
      > > texts.
      >
      > OH! That wasn't clear to me. I thought we were talking about writing...
      >
      > In code, I *only* use an acronym if the acronym is a domain term. For
      > example, in my domain, a TIC is a well-known, often used term that stands
      > for Total Ion Chromatogram - nobody uses the expanded form in writing or
      > speaking. Otherwise, I never abbreviate or use shortened forms or make up
      > my
      > own.
      >
      >
      > Chris.
      >
      > [Non-text portions of this message have been removed]
      >
      >



      --
      http://klimek.box4.net
    • Ron Jeffries
      Hello, Manuel. On Saturday, March 1, 2008, at 4:03:20 AM, you ... Rename Class refactoring. Ron Jeffries www.XProgramming.com Design is the thinking one does
      Message 2 of 19 , Mar 1, 2008
      • 0 Attachment
        Hello, Manuel. On Saturday, March 1, 2008, at 4:03:20 AM, you
        wrote:

        > so I'm back at the beginning: why do people like to abuse acronyms and
        > abrevations in code? Or think it's funny to name a scroll pane class
        > ScrollPain?

        > Perhaps a better question for this forum is: what do you do when you
        > encounter such people?

        Rename Class refactoring.

        Ron Jeffries
        www.XProgramming.com
        Design is the thinking one does before, during, and after
        implementation. It works best for me with a little up front, most of
        it during implementation, and very little after it's too late.
      • Manuel Klimek
        On Sat, Mar 1, 2008 at 10:51 AM, Ron Jeffries ... /Manuel ... -- http://klimek.box4.net
        Message 3 of 19 , Mar 1, 2008
        • 0 Attachment
          On Sat, Mar 1, 2008 at 10:51 AM, Ron Jeffries
          <ronjeffries@...> wrote:
          > > so I'm back at the beginning: why do people like to abuse acronyms and
          > > abrevations in code? Or think it's funny to name a scroll pane class
          > > ScrollPain?
          >
          > > Perhaps a better question for this forum is: what do you do when you
          > > encounter such people?
          >
          > Rename Class refactoring.

          :-)

          /Manuel

          >
          > Ron Jeffries
          > www.XProgramming.com
          > Design is the thinking one does before, during, and after
          > implementation. It works best for me with a little up front, most of
          > it during implementation, and very little after it's too late.
          >
          >



          --
          http://klimek.box4.net
        • Richard
          ScrollPain is not so bad. I just apply Rename to it when I see something like that. I recently renamed XXXConsummationStopped to XXXConsumptionStopped. They
          Message 4 of 19 , Mar 1, 2008
          • 0 Attachment
            ScrollPain is not so bad. I just apply Rename to it when I see
            something like that. I recently renamed XXXConsummationStopped to
            XXXConsumptionStopped. They didn't know that consumption goes with
            consume and not consummate. I just fix it. Unclear acronym usage in
            identifiers is treated the same was as a name that doesn't reveal its
            intention: you rename it. I leave commonly understood acronyms
            inplace: I don't rename xmlDocument to extensibleMarkupLanguageDocument.

            I do often find myself in a quandary about the capitalization of
            acronyms when they begin a word that would normally start with a lower
            case letter. Do you write xmlDocument or xMLDocument or further muddy
            the watters with XMLDocument, even though its supposed to be variable
            name and not a class? If its a class do you write XMLDocument or
            XmlDocument? Do you write HTTPServer or HttpServer? Different people
            have done different things, even within the same code base. If the
            capitalization scheme was all over the place to the point where it
            generated confusion, then I'd propose a rename discussion with the
            team to bring the capitalization into a uniform usage.

            In article <d2d148c0803010103l16884715r6dcb051725279dae@...>,
            "Manuel Klimek" <klimek@...> writes:

            > Perhaps a better question for this forum is: what do you do when you
            > encounter such people?

            For people who use acronyms, you might just consider having a talk
            with them. For people who intentionally pick "cute" names that reveal
            no intention on classes, you give them a warning and if they don't
            start creating useful names, you fire them. I worked at a place where
            they fired an engineer (not for this, but its just indicative of the
            kind of work he did) who named classes Sybok, Spock, Kirk, etc.
            --
            "The Direct3D Graphics Pipeline" -- DirectX 9 draft available for download
            <http://www.xmission.com/~legalize/book/download/index.html>

            Legalize Adulthood! <http://blogs.xmission.com/legalize/>
          • Zhon Johansen
            ... I alway like to have that third category: funny (and sad). When I first started learning ruby (and TDD), I wrote an acronymizer. It would look through
            Message 5 of 19 , Mar 5, 2008
            • 0 Attachment
              Daniel Pupek wrote:
              > Acronyms can be good or bad. I put them into 2 categories. The good
              > category just makes typing and communicating faster; ASAP, DIY, YAGNI,
              > LOL. The bad category ; IBBM, CMMI, SCORM
              >
              > Acronyms in the bad category tend to be derived from convoluted,
              > overly descriptive names for nebulous things. In short....somebody was
              > too lazy to come up with an easy to remember moniker for something.
              > Thus, condemning it to be known only by it's acronym form.
              >
              I alway like to have that third category: funny (and sad).

              When I first started learning ruby (and TDD), I wrote an acronymizer.
              It would look through unused, unread design documentation and replace
              any 3 - 10 repeated words with an acronym thus making the poor outdated
              design documentation even more obscure. While the resulting document
              impressed management, the poor employees who were asked to read the
              result didn't think it was funny.
            Your message has been successfully submitted and would be delivered to recipients shortly.