Loading ...
Sorry, an error occurred while loading the content.

strange "unknown element" with namespace

Expand Messages
  • Jean-Noel Avila
    Hello all, I am encountering a strange problem with an xml file supposed to be valid. When I want to add a xmlns:blah= uri attribute to an element the element
    Message 1 of 3 , Sep 3, 2004
    • 0 Attachment
      Hello all,

      I am encountering a strange problem with an xml file supposed to be
      valid. When I want to add a xmlns:blah="uri" attribute to an element the
      element is automatically tagged as unknown.

      Si attached files. nxml-mode version is 20040726.


      --
      * Jean-Noel Avila Tel. : +33 (0)4 79 25 31 32
      * ALEPH S.A. Fax : +33 (0)4 79 25 24 27
      * Savoie Technolac BP 264
      * F-73375 Le Bourget du Lac
    • James Clark
      ... The tar file is missing docbookx.rnc. I noticed that the namespace on the document (.../SSA/Gauge) doesn t match the namespace in the schema
      Message 2 of 3 , Sep 3, 2004
      • 0 Attachment
        On Fri, 2004-09-03 at 16:51, Jean-Noel Avila wrote:
        > Hello all,
        >
        > I am encountering a strange problem with an xml file supposed to be
        > valid. When I want to add a xmlns:blah="uri" attribute to an element the
        > element is automatically tagged as unknown.
        >
        > Si attached files. nxml-mode version is 20040726.
        >

        The tar file is missing docbookx.rnc. I noticed that the namespace on
        the document (.../SSA/Gauge) doesn't match the namespace in the schema
        (.../SSA*1*/Gauge). If this isn't the problem, then please send a
        complete set of files and say exactly what I should do to see the
        problem.

        James
        --
        To send me mail, replace auth-only by public in the from address.
      • wararmor
        ... Really sorry to have bothered you, my mistake... I changed the namespace and everything went fine. btw, this emacs mode is *really* great. Jean-Noel
        Message 3 of 3 , Sep 3, 2004
        • 0 Attachment
          > The tar file is missing docbookx.rnc. I noticed that the namespace on
          > the document (.../SSA/Gauge) doesn't match the namespace in the schema
          > (.../SSA*1*/Gauge). If this isn't the problem, then please send a
          > complete set of files and say exactly what I should do to see the
          > problem.
          >
          > James
          > --
          > To send me mail, replace auth-only by public in the from address.

          Really sorry to have bothered you, my mistake... I changed the
          namespace and everything went fine.

          btw, this emacs mode is *really* great.

          Jean-Noel
        Your message has been successfully submitted and would be delivered to recipients shortly.