Loading ...
Sorry, an error occurred while loading the content.

Re: [emacs-nxml-mode] xmlunicode.el problem

Expand Messages
  • Norman Walsh
    ... Is your .emacs file byte-compiled? Does it work if you don t do that? ... Be seeing you, norm -- Norman Walsh | There are things
    Message 1 of 10 , May 12, 2004
    • 0 Attachment
      / "Bruce D'Arcus" <bdarcus@...> was heard to say:
      | On May 11, 2004, at 12:29 AM, Carsten Bormann wrote:
      |
      |> Put this in your .emacs before loading xmlunicode.el:
      |>
      |> (require 'cl)
      |
      | Thanks! The error message seems to be getting less verbose, but I
      | still get this.

      Is your .emacs file byte-compiled? Does it work if you don't do that?

      | Debugger entered--Lisp error: (file-error "Cannot open load file"
      | "/Users/darcusb/Library/texmf/d$
      | load("/Users/darcusb/Library/texmf/dvips/emacs/xmlunicode.el" nil nil
      | t)
      | load-file("emacs/xmlunicode.el")
      | eval-buffer(#<buffer *load*> nil "~/.emacs" nil t)
      | ;;; Reading at buffer position 2703
      | load-with-code-conversion("/Users/darcusb/.emacs" "~/.emacs" t t)
      | load("~/.emacs" t t)
      | #[nil "^H\205?^@ ?=\203^Q^@?^H?Q\2025^@
      | ?=\203'^@????#\203#^@?\2025^@?\2025^@ ?=\2031^@$
      | command-line()
      | normal-top-level()
      |
      | The offending lines (which I never did get working correctly) in my
      | .emacs are:
      |
      | (define-key ctl-t-map "c" 'unicode-character-menu-insert)
      | (define-key ctl-t-map "e" 'unicode-character-shortcut-insert)
      | (define-key ctl-t-map "u" 'unicode-character-insert)

      Be seeing you,
      norm

      --
      Norman Walsh <normyahoo@...> | There are things which don't
      http://nwalsh.com/ | deserve to be said briefly.--Jean
      | Rostand
    • Bruce D'Arcus
      ... No; it s not byte-compiled. I have it working now, with some more help from Carsten. One problem was with paths in the .emacs file. Another seems to be
      Message 2 of 10 , May 12, 2004
      • 0 Attachment
        On May 12, 2004, at 3:09 PM, Norman Walsh wrote:

        > Is your .emacs file byte-compiled? Does it work if you don't do that?

        No; it's not byte-compiled. I have it working now, with some more help
        from Carsten. One problem was with paths in the .emacs file. Another
        seems to be that my emacs is not properly setup for using the
        ctl-t-map, so I just left that stuff commented out.

        Short answer, then: adding the (require 'cl) in my emacs and fixing the
        paths worked.

        Thanks,
        Bruce
      Your message has been successfully submitted and would be delivered to recipients shortly.