Loading ...
Sorry, an error occurred while loading the content.

unloading mule-ucs

Expand Messages
  • pug_henry
    I am using nxml-mode on GNU-Emacs 21.3.1, and it is complaining about MULE-UCS. Can someone tell me how I can disable MULE-UCS? Thanks, Victor
    Message 1 of 5 , Jan 20, 2004
    • 0 Attachment
      I am using nxml-mode on GNU-Emacs 21.3.1, and it is complaining about
      MULE-UCS. Can someone tell me how I can disable MULE-UCS?

      Thanks,
      Victor
    • Michael Smith
      ... I think maybe this: M-x unload-feature un-define Or in your .emacs: (unload-feature un-define)
      Message 2 of 5 , Jan 20, 2004
      • 0 Attachment
        pug_henry <pug_henry@...> writes:

        > I am using nxml-mode on GNU-Emacs 21.3.1, and it is complaining about
        > MULE-UCS. Can someone tell me how I can disable MULE-UCS?
        >
        > Thanks,
        > Victor

        I think maybe this:

        M-x unload-feature un-define

        Or in your .emacs:

        (unload-feature un-define)
      • pug_henry
        ... Thanks! I ended up having to comment out the SuSE specific file in the /usr/share/emacs/site-lisp directory, because the suggestion above caused some
        Message 3 of 5 , Jan 21, 2004
        • 0 Attachment
          --- In emacs-nxml-mode@yahoogroups.com, Michael Smith <smith@x> wrote:
          > pug_henry <pug_henry@y...> writes:
          >
          > > I am using nxml-mode on GNU-Emacs 21.3.1, and it is complaining about
          > > MULE-UCS. Can someone tell me how I can disable MULE-UCS?
          > >
          > > Thanks,
          > > Victor
          >
          > I think maybe this:
          >
          > M-x unload-feature un-define
          >
          > Or in your .emacs:
          >
          > (unload-feature un-define)

          Thanks!

          I ended up having to comment out the SuSE specific file in the
          /usr/share/emacs/site-lisp directory, because the suggestion above
          caused some dependency problems. I have no idea why this problem
          didn't bite me at home.

          Victor
        • Michael Smith
          Hi Victor, ... [...] Yeah, I forgot that Emacs will refuse to unload it if other loaded stuff requires it. But there is a way to force it to unload -- use the
          Message 4 of 5 , Jan 21, 2004
          • 0 Attachment
            Hi Victor,

            You wrote:

            > --- In emacs-nxml-mode@yahoogroups.com, Michael Smith <smith@x> wrote:
            > > pug_henry <pug_henry@y...> writes:
            > >
            > > > I am using nxml-mode on GNU-Emacs 21.3.1, and it is complaining about
            > > > MULE-UCS. Can someone tell me how I can disable MULE-UCS?
            > > >
            > > > Thanks,
            > > > Victor
            > >
            > > I think maybe this:
            > >
            > > M-x unload-feature un-define
            > >
            > > Or in your .emacs:
            > >
            > > (unload-feature un-define)
            >
            > Thanks!
            >
            > I ended up having to comment out the SuSE specific file in the
            > /usr/share/emacs/site-lisp directory, because the suggestion above
            > caused some dependency problems.
            [...]

            Yeah, I forgot that Emacs will refuse to unload it if other loaded
            stuff requires it. But there is a way to force it to unload -- use the
            prefix argument:

            C-u M-x unload-feature un-define

            Or in your .emacs:

            (unload-feature 'un-define t)

            You might want to do it that way instead, because I reckon at some point
            you'll probably use the SuSE package manager to install or update some
            Emacs-related packages, and it'll end up overwriting the file you edited
            in your /usr/share/emacs/site-lisp directory, and wiping out your edit.

            And above should work even when you're on a shared system and don't have
            write perms on global config files in /usr/share/emacs/site-lisp or wherever.

            --Mike
          • Karl Eichwalder
            ... If you don t need mule-ucs you can just uninstall this package ;) ... These suse-start-* files coming with the Emacs addon packages are marked as %config
            Message 5 of 5 , Jan 21, 2004
            • 0 Attachment
              Michael Smith <smith@...> writes:

              >> I ended up having to comment out the SuSE specific file in the
              >> /usr/share/emacs/site-lisp directory, because the suggestion above
              >> caused some dependency problems.
              > [...]

              If you don't need mule-ucs you can just uninstall this package ;)

              > Yeah, I forgot that Emacs will refuse to unload it if other loaded
              > stuff requires it. But there is a way to force it to unload -- use the
              > prefix argument:
              >
              > C-u M-x unload-feature un-define
              >
              > Or in your .emacs:
              >
              > (unload-feature 'un-define t)
              >
              > You might want to do it that way instead, because I reckon at some point
              > you'll probably use the SuSE package manager to install or update some
              > Emacs-related packages, and it'll end up overwriting the file you edited
              > in your /usr/share/emacs/site-lisp directory, and wiping out your edit.

              These "suse-start-*" files coming with the Emacs addon packages are
              marked as %config files; this will prevent yast/rpm from replacing the
              files unconditionally during the update. But eventually you are forced
              to sort out .rpmconfig or .rpmsave files ;)

              > And above should work even when you're on a shared system and don't have
              > write perms on global config files in /usr/share/emacs/site-lisp or
              > wherever.

              Yes, that's another point.

              --
              | ,__o
              | _-\_<,
              http://www.gnu.franken.de/ke/ | (*)/'(*)
            Your message has been successfully submitted and would be delivered to recipients shortly.