Loading ...
Sorry, an error occurred while loading the content.

Re: [emacs-nxml-mode] php completion not working

Expand Messages
  • Lennart Borgman (gmail)
    ... Are you trying to complete the php code? There is something called php-completion-file that looks like it should be used for php function name completion.
    Message 1 of 9 , Sep 29, 2007
    • 0 Attachment
      franckbay wrote:
      >
      >
      > that's true, I'm using more and more php (html, with css, templates
      > and php do a good job). But I can't complete :
      >
      > M-Tab (or what I decided) give, for include for example, :
      >
      > inclu (M-TAB)
      > can't find completion for "inclu"
      >
      > weird, enit ?
      >
      > Keep the good job !

      Are you trying to complete the php code? There is something called
      php-completion-file that looks like it should be used for php function
      name completion. I have never tried to use it though.

      Maybe the author of the php-mode could clarify this a bit?
    • Lennart Borgman (gmail)
      Hi Franck, I have not had time to dive into your problem, but there is a new beta available. It would be nice if you could test and give some feedback:
      Message 2 of 9 , Nov 25, 2007
      • 0 Attachment
        Hi Franck,

        I have not had time to dive into your problem, but there is a new beta
        available. It would be nice if you could test and give some feedback:

        http://ourcomments.org/Emacs/nXhtml/doc/nxhtml-changes.html
        http://ourcomments.org/Emacs/DL/elisp/nxhtml/beta/


        franckbay wrote:
        >
        >
        > that's true, I'm using more and more php (html, with css, templates
        > and php do a good job). But I can't complete :
        >
        > M-Tab (or what I decided) give, for include for example, :
        >
        > inclu (M-TAB)
        > can't find completion for "inclu"
        >
        > weird, enit ?
        >
        > Keep the good job !
      • franckbay
        ... Ok I ll have a try (cause I m still unisng it)
        Message 3 of 9 , Dec 2, 2007
        • 0 Attachment
          --- In emacs-nxml-mode@yahoogroups.com, "Lennart Borgman (gmail)"
          <lennart.borgman@...> wrote:
          >
          > Hi Franck,
          >
          > I have not had time to dive into your problem, but there is a new beta
          > available. It would be nice if you could test and give some feedback:
          >
          > http://ourcomments.org/Emacs/nXhtml/doc/nxhtml-changes.html
          > http://ourcomments.org/Emacs/DL/elisp/nxhtml/beta/
          >
          >
          > franckbay wrote:
          > >
          > >
          > > that's true, I'm using more and more php (html, with css, templates
          > > and php do a good job). But I can't complete :
          > >
          > > M-Tab (or what I decided) give, for include for example, :
          > >
          > > inclu (M-TAB)
          > > can't find completion for "inclu"
          > >
          > > weird, enit ?
          > >
          > > Keep the good job !
          >
          Ok I'll have a try (cause I'm still unisng it)
        • franckbay
          ... beta ... Seems good, better indentation, but php-mode seems a bit buggy (with oop). Still got the strange issue with site not found . By the way, I m
          Message 4 of 9 , Jan 2, 2008
          • 0 Attachment
            --- In emacs-nxml-mode@yahoogroups.com, "franckbay" <franckbenoit@...>
            wrote:
            >
            > --- In emacs-nxml-mode@yahoogroups.com, "Lennart Borgman (gmail)"
            > <lennart.borgman@> wrote:
            > >
            > > Hi Franck,
            > >
            > > I have not had time to dive into your problem, but there is a new
            beta
            > > available. It would be nice if you could test and give some feedback:
            > >
            > > http://ourcomments.org/Emacs/nXhtml/doc/nxhtml-changes.html
            > > http://ourcomments.org/Emacs/DL/elisp/nxhtml/beta/
            > >
            > >
            > > franckbay wrote:
            > > >
            > > >
            > > > that's true, I'm using more and more php (html, with css, templates
            > > > and php do a good job). But I can't complete :
            > > >
            > > > M-Tab (or what I decided) give, for include for example, :
            > > >
            > > > inclu (M-TAB)
            > > > can't find completion for "inclu"
            > > >
            > > > weird, enit ?
            > > >
            > > > Keep the good job !
            > >
            > Ok I'll have a try (cause I'm still unisng it)
            >
            Seems good, better indentation, but php-mode seems a bit buggy (with
            oop). Still got the strange issue with 'site not found'.

            By the way, I'm checking a very interesting php mode

            http://deboutv.free.fr/lisp/php/index.php

            Works under xemacs, but gnu emacs also (another version in). Got a lot
            of issue, but seems promising.
          • Lennart Borgman (gmail)
            ... I think context has been lost here. Can you please be more precise about what you are commenting? ... Please enter comments about it here:
            Message 5 of 9 , Jan 2, 2008
            • 0 Attachment
              franckbay wrote:
              >
              >
              > --- In emacs-nxml-mode@yahoogroups.com
              > <mailto:emacs-nxml-mode%40yahoogroups.com>, "franckbay" <franckbenoit@...>
              > wrote:
              > >
              > > --- In emacs-nxml-mode@yahoogroups.com
              > <mailto:emacs-nxml-mode%40yahoogroups.com>, "Lennart Borgman (gmail)"
              > > <lennart.borgman@> wrote:
              > > >
              > > > Hi Franck,
              > > >
              > > > I have not had time to dive into your problem, but there is a new
              > beta
              > > > available. It would be nice if you could test and give some feedback:
              > > >
              > > > http://ourcomments.org/Emacs/nXhtml/doc/nxhtml-changes.html
              > <http://ourcomments.org/Emacs/nXhtml/doc/nxhtml-changes.html>
              > > > http://ourcomments.org/Emacs/DL/elisp/nxhtml/beta/
              > <http://ourcomments.org/Emacs/DL/elisp/nxhtml/beta/>
              > > >
              > > >
              > > > franckbay wrote:
              > > > >
              > > > >
              > > > > that's true, I'm using more and more php (html, with css, templates
              > > > > and php do a good job). But I can't complete :
              > > > >
              > > > > M-Tab (or what I decided) give, for include for example, :
              > > > >
              > > > > inclu (M-TAB)
              > > > > can't find completion for "inclu"
              > > > >
              > > > > weird, enit ?
              > > > >
              > > > > Keep the good job !
              > > >
              > > Ok I'll have a try (cause I'm still unisng it)
              > >
              > Seems good, better indentation, but php-mode seems a bit buggy (with
              > oop). Still got the strange issue with 'site not found'.

              I think context has been lost here. Can you please be more precise about
              what you are commenting?

              > By the way, I'm checking a very interesting php mode
              >
              > http://deboutv.free.fr/lisp/php/index.php
              > <http://deboutv.free.fr/lisp/php/index.php>
              >
              > Works under xemacs, but gnu emacs also (another version in). Got a lot
              > of issue, but seems promising.

              Please enter comments about it here:

              http://www.emacswiki.org/cgi-bin/wiki/PhpMode
            • Franck Benoit
              ... oops! Was speaking about new release
              Message 6 of 9 , Jan 3, 2008
              • 0 Attachment
                "Lennart Borgman (gmail)" <lennart.borgman@...> writes:

                > franckbay wrote:
                >>
                >>

                >> > <lennart.borgman@> wrote:
                >> > >
                >> > > Hi Franck,
                >> > >
                >> > > I have not had time to dive into your problem, but there is a new
                >> beta
                >> > > available. It would be nice if you could test and give some feedback:
                >> > >

                >> Seems good, better indentation, but php-mode seems a bit buggy (with
                >> oop). Still got the strange issue with 'site not found'.
                >


                > I think context has been lost here. Can you please be more precise about
                > what you are commenting?

                oops!
                Was speaking about new release
              • Lennart Borgman (gmail)
                ... Could you please tell exactly how to reproduce the problems (so anyone can do the same)?
                Message 7 of 9 , Jan 3, 2008
                • 0 Attachment
                  Franck Benoit wrote:
                  >
                  >
                  > "Lennart Borgman (gmail)" <lennart.borgman@...
                  > <mailto:lennart.borgman%40gmail.com>> writes:
                  >
                  > > franckbay wrote:
                  > >>
                  > >>
                  >
                  > >> > <lennart.borgman@> wrote:
                  > >> > >
                  > >> > > Hi Franck,
                  > >> > >
                  > >> > > I have not had time to dive into your problem, but there is a new
                  > >> beta
                  > >> > > available. It would be nice if you could test and give some
                  > feedback:
                  > >> > >
                  >
                  > >> Seems good, better indentation, but php-mode seems a bit buggy (with
                  > >> oop). Still got the strange issue with 'site not found'.

                  Could you please tell exactly how to reproduce the problems (so anyone
                  can do the same)?
                • Franck Benoit
                  ... Here the .emacs part (html-site-list (quote (( newpres ~/www/new-site nil fovh.net /new-site http://es-asso.org
                  Message 8 of 9 , Jan 3, 2008
                  • 0 Attachment
                    "Lennart Borgman (gmail)" <lennart.borgman@...> writes:

                    > Franck Benoit wrote:
                    >>
                    >>
                    >> "Lennart Borgman (gmail)" <lennart.borgman@...
                    >> <mailto:lennart.borgman%40gmail.com>> writes:
                    >>
                    >> > franckbay wrote:
                    >> >>
                    >> >>
                    >>
                    >> It would be nice if you could test and give some
                    >> feedback:
                    >> >> > >
                    >>
                    >> >> Seems good, better indentation, but php-mode seems a bit buggy (with
                    >> >> oop). Still got the strange issue with 'site not found'.
                    >
                    > Could you please tell exactly how to reproduce the problems (so anyone
                    > can do the same)?
                    Here the .emacs part


                    '(html-site-list (quote (("newpres" "~/www/new-site" "" "" "" "" ""
                    nil "fovh.net" "" "" "/new-site" "" "http://es-asso.org" "/newsite"
                    "") ("pres" "~/loc-pres" "" "" "" "" "" nil "ovh.net" "" "" "/" "" ""
                    "" "") ("franckbenoitdotnet" "~/ee/" "" "" "" "" "" nil
                    "onlinehome.fr" "" "" "/fbd "" "" "" ""))))

                    jiust remove password and so here

                    It only happens on starting emacs
                  Your message has been successfully submitted and would be delivered to recipients shortly.