Loading ...
Sorry, an error occurred while loading the content.
 

Re: [eiffel-nice-library] Re: STRING 'make' - should its name be changed?

Expand Messages
  • Alexander Kogtenkov
    ... If the feature is accepted for the new ELKS, it will continue to appear in the new code. If the feature is rejected, the new code will not use it probably.
    Message 1 of 37 , Apr 20, 2001
      James McKim wrote:

      > I agree with Franck. We don't really know what the parameter on 'make' is
      > there for. The proof of this is that we can't write a postcondition that
      > uses it. So users won't know what it's for either, except perhaps as part
      > of vendor specific documentation. That said, we're probably stuck with it
      > as the vendors and more importantly their customers all have code that
      > uses it in this form.

      If the feature is accepted for the new ELKS, it will continue to appear in
      the new code. If the feature is rejected, the new code will not use it probably.
      The old code can still rely on it and it will take some (a lot of?) time to get
      rid of this. But the new code will benefit from a better STRING interface.

      Regards,
      Alexander Kogtenkov
      Object Tools, Moscow
    • Simon Parker
      Good morning. ... As I said earlier, I would actually prefer to drop the argument: make -- Create an empty string However, if an argument is to be included I
      Message 37 of 37 , Apr 27, 2001
        Good morning.

        > 20 APRIL 2001 16:30 version:
        >
        > make (n: INTEGER)
        > -- Create empty string with suggested capacity 'n' characters
        > require
        > non_negative_suggested_capacity: n >= 0

        As I said earlier, I would actually prefer to drop the argument:

        make
        -- Create an empty string

        However, if an argument is to be included I suggest this text:

        make (capacity: INTEGER)
        -- Create an empty string
        -- 'capacity' is an implementation hint, whose effect is undefined
        require
        positive_capacity: capacity >= 0



        Regards,
        Simon

        Simon Parker +353 87 249 7859


        On Thursday, April 26, 2001 7:25 PM, Roger Browne [SMTP:egroups@...] wrote:
        > Ulrich Windl wrote:
        >
        > > > 20 APRIL 2001 16:30 version:
        > > >
        > > > make (n: INTEGER)
        > > > -- Create empty string with suggested capacity 'n' characters
        > > > require
        > > > non_negative_suggested_capacity: n >= 0
        > >
        > > Also add some length to `n' ;-) s/n/suggested_capacity/ will make
        > > things more clear IMHO
        >
        > Do you mean like this:
        > make (suggested_capacity: INTEGER)
        > -- Create empty string with suggested capacity
        > -- 'suggested_capacity' characters
        >
        > I find the double occurrence of 'suggested_capacity' in the header
        > comment makes it hard to read.
        >
        > But I do like the idea of making the signature self-documenting. Is there
        > a better header comment that could be used with Ulrich's suggested
        > signature?
        >
        > If anyone has suggestions, please post them soon. We now have the result
        > from the "keep or remove 'make'" poll, and it shows overwhelming support
        > for keeping 'make'. So I'd like to soon run the poll to refine the
        > specification of 'make'.
        >
        > Regards,
        > Roger
        > --
        > Roger Browne - roger@... - Everything Eiffel
        > 19 Eden Park Lancaster LA1 4SJ UK - Phone +44 1524 32428
        >
        >
        > ---------------------------
        >
        > http://www.eiffel-nice.org/
        >
        > --------------------------
        >
        > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.