Loading ...
Sorry, an error occurred while loading the content.

Re: [eiffel-nice-library] Call to vote: 'keep_head', 'keep_tail'

Expand Messages
  • Peter Horan
    ... On being confronted with a vote for this, I feel that keep_head/tail is wrong, because we are doing remove_tail/head. The action is removing, and we are
    Message 1 of 4 , Oct 9, 2000
    • 0 Attachment
      Roger Browne wrote:
      >
      > Arno Wagner wrote:
      > > I would like to propose the following two votes:
      > >
      > > 1) Add the names "keep_head" and "keep_tail" to the features
      > > "head" and "tail", and deprecate the old ones.
      > >
      > > 2) To give consistent names and functionality to features
      > > some vendors already have, add the features "remove_head" and
      > > "remove_tail" (according to my proposal of October, 2.) to
      > > ELKS 2001 (STRING).
      >
      > Ignacio Calvo and Todd King seconded Arno's proposal, so I'll run these
      > votes.

      On being confronted with a vote for this, I feel that keep_head/tail is wrong,
      because we are doing remove_tail/head. The action is removing, and we are
      keeping what is left by default after the action. On the other hand, the
      argument we often would like is the resulting count, which goes with keep_head.
      I have wracked my brain for a better name than those proposed, including
      remove_all_but(n:INTEGER), left(n: INTEGER) (unfortunately a function in VB, or
      this would be better, IMHO). Nothing quite satisfies. So, I'll vote "Abstain
      (not happy either way)".
      --
      Peter Horan School of Computing and Mathematics
      peter@... Deakin University
      +61-3-5227 1234 (Voice) Geelong, Victoria 3217, AUSTRALIA
      +61-3-5227 2028 (FAX) http://www.cm.deakin.edu.au/~peter

      -- The Eiffel guarantee: From specification to implementation
      -- (http://www.cetus-links.org/oo_eiffel.html)
    • Arno Wagner
      ... Please keep in mind that the names keep_head/tail are designed to be the duals to remove_tail/head. The just offer a different perspective: In one case you
      Message 2 of 4 , Oct 10, 2000
      • 0 Attachment
        --- In eiffel-nice-library@egroups.com, Peter Horan <peter@d...>
        wrote:
        > Roger Browne wrote:
        > >
        > > Arno Wagner wrote:
        > > > I would like to propose the following two votes:
        > > >
        > > > 1) Add the names "keep_head" and "keep_tail" to the features
        > > > "head" and "tail", and deprecate the old ones.
        > > >
        > > > 2) To give consistent names and functionality to features
        > > > some vendors already have, add the features "remove_head" and
        > > > "remove_tail" (according to my proposal of October, 2.) to
        > > > ELKS 2001 (STRING).
        > >
        > > Ignacio Calvo and Todd King seconded Arno's proposal, so I'll
        > > run these votes.
        >
        > On being confronted with a vote for this, I feel that
        > keep_head/tail is wrong, because we are doing remove_tail/head.
        > The action is removing, and we are keeping what is left by default
        > after the action. On the other hand, the argument we often would
        > like is the resulting count, which goes with keep_head.
        > I have wracked my brain for a better name than those proposed,
        > including remove_all_but(n:INTEGER), left(n: INTEGER)
        > (unfortunately a function in VB, or this would be better, IMHO).
        > Nothing quite satisfies. So, I'll vote "Abstain
        > (not happy either way)".

        Please keep in mind that the names keep_head/tail are designed
        to be the duals to remove_tail/head. The just offer a different
        perspective:
        In one case you want so keep something specific and remove
        everything else, in the other case you want to remove something
        specific and keep everything else. The names get a lot more
        elegant in this combination. And yes I would like better
        sounding names too, but I think they do the job and are quite
        clear as well. And they _do_ complement their
        "remove" opposites nicely and make it totally clear that these
        functions are related and come in complementary pairs.

        Regards
        Arno

        -------------------------------------------------------------------
        Arno Wagner Dipl. Inform. ETH Zuerich wagner@...
        GnuPG/PGP Key: F0C049F1
        Key Fingerprint: 8C E0 6F A5 CC B1 5A 11 ED C7 AD D2 05 5E BB 6F
        Sig of the week:
        "A distributed system is one in which I cannot get something done
        because a machine I've never heard of is down." --Leslie Lamport
      • Arno Wagner
        ... I think it is close enough, no complaints here. Arno ... Arno Wagner Dipl. Inform. ETH Zuerich wagner@tik.ee.ethz.ch GnuPG/PGP Key: F0C049F1
        Message 3 of 4 , Oct 10, 2000
        • 0 Attachment
          --- In eiffel-nice-library@egroups.com, Roger Browne <egroups@e...>
          wrote:
          > Arno Wagner wrote:
          > > I would like to propose the following two votes:
          > >
          > > 1) Add the names "keep_head" and "keep_tail" to the features
          > > "head" and "tail", and deprecate the old ones.
          > >
          > > 2) To give consistent names and functionality to features
          > > some vendors already have, add the features "remove_head" and
          > > "remove_tail" (according to my proposal of October, 2.) to
          > > ELKS 2001 (STRING).
          >
          > Ignacio Calvo and Todd King seconded Arno's proposal, so I'll
          > run these votes.
          >
          > I'm starting with the Arno's first proposal, which I'm wording like
          > this for the vote:
          >
          > Proposal for class STRING: rename feature 'head' to
          > 'keep_head', and rename feature 'tail' to 'keep_tail'.
          >
          > I realise that's not exactly how Arno worded it, but I think
          > it captures the intent (given that ELKS features are
          > deprecated by being removed from the standard).

          I think it is close enough, no complaints here.

          Arno
          -------------------------------------------------------------------
          Arno Wagner Dipl. Inform. ETH Zuerich wagner@...
          GnuPG/PGP Key: F0C049F1
          Key Fingerprint: 8C E0 6F A5 CC B1 5A 11 ED C7 AD D2 05 5E BB 6F
          Sig of the week:
          "A distributed system is one in which I cannot get something done
          because a machine I've never heard of is down." --Leslie Lamport
        Your message has been successfully submitted and would be delivered to recipients shortly.