Loading ...
Sorry, an error occurred while loading the content.

Shift plus I then a space brings up

Expand Messages
  • yu34801p3jlfr4890q1j
    Dear All I was wondering if anyone could help me with a problem when I try to write the word I . When I try to write a sentence such as I was at... etc, it
    Message 1 of 5 , Jun 10, 2013
    View Source
    • 0 Attachment
      Dear All

      I was wondering if anyone could help me with a problem when I try to write the word "I".

      When I try to write a sentence such as "I was at..." etc, it will produce <i></i> as soon as I press the space bar.

      In my htmlbar.acp I have

      #T=I
      <I></I>

      and the keyboard shortcut is assigned to Ctrl+Alt+I

      I have tried changing the shortcut but whatever I do, Shift+I+space produces <I></I>.

      Can anyone tell me how I can stop this behaviour? Every other keyboard shortcut works fine.

      I am running EditPlus 2.3.1 on Linux Mint 14 under Wine.

      Cliff
    • John Smith
      maybe a work around, use the royal we We were at..... ... [Non-text portions of this message have been removed]
      Message 2 of 5 , Jun 10, 2013
      View Source
      • 0 Attachment
        maybe a work around, use the royal we

        "We were at....."


        :)

        > Dear All
        >
        > I was wondering if anyone could help me with a problem when I try to
        > write the word "I".
        >
        > When I try to write a sentence such as "I was at..." etc, it will
        > produce <i></i> as soon as I press the space bar.
        >
        > In my htmlbar.acp I have
        >
        > #T=I
        > <I></I>
        >
        > and the keyboard shortcut is assigned to Ctrl+Alt+I
        >
        > I have tried changing the shortcut but whatever I do, Shift+I+space
        > produces <I></I>.
        >
        > Can anyone tell me how I can stop this behaviour? Every other keyboard
        > shortcut works fine.
        >
        > I am running EditPlus 2.3.1 on Linux Mint 14 under Wine.
        >
        > Cliff
        >
        >



        [Non-text portions of this message have been removed]
      • yu34801p3jlfr4890q1j
        Oooh, We were at... You must be from near me! That s how we talk here in Lancashire :) But not a solution unfortunately -- anyone else got any ideas? Cliff
        Message 3 of 5 , Jun 10, 2013
        View Source
        • 0 Attachment
          Oooh, "We were at..." You must be from near me! That's how we talk here in Lancashire :)

          But not a solution unfortunately -- anyone else got any ideas?

          Cliff



          --- In editplus@yahoogroups.com, John Smith <john@...> wrote:
          >
          > maybe a work around, use the royal we
          >
          > "We were at....."
          >
          >
          > :)
          >
          > > Dear All
          > >
          > > I was wondering if anyone could help me with a problem when I try to
          > > write the word "I".
          > >
          > > When I try to write a sentence such as "I was at..." etc, it will
          > > produce <i></i> as soon as I press the space bar.
          > >
          > > In my htmlbar.acp I have
          > >
          > > #T=I
          > > <I></I>
          > >
          > > and the keyboard shortcut is assigned to Ctrl+Alt+I
          > >
          > > I have tried changing the shortcut but whatever I do, Shift+I+space
          > > produces <I></I>.
          > >
          > > Can anyone tell me how I can stop this behaviour? Every other keyboard
          > > shortcut works fine.
          > >
          > > I am running EditPlus 2.3.1 on Linux Mint 14 under Wine.
          > >
          > > Cliff
          > >
          > >
          >
          >
          >
          > [Non-text portions of this message have been removed]
          >
        • DZ-Jay
          NOTE: I just realized I sent this message from another account and it was probably rejected. Resent. Ah! The pleasures and pitfalls of auto-complete in
          Message 4 of 5 , Jun 13, 2013
          View Source
          • 0 Attachment
            NOTE: I just realized I sent this message from another account and it was probably rejected. Resent.


            Ah! The pleasures and pitfalls of auto-complete in EditPlus...

            First off, a bit of background: The effect you are seeing is the result of the auto-complete feature of EditPlus. This means that every time you type a word followed by a word boundary, if that word matches a pre-defined shortcut in the document auto-complete file (*.acp), it'll be expanded as defined. In your case, your document is of syntax type "HTML," and the auto-complete definitions are in "htmlbar.acp."

            There are a few ways to avoid this. One is to disable the auto-complete feature. I think there's a setting for this in the preferences, or perhaps a keyword in the syntax file (I forget, sorry, and I'm not on a Windows machine right now to corroborate).

            Another way is to change the shortcut associated with the tag. As you showed,

            -----------
            #T=I
            <I></I>
            -----------

            it means that when the key sequence "I" is encountered (T=I : shortcut sequence), it will be expanded to "<I></I>" (by the way, there should be a "^" in there to denote the cursor insertion point, but I digress). You can change it to something else, say "itl" for "italics," preferably to something that is not as easy to occur in your normal usage--or remove the entry altogether.

            Still, one more way to avoid the automatic expansion is to hit the space-bar with a special modifier key after typing the "I." Now, this modifier key has changed throughout the lifetime of EditPlus, and I'm not sure which it is right now. It used to be the ALT key, but I think it is now the "windows" key (WIN). So, instead of SPACE, try WIN+SPACE. (I asked Sangil repeatedly to change it back, but as far as I know he never did.) This works for all auto-complete shortcuts.

            If you try the last one, please let us know which is the current modifier key.

            Cheers!
            dZ.

            On Jun 10, 2013, at 12:08, yu34801p3jlfr4890q1j <loobyloo@...> wrote:

            > Dear All
            >
            > I was wondering if anyone could help me with a problem when I try to write the word "I".
            >
            > When I try to write a sentence such as "I was at..." etc, it will produce <i></i> as soon as I press the space bar.
            >
            > In my htmlbar.acp I have
            >
            > #T=I
            > <I></I>
            >
            > and the keyboard shortcut is assigned to Ctrl+Alt+I
            >
            > I have tried changing the shortcut but whatever I do, Shift+I+space produces <I></I>.
            >
            > Can anyone tell me how I can stop this behaviour? Every other keyboard shortcut works fine.
            >
            > I am running EditPlus 2.3.1 on Linux Mint 14 under Wine.
            >
            > Cliff
            >
          • Cliff Laine
            On Thu, 13 Jun 2013 10:53:40 -0400 ... Thank you DZ-Jay--I turned off the complete in the preferences and it s stopped it. I m afraid that I haven t
            Message 5 of 5 , Jun 20, 2013
            View Source
            • 0 Attachment
              On Thu, 13 Jun 2013 10:53:40 -0400
              DZ-Jay <dz@...> wrote:

              >
              > Ah! The pleasures and pitfalls of auto-complete in EditPlus...
              >
              > First off, a bit of background: The effect you are seeing is the
              > result of the auto-complete feature of EditPlus. This means that
              > every time you type a word followed by a word boundary, if that word
              > matches a pre-defined shortcut in the document auto-complete file
              > (*.acp), it'll be expanded as defined. In your case, your document
              > is of syntax type "HTML," and the auto-complete definitions are in
              > "htmlbar.acp."
              >
              > There are a few ways to avoid this. One is to disable the
              > auto-complete feature.

              Thank you DZ-Jay--I turned off the complete in the preferences and it's
              stopped it. I'm afraid that I haven't investigated what the modifier
              key is nowadays.

              Thanks for your help--without it I was absolutely stuck!

              Cliff
            Your message has been successfully submitted and would be delivered to recipients shortly.