Loading ...
Sorry, an error occurred while loading the content.

^M

Expand Messages
  • tallstranger
    I just switched from UltraEdit to EditPlus. When I open a previously saved file, I find a ^M at the end of each line. Other files don t have that issue.
    Message 1 of 5 , Mar 5, 2010
    View Source
    • 0 Attachment
      I just switched from UltraEdit to EditPlus. When I open a previously saved file, I find a ^M at the end of each line. Other files don't have that issue. What is ^M and how do I remove them? I tried search and replace with nothing but that removed all carriage returns.

      Thanks!
    • Ron Toland
      Just started using EditPlus. One file has ^M at each carriage return. What is ^M and how do I remove them? thanks. Ron 623.388.8071 [Non-text portions of
      Message 2 of 5 , Mar 5, 2010
      View Source
      • 0 Attachment
        Just started using EditPlus. One file has ^M at each carriage return. What
        is ^M and how do I remove them?

        thanks.

        Ron
        623.388.8071


        [Non-text portions of this message have been removed]
      • DZ-Jay
        ... Hello and welcome! The ^M means an extra Carriage Return at the end of each line. Which program are you using when you see this ^M? The reason that I ask
        Message 3 of 5 , Mar 6, 2010
        View Source
        • 0 Attachment
          On Mar 05, 2010, at 14:59, tallstranger wrote:

          > I just switched from UltraEdit to EditPlus. When I open a previously saved file, I find a ^M at the end of each line. Other files don't have that issue. What is ^M and how do I remove them? I tried search and replace with nothing but that removed all carriage returns.
          >
          > Thanks!

          Hello and welcome!

          The ^M means an extra Carriage Return at the end of each line. Which program are you using when you see this ^M? The reason that I ask is that it is common for people to edit a file in EditPlus and then upload it to a UNIX server. The file is treated by EditPlus as a "DOS" file and then when viewed in "vi" or any other UNIX editor, it has those extraneous Carriage Returns.

          In UNIX, a line delimiter is just a Line Feed character, while in DOS (and Windows) it's a combination of Line Feed and Carriage Return. This is easy to fix by having EditPlus treat the file as UNIX format. Just open the file in EditPlus and select the menu option "Document|File Format (CR/LF)", and choose UNIX from the dialog window, then save the file.

          To truly see what is going on, you could check how EditPlus is interpreting the file. At the bottom of the EditPlus window, in the status bar, there is a field with the file format. It is the 5th field from the left, and it should say, "PC" or "UNIX" for DOS or UNIX file formats, respectively. Make sure that whatever it says matches your expectation of the file. If it is wrong, you can change it as explained above.

          Additionally, EditPlus has an option to automatically fix invalid line delimiters. Go to the Preferences screen, in the Files section, and make sure to tick the box that says, "Check invalid CR/LF, null character when loading." Reload the file in EditPlus. If you get prompted to fix the line endings, accept it. Since you have told EditPlus the proper format of the file, EditPlus will now make sure that line-delimiter-looking character ("\n" or "\r") found after the real sequence it expects, will be removed. Save the file again.

          Let me know if you still help after this.

          dZ.

          --
          Pound! Bang! Bin! Bash! is this a shell script or a Batman comic?!
        • Ron Toland
          Just now getting back to this...thanks for earlier response. I ll try your solution next time I see the ^M issue. Here s a similar one.... When I open one
          Message 4 of 5 , Mar 22, 2010
          View Source
          • 0 Attachment
            Just now getting back to this...thanks for earlier response. I'll try your
            solution next time I see the ^M issue. Here's a similar one....

            When I open one particular file in UltraEdit, it looks fine. In EditPlus,
            the file is displayed as in attachment. I realize the "boxes" are an end of
            line character but don't know how to remove them or simply turn off
            display. I tried your solution for ^M but the app won't let me change the
            format and changing preference as in your suggestion didn't change
            anything. Perhaps it would help to provide a brief explanation of what I'm
            doing...

            EditPlus sits on a Windows terminal server. I write SAS programs in
            EditPlus that I then save/upload to a Unix box. I execute the code in the
            Unix environment and download logs and output files back to the Windows
            server and EditPlus. I may also download the program for changes where the
            process starts all over.

            Once again...thanks for any/all suggestions to help me learn to navigate
            EditPlus.

            Ron

            On Sat, Mar 6, 2010 at 5:44 AM, DZ-Jay <dz@...> wrote:

            >
            >
            >
            > On Mar 05, 2010, at 14:59, tallstranger wrote:
            >
            > > I just switched from UltraEdit to EditPlus. When I open a previously
            > saved file, I find a ^M at the end of each line. Other files don't have that
            > issue. What is ^M and how do I remove them? I tried search and replace with
            > nothing but that removed all carriage returns.
            > >
            > > Thanks!
            >
            > Hello and welcome!
            >
            > The ^M means an extra Carriage Return at the end of each line. Which
            > program are you using when you see this ^M? The reason that I ask is that it
            > is common for people to edit a file in EditPlus and then upload it to a UNIX
            > server. The file is treated by EditPlus as a "DOS" file and then when viewed
            > in "vi" or any other UNIX editor, it has those extraneous Carriage Returns.
            >
            > In UNIX, a line delimiter is just a Line Feed character, while in DOS (and
            > Windows) it's a combination of Line Feed and Carriage Return. This is easy
            > to fix by having EditPlus treat the file as UNIX format. Just open the file
            > in EditPlus and select the menu option "Document|File Format (CR/LF)", and
            > choose UNIX from the dialog window, then save the file.
            >
            > To truly see what is going on, you could check how EditPlus is interpreting
            > the file. At the bottom of the EditPlus window, in the status bar, there is
            > a field with the file format. It is the 5th field from the left, and it
            > should say, "PC" or "UNIX" for DOS or UNIX file formats, respectively. Make
            > sure that whatever it says matches your expectation of the file. If it is
            > wrong, you can change it as explained above.
            >
            > Additionally, EditPlus has an option to automatically fix invalid line
            > delimiters. Go to the Preferences screen, in the Files section, and make
            > sure to tick the box that says, "Check invalid CR/LF, null character when
            > loading." Reload the file in EditPlus. If you get prompted to fix the line
            > endings, accept it. Since you have told EditPlus the proper format of the
            > file, EditPlus will now make sure that line-delimiter-looking character
            > ("\n" or "\r") found after the real sequence it expects, will be removed.
            > Save the file again.
            >
            > Let me know if you still help after this.
            >
            > dZ.
            >
            > --
            > Pound! Bang! Bin! Bash! is this a shell script or a Batman comic?!
            >
            >
            >


            [Non-text portions of this message have been removed]
          • Ron Toland
            Forgot the attachment... ... [Non-text portions of this message have been removed]
            Message 5 of 5 , Mar 22, 2010
            View Source
            • 0 Attachment
              Forgot the attachment...

              On Mon, Mar 22, 2010 at 12:43 PM, Ron Toland <ron.toland.co@...>wrote:

              > Just now getting back to this...thanks for earlier response. I'll try your
              > solution next time I see the ^M issue. Here's a similar one....
              >
              > When I open one particular file in UltraEdit, it looks fine. In EditPlus,
              > the file is displayed as in attachment. I realize the "boxes" are an end of
              > line character but don't know how to remove them or simply turn off
              > display. I tried your solution for ^M but the app won't let me change the
              > format and changing preference as in your suggestion didn't change
              > anything. Perhaps it would help to provide a brief explanation of what I'm
              > doing...
              >
              > EditPlus sits on a Windows terminal server. I write SAS programs in
              > EditPlus that I then save/upload to a Unix box. I execute the code in the
              > Unix environment and download logs and output files back to the Windows
              > server and EditPlus. I may also download the program for changes where the
              > process starts all over.
              >
              > Once again...thanks for any/all suggestions to help me learn to navigate
              > EditPlus.
              >
              > Ron
              >
              > On Sat, Mar 6, 2010 at 5:44 AM, DZ-Jay <dz@...> wrote:
              >
              >>
              >>
              >>
              >> On Mar 05, 2010, at 14:59, tallstranger wrote:
              >>
              >> > I just switched from UltraEdit to EditPlus. When I open a previously
              >> saved file, I find a ^M at the end of each line. Other files don't have that
              >> issue. What is ^M and how do I remove them? I tried search and replace with
              >> nothing but that removed all carriage returns.
              >> >
              >> > Thanks!
              >>
              >> Hello and welcome!
              >>
              >> The ^M means an extra Carriage Return at the end of each line. Which
              >> program are you using when you see this ^M? The reason that I ask is that it
              >> is common for people to edit a file in EditPlus and then upload it to a UNIX
              >> server. The file is treated by EditPlus as a "DOS" file and then when viewed
              >> in "vi" or any other UNIX editor, it has those extraneous Carriage Returns.
              >>
              >> In UNIX, a line delimiter is just a Line Feed character, while in DOS (and
              >> Windows) it's a combination of Line Feed and Carriage Return. This is easy
              >> to fix by having EditPlus treat the file as UNIX format. Just open the file
              >> in EditPlus and select the menu option "Document|File Format (CR/LF)", and
              >> choose UNIX from the dialog window, then save the file.
              >>
              >> To truly see what is going on, you could check how EditPlus is
              >> interpreting the file. At the bottom of the EditPlus window, in the status
              >> bar, there is a field with the file format. It is the 5th field from the
              >> left, and it should say, "PC" or "UNIX" for DOS or UNIX file formats,
              >> respectively. Make sure that whatever it says matches your expectation of
              >> the file. If it is wrong, you can change it as explained above.
              >>
              >> Additionally, EditPlus has an option to automatically fix invalid line
              >> delimiters. Go to the Preferences screen, in the Files section, and make
              >> sure to tick the box that says, "Check invalid CR/LF, null character when
              >> loading." Reload the file in EditPlus. If you get prompted to fix the line
              >> endings, accept it. Since you have told EditPlus the proper format of the
              >> file, EditPlus will now make sure that line-delimiter-looking character
              >> ("\n" or "\r") found after the real sequence it expects, will be removed.
              >> Save the file again.
              >>
              >> Let me know if you still help after this.
              >>
              >> dZ.
              >>
              >> --
              >> Pound! Bang! Bin! Bash! is this a shell script or a Batman comic?!
              >>
              >>
              >>
              >
              >


              [Non-text portions of this message have been removed]
            Your message has been successfully submitted and would be delivered to recipients shortly.