Loading ...
Sorry, an error occurred while loading the content.

EditPlus has a bug.

Expand Messages
  • yanakey@ymail.com
    Hello! When using UTF-8 as default encoding, opening ANSI-files through File menu or by pressing folder icon on toolbar or by pressing Ctlr+O deletes all texts
    Message 1 of 8 , Mar 25, 2009
    • 0 Attachment
      Hello!

      When using UTF-8 as default encoding, opening ANSI-files through File
      menu or by pressing folder icon on toolbar or by pressing Ctlr+O deletes
      all texts in russian, while when drag-n-drop them into EditPlus window
      there is no such problem. I already wrote to the author of EditPlus, but
      he "don't think that it is a bug" and can't "reproduce the problem" on
      his machine. I don't think, that problem related to my machine and there
      is no such problem with EditPlus 2. It seems to me the bug is obvious
      and must to be fixed. I need confirmation of existing problem from other
      users. Here is example files, containing "$var = 'текст,
      текст, текст, текст';" &
      "текст, текст, текст,
      текст":


      * php example
      <http://rapidshare.com/files/213541258/example_ansi.php.html>
      * txt <http://rapidshare.com/files/213541585/example_ansi.txt.html>

      My OS - Win XP SP2 Eng. EditPlus version 3.10 (193).

      P. S. Please, don't suggest to use ANSI as default encoding.




      [Non-text portions of this message have been removed]
    • Marc Leveille
      ... I can confirm this. I m using 3.01 (446) with ANSI as the default encoding, and I can t get the file to open properly using UTF-8 either through the Open
      Message 2 of 8 , Mar 27, 2009
      • 0 Attachment
        > When using UTF-8 as default encoding, opening ANSI-files through File
        > menu or by pressing folder icon on toolbar or by pressing Ctlr+O deletes
        > all texts in russian, while when drag-n-drop them into EditPlus window
        > there is no such problem. I already wrote to the author of EditPlus, but
        > he "don't think that it is a bug" and can't "reproduce the problem" on
        > his machine. I don't think, that problem related to my machine and there
        > is no such problem with EditPlus 2. It seems to me the bug is obvious
        > and must to be fixed. I need confirmation of existing problem from other
        > users.

        I can confirm this. I'm using 3.01 (446) with ANSI as the default
        encoding, and I can't get the file to open properly using UTF-8 either
        through the Open menu or drag-n-drop. After loading, the buffer is
        completely empty. I've tried adding some normal ASCII characters to the
        document in another editor, and still, when I try to use EditPlus to open
        the file, the buffer ends up empty.

        When I switched to UTF-8 as the default encoding, all my text files that
        don't contain web links load as UTF-8 when using drag-n-drop. The Russian
        file, however, loads as ANSI. EditPlus seems to explicitly detect the file
        as ANSI.

        My CMS uses a Chinese language pack encoded in UTF-8, and that loads
        just fine as UTF-8 with the SimHei screen font. I set the screen font to
        Verdana, which supports Cyrillic characters, and that didn't make a
        difference when trying to load the Russian file. I'm not exactly sure how
        UTF-8 encoding works, but this could very well be an encoding detection
        issue. The editor should at least be able to load something in UTF-8 mode,
        even if it were mangled. Instead, all I get is a buffer of zero length
        without any spaces or invisible characters.

        -- Marc
      • Marc Leveille
        ... Replying to myself, here. I should clarify that I was using the TXT file for this test, and that s what gave me the empty buffer. I just tried the PHP
        Message 3 of 8 , Mar 27, 2009
        • 0 Attachment
          > I can confirm this. I'm using 3.01 (446) with ANSI as the default
          > encoding, and I can't get the file to open properly using UTF-8 either
          > through the Open menu or drag-n-drop. After loading, the buffer is
          > completely empty. I've tried adding some normal ASCII characters to the
          > document in another editor, and still, when I try to use EditPlus to open
          > the file, the buffer ends up empty.

          Replying to myself, here. I should clarify that I was using the TXT
          file for this test, and that's what gave me the empty buffer. I just tried
          the PHP file, and the Russian characters are deleted, but the ANSI
          characters show up just fine. So, instead of this:

          $var = 'òåêñò, òåêñò, òåêñò, òåêñò';

          I get this:

          $var = ', , , ';

          -- Marc
        • Perminov Vladimir
          ... How does it work with chinese?
          Message 4 of 8 , Mar 31, 2009
          • 0 Attachment
            > Replying to myself, here. I should clarify that I was using the TXT
            > file for this test, and that's what gave me the empty buffer. I just tried
            > the PHP file, and the Russian characters are deleted, but the ANSI
            > characters show up just fine. So, instead of this:
            >
            > $var = 'текст, текст, текст, текст';
            >
            > I get this:
            >
            > $var = ', , , ';

            How does it work with chinese?
          • Marc Leveille
            ... I cannot understand the simplified Chinese language pack personally, but I ve had no problems at all with characters showing up when loaded as UTF-8 and
            Message 5 of 8 , Mar 31, 2009
            • 0 Attachment
              >> Replying to myself, here. I should clarify that I was using the TXT
              >> file for this test, and that's what gave me the empty buffer. I just
              >> tried
              >> the PHP file, and the Russian characters are deleted, but the ANSI
              >> characters show up just fine.
              >
              > How does it work with chinese?

              I cannot understand the simplified Chinese language pack personally, but
              I've had no problems at all with characters showing up when loaded as UTF-8
              and setting the screen font to SimHei. I also have a traditional Chinese
              language pack, but it is encoded using BIG-5, which is not supported by
              EditPlus, so the characters do not show correctly. With both language
              packs, I have had no problems with missing/disappearing characters or a
              truncated file.

              -- Marc Leveille
            • Perminov Vladimir
              ... no problems means even with russian?
              Message 6 of 8 , Apr 1, 2009
              • 0 Attachment
                > >> Replying to myself, here. I should clarify that I was using the TXT
                > >> file for this test, and that's what gave me the empty buffer. I just
                > >> tried
                > >> the PHP file, and the Russian characters are deleted, but the ANSI
                > >> characters show up just fine.
                > >
                > > How does it work with chinese?
                > With both language
                > packs, I have had no problems with missing/disappearing characters or a
                > truncated file.

                "no problems" means even with russian?
              • Marc Leveille
                ... By both language packs , I meant simplified Chinese (UTF-8) and traditional Chinese (BIG-5). I can t get the Russian files Vladimir provided to work. --
                Message 7 of 8 , Apr 1, 2009
                • 0 Attachment
                  >> > How does it work with chinese?
                  >>
                  >> With both language packs, I have had no problems with
                  >> missing/disappearing characters or a truncated file.
                  >
                  > "no problems" means even with russian?

                  By "both language packs", I meant simplified Chinese (UTF-8) and
                  traditional Chinese (BIG-5). I can't get the Russian files Vladimir
                  provided to work.

                  -- Marc
                • yanakey@ymail.com
                  Thank You for testing! I wrote to support again...
                  Message 8 of 8 , Apr 12, 2009
                  • 0 Attachment
                    Thank You for testing! I wrote to support again...
                  Your message has been successfully submitted and would be delivered to recipients shortly.