Loading ...
Sorry, an error occurred while loading the content.

View source in browser with EditPlus

Expand Messages
  • Proust69
    View source (Ctrl-U) with EditPlus either in FireFox or IE7 does not always work for me. I am not sure if its Vista or something else but every few times it
    Message 1 of 25 , Jun 30, 2007
    • 0 Attachment
      View source (Ctrl-U) with EditPlus either in FireFox or IE7 does not
      always work for me. I am not sure if its Vista or something else but
      every few times it isnt working properly. Any ideas whats wrong here?
    • T Cosmas
      I do not see anywhere where the Ctrl-U setting in FireFox nor IE7 can be set to open the source in EPP. FF open a window with the source in it and IE opens
      Message 2 of 25 , Jul 1, 2007
      • 0 Attachment
        I do not see anywhere where the Ctrl-U setting in FireFox nor IE7 can
        be set to open the source in EPP. FF open a window with the source in
        it and IE opens notepad with the source in it.

        --- In editplus@yahoogroups.com, "Proust69" <proust69@...> wrote:
        >
        > View source (Ctrl-U) with EditPlus either in FireFox or IE7 does not
        > always work for me. I am not sure if its Vista or something else but
        > every few times it isnt working properly. Any ideas whats wrong here?
        >
      • Richard Grevers
        On Mon, 02 Jul 2007 14:04:45 +1200, T Cosmas gave ... For IE: (this is Win2k, not Vista) Tools - Internet options - Programs. Whatever
        Message 3 of 25 , Jul 1, 2007
        • 0 Attachment
          On Mon, 02 Jul 2007 14:04:45 +1200, T Cosmas <t_cosmas@...> gave
          utterance to the following:

          > I do not see anywhere where the Ctrl-U setting in FireFox nor IE7 can
          >
          > be set to open the source in EPP. FF open a window with the source in
          >
          > it and IE opens notepad with the source in it.
          >
          For IE: (this is Win2k, not Vista)
          Tools ->Internet options -> Programs. Whatever you specify as HTML editor
          is used as the source viewer.

          Firefox has extensions which allow you to specify a source viewer (and
          whether it is raw or computed source which is displayed).

          --
          Richard Grevers
          I'm lactose intolerant - I get really annoyed driving behind slow milk
          tankers
        • T Cosmas
          Well, IE7 has the Program to Edit HTML set as EP2; but it opens the Source (Ctrl-U or Ctrl-Shift-U) in NotePad. As for FF, what AddOn? The Web Developer AddOn
          Message 4 of 25 , Jul 2, 2007
          • 0 Attachment
            Well, IE7 has the Program to Edit HTML set as EP2; but it opens the
            Source (Ctrl-U or Ctrl-Shift-U) in NotePad.

            As for FF, what AddOn? The Web Developer AddOn allows me to add
            EditPlus to the View Source menu choices; but nowhere do I see a
            select tion to set Ctrl-U or Ctrl-Shift-U to automatically open EP2.

            --- In editplus@yahoogroups.com, "Richard Grevers" <lists@...> wrote:
            >
            ...
            > >
            > For IE: (this is Win2k, not Vista)
            > Tools ->Internet options -> Programs. Whatever you specify as HTML
            editor
            > is used as the source viewer.
            >
            > Firefox has extensions which allow you to specify a source viewer (and
            > whether it is raw or computed source which is displayed).
            >
            ...
          • DZ-Jay
            ... You ll be happy to hear that a new beta version has been deployed and among the fixes it include is: * Use EditPlus in Internet Explorer didn t work as
            Message 5 of 25 , Jul 3, 2007
            • 0 Attachment
              On Jun 30, 2007, at 18:54, Proust69 wrote:

              > View source (Ctrl-U) with EditPlus either in FireFox or IE7 does not
              > always work for me. I am not sure if its Vista or something else but
              > every few times it isnt working properly. Any ideas whats wrong here?

              You'll be happy to hear that a new beta version has been deployed and
              among the fixes it include is:

              * 'Use EditPlus in Internet Explorer' didn't work as expected in Vista.

              dZ.

              An escalator can never break; it can only become stairs. You will never
              see an "Escalator temporarily out of order" sign, just "Escalator
              temporarily stairs. Sorry for the convenience."

              -- Mitch Hedberg
            • Proust69
              Hi thx for letting me know but I got that new beta version already and the problem remains. In fact EditPlus doesnt show the source (with Ctrl-U in FF) of a
              Message 6 of 25 , Jul 4, 2007
              • 0 Attachment
                Hi thx for letting me know but I got that new beta version already and
                the problem remains. In fact EditPlus doesnt show the source (with
                Ctrl-U in FF) of a webpage when EditPlus is up and running already
                from your desktop. In those cases you have to close EditPlus (which is
                very unproductive and annoying) and then Ctrl-U shortcut will work again.
                M!


                -- In editplus@yahoogroups.com, DZ-Jay <dz@...> wrote:
                >
                >
                > On Jun 30, 2007, at 18:54, Proust69 wrote:
                >
                > > View source (Ctrl-U) with EditPlus either in FireFox or IE7 does not
                > > always work for me. I am not sure if its Vista or something else but
                > > every few times it isnt working properly. Any ideas whats wrong here?
                >
                > You'll be happy to hear that a new beta version has been deployed and
                > among the fixes it include is:
                >
                > * 'Use EditPlus in Internet Explorer' didn't work as expected in Vista.
                >
                > dZ.
                >
                > An escalator can never break; it can only become stairs. You will never
                > see an "Escalator temporarily out of order" sign, just "Escalator
                > temporarily stairs. Sorry for the convenience."
                >
                > -- Mitch Hedberg
                >
              • T Cosmas
                Well, Ctrl-U opens EP from FF when I set the external HTML editor on the about:config page as described previously. I suggest you try that again. There are two
                Message 7 of 25 , Jul 4, 2007
                • 0 Attachment
                  Well, Ctrl-U opens EP from FF when I set the external HTML editor on
                  the about:config page as described previously. I suggest you try that
                  again. There are two lines you need to alter:

                  1. view_source.editor.external = true
                  2. view_source.editor.path = C:\Program Files\EditPlus\editplus.exe
                  or whereever you have EP installed.

                  --- In editplus@yahoogroups.com, "Proust69" <proust69@...> wrote:
                  >
                  > Hi thx for letting me know but I got that new beta version already and
                  > the problem remains. In fact EditPlus doesnt show the source (with
                  > Ctrl-U in FF) of a webpage when EditPlus is up and running already
                  > from your desktop. In those cases you have to close EditPlus (which is
                  > very unproductive and annoying) and then Ctrl-U shortcut will work
                  again.
                  > M!
                  >
                  >
                • Proust69
                  Hi, my problem is that Ctrl-U from FF does NOT show the source in EP when EP is already running and was started before FF. In that case I have to close EP to
                  Message 8 of 25 , Jul 5, 2007
                  • 0 Attachment
                    Hi, my problem is that Ctrl-U from FF does NOT show the source in EP
                    when EP is already running and was started before FF. In that case I
                    have to close EP to make Ctrl-U work again. You can do a test .. first
                    run EP >> then run FF >> then try Ctrl-U >> nobody home :(



                    --- In editplus@yahoogroups.com, "T Cosmas" <t_cosmas@...> wrote:
                    >
                    > Well, Ctrl-U opens EP from FF when I set the external HTML editor on
                    > the about:config page as described previously. I suggest you try that
                    > again. There are two lines you need to alter:
                    >
                    > 1. view_source.editor.external = true
                    > 2. view_source.editor.path = C:\Program Files\EditPlus\editplus.exe
                    > or whereever you have EP installed.
                    >
                    > --- In editplus@yahoogroups.com, "Proust69" <proust69@> wrote:
                    > >
                    > > Hi thx for letting me know but I got that new beta version already and
                    > > the problem remains. In fact EditPlus doesnt show the source (with
                    > > Ctrl-U in FF) of a webpage when EditPlus is up and running already
                    > > from your desktop. In those cases you have to close EditPlus (which is
                    > > very unproductive and annoying) and then Ctrl-U shortcut will work
                    > again.
                    > > M!
                    > >
                    > >
                    >
                  • foofanootoo
                    ... already and ... (which is ... I use this Firefox extension that allows any editor to be designated in the config box from it s main options tab:
                    Message 9 of 25 , Jul 5, 2007
                    • 0 Attachment
                      --- In editplus@yahoogroups.com, "Proust69" <proust69@...> wrote:
                      >
                      > Hi, my problem is that Ctrl-U from FF does NOT show the source in EP
                      > when EP is already running and was started before FF. In that case I
                      > have to close EP to make Ctrl-U work again. You can do a test .. first
                      > run EP >> then run FF >> then try Ctrl-U >> nobody home :(
                      >
                      >
                      >
                      > --- In editplus@yahoogroups.com, "T Cosmas" <t_cosmas@> wrote:
                      > >
                      > > Well, Ctrl-U opens EP from FF when I set the external HTML editor on
                      > > the about:config page as described previously. I suggest you try that
                      > > again. There are two lines you need to alter:
                      > >
                      > > 1. view_source.editor.external = true
                      > > 2. view_source.editor.path = C:\Program Files\EditPlus\editplus.exe
                      > > or whereever you have EP installed.
                      > >
                      > > --- In editplus@yahoogroups.com, "Proust69" <proust69@> wrote:
                      > > >
                      > > > Hi thx for letting me know but I got that new beta version
                      already and
                      > > > the problem remains. In fact EditPlus doesnt show the source (with
                      > > > Ctrl-U in FF) of a webpage when EditPlus is up and running already
                      > > > from your desktop. In those cases you have to close EditPlus
                      (which is
                      > > > very unproductive and annoying) and then Ctrl-U shortcut will work
                      > > again.
                      > > > M!
                      > > >
                      > > >
                      > >
                      >
                      I use this Firefox extension that allows any editor to be designated
                      in the config box from it's main options tab:
                      http://dafizilla.sourceforge.net/viewsourcewith/
                    • foofanootoo
                      ... that ... (forgot to mention) facilitates ctrl + u
                      Message 10 of 25 , Jul 5, 2007
                      • 0 Attachment
                        --- In editplus@yahoogroups.com, "foofanootoo" <foofanoo@...> wrote:
                        >
                        > --- In editplus@yahoogroups.com, "Proust69" <proust69@> wrote:
                        > >
                        > > Hi, my problem is that Ctrl-U from FF does NOT show the source in EP
                        > > when EP is already running and was started before FF. In that case I
                        > > have to close EP to make Ctrl-U work again. You can do a test .. first
                        > > run EP >> then run FF >> then try Ctrl-U >> nobody home :(
                        > >
                        > >
                        > >
                        > > --- In editplus@yahoogroups.com, "T Cosmas" <t_cosmas@> wrote:
                        > > >
                        > > > Well, Ctrl-U opens EP from FF when I set the external HTML editor on
                        > > > the about:config page as described previously. I suggest you try
                        that
                        > > > again. There are two lines you need to alter:
                        > > >
                        > > > 1. view_source.editor.external = true
                        > > > 2. view_source.editor.path = C:\Program Files\EditPlus\editplus.exe
                        > > > or whereever you have EP installed.
                        > > >
                        > > > --- In editplus@yahoogroups.com, "Proust69" <proust69@> wrote:
                        > > > >
                        > > > > Hi thx for letting me know but I got that new beta version
                        > already and
                        > > > > the problem remains. In fact EditPlus doesnt show the source (with
                        > > > > Ctrl-U in FF) of a webpage when EditPlus is up and running already
                        > > > > from your desktop. In those cases you have to close EditPlus
                        > (which is
                        > > > > very unproductive and annoying) and then Ctrl-U shortcut will work
                        > > > again.
                        > > > > M!
                        > > > >
                        > > > >
                        > > >
                        > >
                        > I use this Firefox extension that allows any editor to be designated
                        > in the config box from it's main options tab:
                        > http://dafizilla.sourceforge.net/viewsourcewith/

                        (forgot to mention) > facilitates ctrl + u
                      • Peter Anderson
                        ... Hi! It is quite easy to get EditPlus to work with FireFox: 1. In the URL address bar type about:config (no quotes obviously) and this brings up the FF
                        Message 11 of 25 , Jul 5, 2007
                        • 0 Attachment
                          --- In editplus@yahoogroups.com, "foofanootoo" <foofanoo@...> wrote:
                          >
                          ...
                          > > I use this Firefox extension that allows any editor to be designated
                          > > in the config box from it's main options tab:
                          > > http://dafizilla.sourceforge.net/viewsourcewith/
                          >

                          Hi! It is quite easy to get EditPlus to work with FireFox:
                          1. In the URL address bar type "about:config" (no quotes obviously)
                          and this brings up the FF configuration page.
                          2. Scroll down to the entry " view_source.editor.external" and change
                          the default value ("true") to "false"
                          3. Scroll down to the next entry "view_source.editor.path" and change
                          the value to the path for EditPlus ("C:\Program Files\EditPlus
                          2\editplus.exe" on my PC)
                          4. Close the tab with about:config
                          5. Open another tab with any website and press [Ctrl]+[U] and 'bob's
                          your uncle!!!

                          No plugins needed. Hope that helps.

                          For more information on about:config see:

                          http://kb.mozillazine.org/About:config_entries

                          Regards,
                          Peter
                        • Peter Anderson
                          ... Hi! I don t want to sound grumpy about this but many people (including me) have told you how to setup your about:config file so that you can use an
                          Message 12 of 25 , Jul 6, 2007
                          • 0 Attachment
                            --- In editplus@yahoogroups.com, "Proust69" <proust69@...> wrote:
                            >
                            > Hi, my problem is that Ctrl-U from FF does NOT show the source in EP
                            > when EP is already running and was started before FF. In that case I
                            > have to close EP to make Ctrl-U work again. You can do a test .. first
                            > run EP >> then run FF >> then try Ctrl-U >> nobody home :(
                            >

                            Hi! I don't want to sound grumpy about this but many people
                            (including me) have told you how to setup your about:config file so
                            that you can use an external editor (such as EditPlus) with Firefox's
                            [Ctrl]+[U] keystroke combination - its simple and it works so you must
                            be doing something wrong!

                            Regards,
                            Peter
                          • Richard Grevers
                            On Sat, 07 Jul 2007 16:05:15 +1200, Peter Anderson ... And the OP has said twice that he has done that and it does work - but only if Editplus is not already
                            Message 13 of 25 , Jul 6, 2007
                            • 0 Attachment
                              On Sat, 07 Jul 2007 16:05:15 +1200, Peter Anderson
                              <pjafrombbay@...> gave utterance to the following:

                              > --- In editplus@yahoogroups.com, "Proust69" <proust69@...> wrote:
                              >
                              >>
                              >
                              >> Hi, my problem is that Ctrl-U from FF does NOT show the source in EP
                              >
                              >> when EP is already running and was started before FF. In that case I
                              >
                              >> have to close EP to make Ctrl-U work again. You can do a test .. first
                              >
                              >> run EP >> then run FF >> then try Ctrl-U >> nobody home :(
                              >
                              >>
                              >
                              >
                              > Hi! I don't want to sound grumpy about this but many people
                              >
                              > (including me) have told you how to setup your about:config file so
                              >
                              > that you can use an external editor (such as EditPlus) with Firefox's
                              >
                              > [Ctrl]+[U] keystroke combination - its simple and it works so you must
                              >
                              > be doing something wrong!
                              >
                              And the OP has said twice that he has done that and it does work - but
                              only if Editplus is not already running. Which sounds like some weirdness
                              in DDE configuration on his machine.
                              --
                              Richard Grevers
                              I'm lactose intolerant - I get really annoyed driving behind slow milk
                              tankers
                            • DZ-Jay
                              ... I had that problem once on my development Win2k machine, and after reporting it as a bug and all, it got magically fixed the next time I rebooted the
                              Message 14 of 25 , Jul 7, 2007
                              • 0 Attachment
                                On Jul 7, 2007, at 01:38, Richard Grevers wrote:
                                > And the OP has said twice that he has done that and it does work - but
                                > only if Editplus is not already running. Which sounds like some
                                > weirdness
                                > in DDE configuration on his machine.

                                I had that problem once on my development Win2k machine, and after
                                reporting it as a bug and all, it got "magically" fixed the next time I
                                rebooted the computer. You see, that particular machine is always on,
                                and only gets rebooted after system crashes or critical updates.

                                dZ.

                                --
                                Give a man a fish, he owes you one fish.
                                Teach a man to fish, you give up your monopoly on fisheries.
                              • Peter Anderson
                                ... weirdness ... It works for me whether EP is running or not! Must be lucky I guess! If its a DDE configuration issue then perhaps uninstall both EP and
                                Message 15 of 25 , Jul 7, 2007
                                • 0 Attachment
                                  --- In editplus@yahoogroups.com, "Richard Grevers" <lists@...> wrote:
                                  >
                                  ...
                                  > And the OP has said twice that he has done that and it does work - but
                                  > only if Editplus is not already running. Which sounds like some
                                  weirdness
                                  > in DDE configuration on his machine.
                                  >

                                  It works for me whether EP is running or not! Must be lucky I guess!
                                  If its a "DDE configuration" issue then perhaps uninstall both EP and
                                  FF and re-install might help.

                                  Peter
                                • xof
                                  Hi, The feature Find in directory / Find in files do not work anymore on my computer. I use this feature regularly and I appreciate its efficiency, but for
                                  Message 16 of 25 , Jul 8, 2007
                                  • 0 Attachment
                                    Hi,



                                    The feature Find in directory / Find in files do not work anymore on my
                                    computer.

                                    I use this feature regularly and I appreciate its efficiency, but for some
                                    reason, it has ceased to work. It returns me old results, as if Editplus was
                                    searching in a deprecated, cached version of the files.

                                    Does anyone else have this problem too or is it just me ?



                                    Regards

                                    Christophe



                                    [Non-text portions of this message have been removed]
                                  • DZ-Jay
                                    Hello: This may sound like a very stupid question, but it needs to be asked: Have you made sure the directory selected is the one you want, and that include
                                    Message 17 of 25 , Jul 8, 2007
                                    • 0 Attachment
                                      Hello:
                                      This may sound like a very stupid question, but it needs to be asked:
                                      Have you made sure the directory selected is the one you want, and that
                                      "include subdirectories" is ticked too?

                                      dZ.

                                      On Jul 8, 2007, at 05:38, xof wrote:

                                      > Hi,
                                      >
                                      >
                                      >
                                      > The feature Find in directory / Find in files do not work anymore on my
                                      > computer.
                                      >
                                      > I use this feature regularly and I appreciate its efficiency, but for
                                      > some
                                      > reason, it has ceased to work. It returns me old results, as if
                                      > Editplus was
                                      > searching in a deprecated, cached version of the files.
                                      >
                                      > Does anyone else have this problem too or is it just me ?
                                      >
                                      >
                                      >
                                      > Regards
                                      >
                                      > Christophe
                                      >
                                      >
                                      >
                                      > [Non-text portions of this message have been removed]
                                      >
                                      >
                                      >
                                      > http://www.editplus.com
                                      > Yahoo! Groups Links
                                      >
                                      >
                                      >
                                      >
                                    • xof
                                      Yes, I did check this. The only checked box is include subfolders . I get a result that points me to a file that is effectively in the relevant directory.
                                      Message 18 of 25 , Jul 8, 2007
                                      • 0 Attachment
                                        Yes, I did check this. The only checked box is "include subfolders".

                                        I get a result that points me to a file that is effectively in the relevant
                                        directory. When I follow the "link" by double clicking the result line, it
                                        opens the right file on the line number as mentioned in the result but the
                                        line content do not match with what the result says. Actually the searched
                                        word was on this line some time ago but I deleted it (this was the goal of
                                        my search). It is as if Editplus was searching in a previous version of my
                                        file and was not able to actualize the search.

                                        Closing the file and restarting Editplus does not solve the problem.

                                        christophe



                                        _____

                                        From: editplus@yahoogroups.com [mailto:editplus@yahoogroups.com] On Behalf
                                        Of DZ-Jay
                                        Sent: dimanche 8 juillet 2007 12:37
                                        To: editplus@yahoogroups.com
                                        Subject: Re: [edit+] "Find in Files" returns me deprecated results



                                        Hello:
                                        This may sound like a very stupid question, but it needs to be asked:
                                        Have you made sure the directory selected is the one you want, and that
                                        "include subdirectories" is ticked too?

                                        dZ.

                                        On Jul 8, 2007, at 05:38, xof wrote:

                                        > Hi,
                                        >
                                        >
                                        >
                                        > The feature Find in directory / Find in files do not work anymore on my
                                        > computer.
                                        >
                                        > I use this feature regularly and I appreciate its efficiency, but for
                                        > some
                                        > reason, it has ceased to work. It returns me old results, as if
                                        > Editplus was
                                        > searching in a deprecated, cached version of the files.
                                        >
                                        > Does anyone else have this problem too or is it just me ?
                                        >
                                        >
                                        >
                                        > Regards
                                        >
                                        > Christophe
                                        >
                                        >
                                        >
                                        > [Non-text portions of this message have been removed]
                                        >
                                        >
                                        >
                                        > http://www.editplus <http://www.editplus.com> .com
                                        > Yahoo! Groups Links
                                        >
                                        >
                                        >
                                        >





                                        [Non-text portions of this message have been removed]
                                      • xof
                                        After some research, I can precise a bit my problem: Editplus does not return deprecated results as I first thought, but results with wrong line numbers.
                                        Message 19 of 25 , Jul 8, 2007
                                        • 0 Attachment
                                          After some research, I can precise a bit my problem:

                                          Editplus does not return "deprecated" results as I first thought, but
                                          results with wrong line numbers. Sometimes when I follow the "link" of a
                                          result (by double clicking a result line), I don't find the text I am
                                          searching on the suggested line. Instead it is located 10 or 20 lines upper
                                          in the file. This is quite disturbing. I don't have any clue about the
                                          origin of this offset.



                                          christophe





                                          _____

                                          From: editplus@yahoogroups.com [mailto:editplus@yahoogroups.com] On Behalf
                                          Of xof
                                          Sent: dimanche 8 juillet 2007 13:03
                                          To: editplus@yahoogroups.com
                                          Subject: RE: [edit+] "Find in Files" returns me deprecated results



                                          Yes, I did check this. The only checked box is "include subfolders".

                                          I get a result that points me to a file that is effectively in the relevant
                                          directory. When I follow the "link" by double clicking the result line, it
                                          opens the right file on the line number as mentioned in the result but the
                                          line content do not match with what the result says. Actually the searched
                                          word was on this line some time ago but I deleted it (this was the goal of
                                          my search). It is as if Editplus was searching in a previous version of my
                                          file and was not able to actualize the search.

                                          Closing the file and restarting Editplus does not solve the problem.

                                          christophe

                                          _____

                                          From: editplus@yahoogroup <mailto:editplus%40yahoogroups.com> s.com
                                          [mailto:editplus@yahoogroup <mailto:editplus%40yahoogroups.com> s.com] On
                                          Behalf
                                          Of DZ-Jay
                                          Sent: dimanche 8 juillet 2007 12:37
                                          To: editplus@yahoogroup <mailto:editplus%40yahoogroups.com> s.com
                                          Subject: Re: [edit+] "Find in Files" returns me deprecated results

                                          Hello:
                                          This may sound like a very stupid question, but it needs to be asked:
                                          Have you made sure the directory selected is the one you want, and that
                                          "include subdirectories" is ticked too?

                                          dZ.

                                          On Jul 8, 2007, at 05:38, xof wrote:

                                          > Hi,
                                          >
                                          >
                                          >
                                          > The feature Find in directory / Find in files do not work anymore on my
                                          > computer.
                                          >
                                          > I use this feature regularly and I appreciate its efficiency, but for
                                          > some
                                          > reason, it has ceased to work. It returns me old results, as if
                                          > Editplus was
                                          > searching in a deprecated, cached version of the files.
                                          >
                                          > Does anyone else have this problem too or is it just me ?
                                          >
                                          >
                                          >
                                          > Regards
                                          >
                                          > Christophe
                                          >
                                          >
                                          >
                                          > [Non-text portions of this message have been removed]
                                          >
                                          >
                                          >
                                          > http://www.editplus <http://www.editplus <http://www.editplus.com> .com>
                                          .com
                                          > Yahoo! Groups Links
                                          >
                                          >
                                          >
                                          >

                                          [Non-text portions of this message have been removed]





                                          [Non-text portions of this message have been removed]
                                        • Damien
                                          ... Hi Christophe, As far as I know, Editplus *does* keep a keyword index in memory after you give it a Find in files operation. However I d be very
                                          Message 20 of 25 , Jul 8, 2007
                                          • 0 Attachment
                                            > Hi,
                                            >
                                            > The feature Find in directory / Find in files do not work anymore on my
                                            > computer.
                                            >
                                            > I use this feature regularly and I appreciate its efficiency, but for some
                                            > reason, it has ceased to work. It returns me old results, as if Editplus was
                                            > searching in a deprecated, cached version of the files.
                                            >
                                            > Does anyone else have this problem too or is it just me ?
                                            >
                                            > Regards
                                            >
                                            > Christophe
                                            >

                                            Hi Christophe,

                                            As far as I know, Editplus *does* keep a keyword index in memory after
                                            you give it a "Find in files" operation. However I'd be very surprised
                                            if it kept this index around after a restart. Try restarting EP and
                                            see if that helps. Otherwise, have a poke around for any
                                            likely-sounding files in the Editplus folder.

                                            And, as someone else said, make ultra-sure you're telling it to search
                                            the right place, with the correct file extensions, with "Current file
                                            directory" and "Subfolders" checkboxes ticked appropriately :)

                                            -Damien
                                          • damienie22
                                            Hmm, this is really interesting. Is it only happening in one particular directory? Is there a consistent line-offset amount? Or is the amount based on previous
                                            Message 21 of 25 , Jul 8, 2007
                                            • 0 Attachment
                                              Hmm, this is really interesting. Is it only happening in one
                                              particular directory? Is there a consistent line-offset amount? Or is
                                              the amount based on previous edits you've made to the file?
                                              Investigating more like this should help you decide what kind of
                                              problem it is.

                                              This sounds like an interesting bug, but I can't remember ever coming
                                              across it, and I'm a very frequent user of FIF. One thing -- do you
                                              have "Auto-reload on file modification" checked? If so, maybe the file
                                              is somehow changing between your search and your click on a results
                                              line. Another problem could be the word wrap setting (although, if EP
                                              isn't doing what you expect in this case, it's probably a bug, too :)

                                              Ultimately as a 'fix', I would try reinstalling Editplus. But then you
                                              might never find out what the problem was :) Have another look around
                                              your EP directory for the cache I mentioned -- maybe it is being
                                              persisted to disk somehow.



                                              --- In editplus@yahoogroups.com, "xof" <xofm1@...> wrote:
                                              >
                                              > After some research, I can precise a bit my problem:
                                              >
                                              > Editplus does not return "deprecated" results as I first thought, but
                                              > results with wrong line numbers. Sometimes when I follow the "link" of a
                                              > result (by double clicking a result line), I don't find the text I am
                                              > searching on the suggested line. Instead it is located 10 or 20
                                              lines upper
                                              > in the file. This is quite disturbing. I don't have any clue about the
                                              > origin of this offset.
                                              >
                                              >
                                              >
                                              > christophe
                                              >
                                              >
                                              >
                                              >
                                              >
                                              > _____
                                              >
                                              > From: editplus@yahoogroups.com [mailto:editplus@yahoogroups.com] On
                                              Behalf
                                              > Of xof
                                              > Sent: dimanche 8 juillet 2007 13:03
                                              > To: editplus@yahoogroups.com
                                              > Subject: RE: [edit+] "Find in Files" returns me deprecated results
                                              >
                                              >
                                              >
                                              > Yes, I did check this. The only checked box is "include subfolders".
                                              >
                                              > I get a result that points me to a file that is effectively in the
                                              relevant
                                              > directory. When I follow the "link" by double clicking the result
                                              line, it
                                              > opens the right file on the line number as mentioned in the result
                                              but the
                                              > line content do not match with what the result says. Actually the
                                              searched
                                              > word was on this line some time ago but I deleted it (this was the
                                              goal of
                                              > my search). It is as if Editplus was searching in a previous version
                                              of my
                                              > file and was not able to actualize the search.
                                              >
                                              > Closing the file and restarting Editplus does not solve the problem.
                                              >
                                              > christophe
                                              >
                                              > _____
                                              >
                                              > From: editplus@yahoogroup <mailto:editplus%40yahoogroups.com> s.com
                                              > [mailto:editplus@yahoogroup <mailto:editplus%40yahoogroups.com>
                                              s.com] On
                                              > Behalf
                                              > Of DZ-Jay
                                              > Sent: dimanche 8 juillet 2007 12:37
                                              > To: editplus@yahoogroup <mailto:editplus%40yahoogroups.com> s.com
                                              > Subject: Re: [edit+] "Find in Files" returns me deprecated results
                                              >
                                              > Hello:
                                              > This may sound like a very stupid question, but it needs to be asked:
                                              > Have you made sure the directory selected is the one you want, and that
                                              > "include subdirectories" is ticked too?
                                              >
                                              > dZ.
                                              >
                                              > On Jul 8, 2007, at 05:38, xof wrote:
                                              >
                                              > > Hi,
                                              > >
                                              > >
                                              > >
                                              > > The feature Find in directory / Find in files do not work anymore
                                              on my
                                              > > computer.
                                              > >
                                              > > I use this feature regularly and I appreciate its efficiency, but for
                                              > > some
                                              > > reason, it has ceased to work. It returns me old results, as if
                                              > > Editplus was
                                              > > searching in a deprecated, cached version of the files.
                                              > >
                                              > > Does anyone else have this problem too or is it just me ?
                                              > >
                                              > >
                                              > >
                                              > > Regards
                                              > >
                                              > > Christophe
                                              > >
                                              > >
                                              > >
                                              > > [Non-text portions of this message have been removed]
                                              > >
                                              > >
                                              > >
                                              > > http://www.editplus <http://www.editplus <http://www.editplus.com>
                                              .com>
                                              > .com
                                              > > Yahoo! Groups Links
                                              > >
                                              > >
                                              > >
                                              > >
                                              >
                                              > [Non-text portions of this message have been removed]
                                              >
                                              >
                                              >
                                              >
                                              >
                                              > [Non-text portions of this message have been removed]
                                              >
                                            • DZ-Jay
                                              ... Could it be that the lines are wrapped and so they appear to display lower? dZ. -- The mills of the gods grind slowly, yet the grind exceeding small.
                                              Message 22 of 25 , Jul 8, 2007
                                              • 0 Attachment
                                                On Jul 8, 2007, at 11:07, xof wrote:

                                                > After some research, I can precise a bit my problem:
                                                >
                                                > Editplus does not return "deprecated" results as I first thought, but
                                                > results with wrong line numbers. Sometimes when I follow the "link" of
                                                > a
                                                > result (by double clicking a result line), I don't find the text I am
                                                > searching on the suggested line. Instead it is located 10 or 20 lines
                                                > upper
                                                > in the file. This is quite disturbing. I don't have any clue about the
                                                > origin of this offset.
                                                >

                                                Could it be that the lines are "wrapped" and so they appear to display
                                                lower?

                                                dZ.

                                                --
                                                "The mills of the gods grind slowly, yet the grind exceeding small."
                                              • Bronius Motekaitis
                                                If you can post some same files with orig file names (and it s not sensitive data), someone can try to reproduce the issue.. I ve never had problems with
                                                Message 23 of 25 , Jul 8, 2007
                                                • 0 Attachment
                                                  If you can post some same files with orig file names (and it's not sensitive
                                                  data), someone can try to reproduce the issue.. I've never had problems
                                                  with find-in-files, not even in massively huge data files.

                                                  -bronius


                                                  On 7/8/07, DZ-Jay <dz@...> wrote:
                                                  >
                                                  >
                                                  > On Jul 8, 2007, at 11:07, xof wrote:
                                                  >
                                                  > > After some research, I can precise a bit my problem:
                                                  > >
                                                  > > Editplus does not return "deprecated" results as I first thought, but
                                                  > > results with wrong line numbers. Sometimes when I follow the "link" of
                                                  > > a
                                                  > > result (by double clicking a result line), I don't find the text I am
                                                  > > searching on the suggested line. Instead it is located 10 or 20 lines
                                                  > > upper
                                                  > > in the file. This is quite disturbing. I don't have any clue about the
                                                  > > origin of this offset.
                                                  > >
                                                  >
                                                  > Could it be that the lines are "wrapped" and so they appear to display
                                                  > lower?
                                                  >
                                                  > dZ.
                                                  >
                                                  > --
                                                  > "The mills of the gods grind slowly, yet the grind exceeding small."
                                                  >
                                                  >
                                                  >


                                                  [Non-text portions of this message have been removed]
                                                • xof
                                                  Hi, Thank you for your ideas. I finally found the answer: the line numbers in the search result are wrong because some of my files are no more in correct PC
                                                  Message 24 of 25 , Jul 9, 2007
                                                  • 0 Attachment
                                                    Hi,



                                                    Thank you for your ideas. I finally found the answer: the line numbers in
                                                    the search result are wrong because some of my files are no more in correct
                                                    PC text format.

                                                    I tried to delete line after line in one of the erroneous files and noted
                                                    that only some special lines were counting for two in the search result
                                                    window. At the end I got a very simple file with a single corrupted line.
                                                    Selecting this line was producing a weird move of the cursor. I could
                                                    reproduce the corruption with "Duplicate the line" but not with a
                                                    copy-paste.

                                                    With an hexadecimal editor, I saw that the mysterious double counting chars
                                                    were something like "0D0A" i.e. Carriage Return / Line Feed chars...

                                                    In Tools/Preferences./Files., I then discovered that the checkbox "Check
                                                    invalid CR/CF, null character when loading" was not (anymore?) checked! I
                                                    reloaded my file and got an alert: "The text contains invalid CR/CF. Do you
                                                    want to convert?".

                                                    That solved the problem and restored my confidence in Editplus.

                                                    I wonder how a regular file can become corrupted like this.

                                                    Regards

                                                    Christophe



                                                    [Non-text portions of this message have been removed]
                                                  • cyberfunkr
                                                    Checking the EditPlus website, there is a semi-recent patch out that covers this. DATE: 2007-07-10 BUILD: 514 This is a patch file to fix the bugs of EditPlus
                                                    Message 25 of 25 , Aug 7, 2007
                                                    • 0 Attachment
                                                      Checking the EditPlus website, there is a semi-recent patch out that
                                                      covers this.

                                                      DATE: 2007-07-10
                                                      BUILD: 514

                                                      This is a patch file to fix the bugs of EditPlus v2.31

                                                      .
                                                      .
                                                      .
                                                      * 'Save wrapped lines with CR/LF' option could corrupt file.
                                                      .
                                                      .
                                                      .

                                                      Apply the patch and see if this fixes your file.

                                                      /Cyberfunkr

                                                      --- In editplus@yahoogroups.com, "xof" <xofm1@...> wrote:
                                                      >
                                                      > Hi,
                                                      >
                                                      >
                                                      >
                                                      > Thank you for your ideas. I finally found the answer: the line
                                                      numbers in
                                                      > the search result are wrong because some of my files are no more in
                                                      correct
                                                      > PC text format.
                                                      >
                                                      > I tried to delete line after line in one of the erroneous files and
                                                      noted
                                                      > that only some special lines were counting for two in the search result
                                                      > window. At the end I got a very simple file with a single corrupted
                                                      line.
                                                      > Selecting this line was producing a weird move of the cursor. I could
                                                      > reproduce the corruption with "Duplicate the line" but not with a
                                                      > copy-paste.
                                                      >
                                                      > With an hexadecimal editor, I saw that the mysterious double
                                                      counting chars
                                                      > were something like "0D0A" i.e. Carriage Return / Line Feed chars...
                                                      >
                                                      > In Tools/Preferences./Files., I then discovered that the checkbox "Check
                                                      > invalid CR/CF, null character when loading" was not (anymore?)
                                                      checked! I
                                                      > reloaded my file and got an alert: "The text contains invalid CR/CF.
                                                      Do you
                                                      > want to convert?".
                                                      >
                                                      > That solved the problem and restored my confidence in Editplus.
                                                      >
                                                      > I wonder how a regular file can become corrupted like this.
                                                      >
                                                      > Regards
                                                      >
                                                      > Christophe
                                                      >
                                                      >
                                                      >
                                                      > [Non-text portions of this message have been removed]
                                                      >
                                                    Your message has been successfully submitted and would be delivered to recipients shortly.