Loading ...
Sorry, an error occurred while loading the content.

Re: displaying multilingual UTF-8 file

Expand Messages
  • J
    Have you tried the Reload as option on the Document menu? There are some options there that seem relevant (EditPlus might not be reading the file as UTF-8).
    Message 1 of 6 , Oct 1, 2003
    • 0 Attachment
      Have you tried the "Reload as" option on the Document menu?
      There are some options there that seem relevant (EditPlus
      might not be reading the file as UTF-8). There's also some
      language options if you hit the button with three dots, but
      I don't think they'll help.

      Sadly I have no experience with multi-lingual files, so you
      may find my suggestion as un-helpful as the previous
      poster's.

      > Date: Tue, 30 Sep 2003 15:29:07 +0300
      > From: "Pavils Jurjans" <pavils@...>
      > Subject: displaying multilingual UTF-8 file
      >
      > Hallo,
      >
      > I have trouble displaying a multilingual UTF-8 text file
      > in EditPlus 2.11 (2096). It has characters in Latvian and
      > Russian. All chars are displayed fine in Notepad. When
      > opened in EditPlus, the russian characters display as
      > '????'s, while latvian chars are Ok. This inconsistency
      > may be connected with the fact that my system codepage is
      > Latvian. However, if it is unicode UTF-8 file, EditPlus
      > should display also those russian chars, just like
      > Notepad is. Trouble is, this bug hinders me to use
      > EditPlus for this particular tast further, because when
      > the document is saved, actual '?????'s are saved, not the
      > russian chars they were before opening the document.
      > Also, it should be noted that when russian characters are
      > entered from keyboard, they are not interpreted correctly
      > as unicode characters, but rather than upper-ANSI
      > charcodes. This can be avoided by using copy-paste from,
      > say, word, yet it's a bug, too.
      >
      > I can provide testcase txt file upon request.
      >
      > thanks,
      >
      > -- Pavils

      ________________________________________________________________________
      Want to chat instantly with your online friends? Get the FREE Yahoo!
      Messenger http://mail.messenger.yahoo.co.uk
    • brozerhood
      No, unfortunately that doesn t help either. I am strongly convined it s a bug. -- Pavils
      Message 2 of 6 , Oct 1, 2003
      • 0 Attachment
        No, unfortunately that doesn't help either. I am strongly convined
        it's a bug.

        -- Pavils

        --- In editplus@yahoogroups.com, J <banana@l...> wrote:
        > Have you tried the "Reload as" option on the Document menu?
        > There are some options there that seem relevant (EditPlus
        > might not be reading the file as UTF-8). There's also some
        > language options if you hit the button with three dots, but
        > I don't think they'll help.
        >
        > Sadly I have no experience with multi-lingual files, so you
        > may find my suggestion as un-helpful as the previous
        > poster's.
      • J
        I ve had remarkably quick responses to bugs submitted to support@editplus.com so it s definitely worth sending your problem there. ...
        Message 3 of 6 , Oct 2, 2003
        • 0 Attachment
          I've had remarkably quick responses to bugs submitted to
          support@... so it's definitely worth sending your
          problem there.

          > Date: Wed, 01 Oct 2003 11:11:24 -0000
          > From: "brozerhood" <pavils@...>
          > Subject: Re: displaying multilingual UTF-8 file
          >
          > No, unfortunately that doesn't help either. I am strongly
          > convined
          > it's a bug.
          >
          > -- Pavils

          ________________________________________________________________________
          Want to chat instantly with your online friends? Get the FREE Yahoo!
          Messenger http://mail.messenger.yahoo.co.uk
        Your message has been successfully submitted and would be delivered to recipients shortly.