Loading ...
Sorry, an error occurred while loading the content.
 

displaying multilingual UTF-8 file

Expand Messages
  • Pavils Jurjans
    Hallo, I have trouble displaying a multilingual UTF-8 text file in EditPlus 2.11 (2096). It has characters in Latvian and Russian. All chars are displayed fine
    Message 1 of 6 , Sep 30, 2003
      Hallo,

      I have trouble displaying a multilingual UTF-8 text file in EditPlus 2.11 (2096). It has characters in Latvian and Russian. All chars are displayed fine in Notepad. When opened in EditPlus, the russian characters display as '????'s, while latvian chars are Ok. This inconsistency may be connected with the fact that my system codepage is Latvian. However, if it is unicode UTF-8 file, EditPlus should display also those russian chars, just like Notepad is. Trouble is, this bug hinders me to use EditPlus for this particular tast further, because when the document is saved, actual '?????'s are saved, not the russian chars they were before opening the document. Also, it should be noted that when russian characters are entered from keyboard, they are not interpreted correctly as unicode characters, but rather than upper-ANSI charcodes. This can be avoided by using copy-paste from, say, word, yet it's a bug, too.

      I can provide testcase txt file upon request.

      thanks,

      -- Pavils

      [Non-text portions of this message have been removed]
    • Alexandru Savescu
      Try setting the language from Language Combo Box in the Fonts page from General Preferences area. Alex ... From: Pavils Jurjans [mailto:pavils@mailbox.riga.lv]
      Message 2 of 6 , Sep 30, 2003
        Try setting the language from Language Combo Box in the Fonts page from
        General Preferences area.

        Alex

        -----Original Message-----
        From: Pavils Jurjans [mailto:pavils@...]
        Sent: Tuesday, September 30, 2003 3:29 PM
        To: editplus@yahoogroups.com
        Subject: [edit+] displaying multilingual UTF-8 file

        Hallo,

        I have trouble displaying a multilingual UTF-8 text file in EditPlus
        2.11 (2096). It has characters in Latvian and Russian. All chars are
        displayed fine in Notepad. When opened in EditPlus, the russian
        characters display as '????'s, while latvian chars are Ok. This
        inconsistency may be connected with the fact that my system codepage is
        Latvian. However, if it is unicode UTF-8 file, EditPlus should display
        also those russian chars, just like Notepad is. Trouble is, this bug
        hinders me to use EditPlus for this particular tast further, because
        when the document is saved, actual '?????'s are saved, not the russian
        chars they were before opening the document. Also, it should be noted
        that when russian characters are entered from keyboard, they are not
        interpreted correctly as unicode characters, but rather than upper-ANSI
        charcodes. This can be avoided by using copy-paste from, say, word, yet
        it's a bug, too.

        I can provide testcase txt file upon request.

        thanks,

        -- Pavils

        [Non-text portions of this message have been removed]



        Yahoo! Groups Sponsor
        ADVERTISEMENT




        http://www.editplus.com
        http://groups.yahoo.com/group/editplus

        Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.
      • brozerhood
        Alex, Apparently you didn t care to check out the porblem I am talking about, nor that hindered you to throw me the fix . I am not a newbie to be suggested
        Message 3 of 6 , Sep 30, 2003
          Alex,

          Apparently you didn't care to check out the porblem I am talking
          about, nor that hindered you to throw me the "fix". I am not a
          newbie to be suggested irrelevant solutions to fix buggy behaviour.

          The language combo box is provided to allow use of upper-ANSI
          cahracters (hex code from 80 to ff) for international language
          chars. That space is too small to allocate all the non-ASCII
          characters from more than just few languages. Thus, there is no way
          to fit both Latvian and Russian special characters in a one single-
          byte encoding. This is why Unicode comes handy. In UTF-8 files, that
          language combo box actually should have no meaning whatsoever,
          because all the non-ASCII characters are encoded in multi-byte
          sequences and should be displayed according to their unicode value.
          Just like Notepad in Windows XP handles unicode text files (both
          Unicode encoding and UTF-8).

          These mulitlingual text files are not just a fancy of mine. I live
          in a region, where web applications in three languages is not a rare
          case. I have to work with multilingual TXT, XML, ASP, HTML, etc.
          files. The base of the webservers and applications understanding
          unicode and UTF-8 encoding is growing, and I'd be happy to stick
          with EditPlus in my everyday programming needs also in future.

          Regards,

          -- Pavils


          --- In editplus@yahoogroups.com, "Alexandru Savescu" <alex@r...>
          wrote:
          > Try setting the language from Language Combo Box in the Fonts page
          from
          > General Preferences area.
          >
          > Alex
          >
          > -----Original Message-----
          > From: Pavils Jurjans [mailto:pavils@m...]
          > Sent: Tuesday, September 30, 2003 3:29 PM
          > To: editplus@yahoogroups.com
          > Subject: [edit+] displaying multilingual UTF-8 file
          >
          > Hallo,
          >
          > I have trouble displaying a multilingual UTF-8 text file in
          EditPlus

          <snip>
        • J
          Have you tried the Reload as option on the Document menu? There are some options there that seem relevant (EditPlus might not be reading the file as UTF-8).
          Message 4 of 6 , Oct 1, 2003
            Have you tried the "Reload as" option on the Document menu?
            There are some options there that seem relevant (EditPlus
            might not be reading the file as UTF-8). There's also some
            language options if you hit the button with three dots, but
            I don't think they'll help.

            Sadly I have no experience with multi-lingual files, so you
            may find my suggestion as un-helpful as the previous
            poster's.

            > Date: Tue, 30 Sep 2003 15:29:07 +0300
            > From: "Pavils Jurjans" <pavils@...>
            > Subject: displaying multilingual UTF-8 file
            >
            > Hallo,
            >
            > I have trouble displaying a multilingual UTF-8 text file
            > in EditPlus 2.11 (2096). It has characters in Latvian and
            > Russian. All chars are displayed fine in Notepad. When
            > opened in EditPlus, the russian characters display as
            > '????'s, while latvian chars are Ok. This inconsistency
            > may be connected with the fact that my system codepage is
            > Latvian. However, if it is unicode UTF-8 file, EditPlus
            > should display also those russian chars, just like
            > Notepad is. Trouble is, this bug hinders me to use
            > EditPlus for this particular tast further, because when
            > the document is saved, actual '?????'s are saved, not the
            > russian chars they were before opening the document.
            > Also, it should be noted that when russian characters are
            > entered from keyboard, they are not interpreted correctly
            > as unicode characters, but rather than upper-ANSI
            > charcodes. This can be avoided by using copy-paste from,
            > say, word, yet it's a bug, too.
            >
            > I can provide testcase txt file upon request.
            >
            > thanks,
            >
            > -- Pavils

            ________________________________________________________________________
            Want to chat instantly with your online friends? Get the FREE Yahoo!
            Messenger http://mail.messenger.yahoo.co.uk
          • brozerhood
            No, unfortunately that doesn t help either. I am strongly convined it s a bug. -- Pavils
            Message 5 of 6 , Oct 1, 2003
              No, unfortunately that doesn't help either. I am strongly convined
              it's a bug.

              -- Pavils

              --- In editplus@yahoogroups.com, J <banana@l...> wrote:
              > Have you tried the "Reload as" option on the Document menu?
              > There are some options there that seem relevant (EditPlus
              > might not be reading the file as UTF-8). There's also some
              > language options if you hit the button with three dots, but
              > I don't think they'll help.
              >
              > Sadly I have no experience with multi-lingual files, so you
              > may find my suggestion as un-helpful as the previous
              > poster's.
            • J
              I ve had remarkably quick responses to bugs submitted to support@editplus.com so it s definitely worth sending your problem there. ...
              Message 6 of 6 , Oct 2, 2003
                I've had remarkably quick responses to bugs submitted to
                support@... so it's definitely worth sending your
                problem there.

                > Date: Wed, 01 Oct 2003 11:11:24 -0000
                > From: "brozerhood" <pavils@...>
                > Subject: Re: displaying multilingual UTF-8 file
                >
                > No, unfortunately that doesn't help either. I am strongly
                > convined
                > it's a bug.
                >
                > -- Pavils

                ________________________________________________________________________
                Want to chat instantly with your online friends? Get the FREE Yahoo!
                Messenger http://mail.messenger.yahoo.co.uk
              Your message has been successfully submitted and would be delivered to recipients shortly.