Loading ...
Sorry, an error occurred while loading the content.

Aaaargh! Indenting problem with user acp and stx files

Expand Messages
  • shuttermutt <shuttermutt@yahoo.com>
    WARNING! I answered my own question while typing this plea for help. I posted anyway just in case someone else comes across the same problem and searches here.
    Message 1 of 1 , Feb 1, 2003
    • 0 Attachment
      WARNING! I answered my own question while typing this plea for help.
      I posted anyway just in case someone else comes across the same
      problem and searches here. With that in mind, here's my original
      message...

      Greets all! I've been writing custom acp, stx, ctl and related files
      for a language I'm using. This language is very similar to C in that
      it uses curly braces, similar statements and so forth.

      So far I've had great luck getting EditPlus to do what I need, but
      I've recently run across a gritty little problem that's making me
      bonkers. You see, if I create a new C/C++ file with E+ and
      type "if " then I get the curly braces, parenthesis and all that
      jazz from the acp file. Cool.

      Now, if I position my cursor directly after the opening curly brace
      and press the Enter key, not only do I get an indention, but it's
      relative to the curly brace. Perfect! Like this...

      if (1 != 74)
      {<-- press enter here
      <-- cursor goes here
      }

      My acp file is a direct copy of the "if" keyword from the cpp.acl
      file. When I type "if" after creating a file based on my stx/acp
      definitions, I don't get the magic indentation. I get this...

      if (1 != 74)
      {<-- press enter here
      <-- cursor goes here
      }

      Aaaargh! I've tried everything I can think of. I notice that the
      C/C++ and Perl file types all do what they're supposed to, but I
      just can't get mine to act the same. Can anyone think of what I
      might be doing wrong?

      DOH! DOH! DOH!

      I figured it out. Silly ol' bear! I forgot to set up the open, close
      and terminator characters on the Tab/Indent tab in the Preferences
      dialog for my file type. Problem solved!

      -Greg
    Your message has been successfully submitted and would be delivered to recipients shortly.