Loading ...
Sorry, an error occurred while loading the content.

Re: [dxatlas] Re: CW Skimmer 1.6

Expand Messages
  • Iain MacDonnell - N6ML
    On a somewhat related note.... One of the biggest frustrations I have at the moment is when using CW Skimmer to track DX pileups, when I transmit (on my K3 (w/
    Message 1 of 14 , Mar 22, 2010
    • 0 Attachment
      On a somewhat related note....

      One of the biggest frustrations I have at the moment is when using CW
      Skimmer to track DX pileups, when I transmit (on my K3 (w/
      LP-Pan/LP-Bridge), skimmer jumps to the TX frequency, and sticks there for a
      while after I stop sending, then jumps back to the RX frequency. In the
      window between returning to RX, and skimmer catching up, the waterfall is
      offset by the QSX, making it a pain to line up the guy sending "5NN TU" with
      the actual frequency that I want to call on next.

      I haven't spent a lot of time trying to diagnose this yet - I assume the K3
      must be reporting the TX frequency in response to some polling command....
      but wondering if anyone has come up with a solution for this...?

      ~Iain / N6ML



      On Mon, Mar 22, 2010 at 12:05 PM, Greg - AB7R <ab7r@...> wrote:

      >
      >
      > A program called RigSync by Ed Russell handles split with Skimmer. It has a
      > checkbox
      > that when checked clicking a new freq on Skimmer will change the TX freq
      > but leave
      > the RX freq alone.
      >
      > Still. It would be nice to have as part of DXL since it does just about
      > everything
      > else. :)
      >
      > -------------------------
      > 73,
      > Greg - AB7R
      > Whidbey Island WA
      > NA-065
      >
      >
      > On Mon Mar 22 11:48 , "Dave AA6YQ" sent:
      >
      > >
      > > Alex, several users of CW Skimmer and DXLab have requested this
      > capability.
      > >
      > >
      > >
      > >Does CW Skimmer know whether the transceiver is in Split mode? If so, your
      >
      > >
      > >providing a "use VFO B when in split mode" option would benefit all CW
      > >
      > >Skimmer users.
      > >
      > >
      > >
      > >If you don't plan to implement this capability, I will -- in combination
      > >
      > >with DXLab Commander, which does know whether or not the transceiver is in
      >
      > >
      > >Split mode. Please let me know one way or the other.
      > >
      > >
      > >
      > >Nice to work you from 8P9RY...
      > >
      > >
      > >
      > >73,
      > >
      > >
      > >
      > >Dave, AA6YQ
      > >
      > >
      > >
      > >-----Original Message-----
      > >
      > >From: dxatlas_group@yahoogroups.com <dxatlas_group%40yahoogroups.com>[mailto:
      > dxatlas_group@yahoogroups.com <dxatlas_group%40yahoogroups.com>]On
      > >
      > >Behalf Of jim_w8wy
      > >
      > >Sent: Monday, March 22, 2010 2:35 PM
      > >
      > >To: dxatlas_group@yahoogroups.com <dxatlas_group%40yahoogroups.com>
      > >
      > >Subject: [dxatlas] Re: CW Skimmer 1.6
      > >
      > >
      > >
      > >Thanks Alex for the update:
      > >
      > >Any chance for VFOB selection? Many users, I think, beside nyself use VFOB
      >
      > >
      > >in split mode to find a clear frequency or to clamp on the last station
      > >
      > >called in pile-ups while we have VFOA on the DX signal; using all filters
      > >
      > >possible to hear him. 73, Jim w8wy
      > >
      > >
      > >
      > >--- In dxatlas_group@yahoogroups.com <dxatlas_group%40yahoogroups.com>,
      > "alshovk" <alshovk@...> wrote:
      > >
      > >>
      > >
      > >> CW Skimmer 1.6 has been released. New in this version:
      > >
      > >>
      > >
      > >> - improved frequency calibration;
      > >
      > >> - improved CQ/DE detection;
      > >
      > >> - a few bug fixes.
      > >
      > >>
      > >
      > >> The upgrade is free for the registered users, all other users have a new
      >
      > >
      > >30-day trial period.
      > >
      > >>
      > >
      > >> 73 Alex VE3NEA
      > >
      > >>
      > >
      > >
      > >
      > >[Non-text portions of this message have been removed]
      > >
      > >
      > >
      > >
      > >
      > >
      > >
      > >
      > >
      > >
      > >
      > >
      > >
      > >
      > >
      > >
      > >
      > >
      > >
      > >
      > >
      > >
      > >
      >
      >
      >
      >


      [Non-text portions of this message have been removed]
    • Dave AA6YQ
      Sounds like the OmniRig built into Skimmer is polling too slowly. Try reducing the polling interval to 100 ms. 73, Dave, AA6YQ ... From: dseven@dseven.org
      Message 2 of 14 , Mar 22, 2010
      • 0 Attachment
        Sounds like the OmniRig built into Skimmer is polling too slowly. Try
        reducing the polling interval to 100 ms.

        73,

        Dave, AA6YQ


        -----Original Message-----
        From: dseven@... [mailto:dseven@...]On Behalf Of Iain
        MacDonnell - N6ML
        Sent: Monday, March 22, 2010 3:13 PM
        To: dxatlas_group@yahoogroups.com
        Cc: Dave AA6YQ
        Subject: Re: [dxatlas] Re: CW Skimmer 1.6



        On a somewhat related note....

        One of the biggest frustrations I have at the moment is when using CW
        Skimmer to track DX pileups, when I transmit (on my K3 (w/
        LP-Pan/LP-Bridge), skimmer jumps to the TX frequency, and sticks there for a
        while after I stop sending, then jumps back to the RX frequency. In the
        window between returning to RX, and skimmer catching up, the waterfall is
        offset by the QSX, making it a pain to line up the guy sending "5NN TU" with
        the actual frequency that I want to call on next.

        I haven't spent a lot of time trying to diagnose this yet - I assume the K3
        must be reporting the TX frequency in response to some polling command....
        but wondering if anyone has come up with a solution for this...?

        ~Iain / N6ML




        On Mon, Mar 22, 2010 at 12:05 PM, Greg - AB7R <ab7r@...> wrote:


        A program called RigSync by Ed Russell handles split with Skimmer. It has
        a checkbox
        that when checked clicking a new freq on Skimmer will change the TX freq
        but leave
        the RX freq alone.

        Still. It would be nice to have as part of DXL since it does just about
        everything
        else. :)

        -------------------------
        73,
        Greg - AB7R
        Whidbey Island WA
        NA-065


        On Mon Mar 22 11:48 , "Dave AA6YQ" sent:



        >
        > Alex, several users of CW Skimmer and DXLab have requested this
        capability.
        >
        >
        >
        >Does CW Skimmer know whether the transceiver is in Split mode? If so,
        your
        >
        >providing a "use VFO B when in split mode" option would benefit all CW
        >
        >Skimmer users.
        >
        >
        >
        >If you don't plan to implement this capability, I will -- in combination
        >
        >with DXLab Commander, which does know whether or not the transceiver is
        in
        >
        >Split mode. Please let me know one way or the other.
        >
        >
        >
        >Nice to work you from 8P9RY...
        >
        >
        >
        >73,
        >
        >
        >
        >Dave, AA6YQ
        >
        >
        >
        >-----Original Message-----
        >
        >From: dxatlas_group@yahoogroups.com
        [mailto:dxatlas_group@yahoogroups.com]On
        >
        >Behalf Of jim_w8wy
        >
        >Sent: Monday, March 22, 2010 2:35 PM
        >
        >To: dxatlas_group@yahoogroups.com
        >
        >Subject: [dxatlas] Re: CW Skimmer 1.6
        >
        >
        >
        >Thanks Alex for the update:
        >
        >Any chance for VFOB selection? Many users, I think, beside nyself use
        VFOB
        >
        >in split mode to find a clear frequency or to clamp on the last station
        >
        >called in pile-ups while we have VFOA on the DX signal; using all filters
        >
        >possible to hear him. 73, Jim w8wy
        >
        >
        >
        >--- In dxatlas_group@yahoogroups.com, "alshovk" <alshovk@...> wrote:
        >
        >>
        >
        >> CW Skimmer 1.6 has been released. New in this version:
        >
        >>
        >
        >> - improved frequency calibration;
        >
        >> - improved CQ/DE detection;
        >
        >> - a few bug fixes.
        >
        >>
        >
        >> The upgrade is free for the registered users, all other users have a
        new
        >
        >30-day trial period.
        >
        >>
        >
        >> 73 Alex VE3NEA
        >
        >>
        >
        >
        >
        >[Non-text portions of this message have been removed]
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >






        [Non-text portions of this message have been removed]
      • Iain MacDonnell - N6ML
        Polling intervals really just exacerbate the problem - my question has more to do with why the jump the TX frequency happens at all... Looking closer, using a
        Message 3 of 14 , Mar 22, 2010
        • 0 Attachment
          Polling intervals really just exacerbate the problem - my question has
          more to do with why the jump the TX frequency happens at all...

          Looking closer, using a serial port monitor, I see Skimmer sending
          FA, FB and IF commands to the K3. The only thing that changes when I
          transmit (in split mode), is the 't' bit in the IF response (which
          shows that the rig is TXing). The FA and FB response do not change.

          In RX:

          FA;
          FA00010115000;
          FB;
          FB00010117700;
          IF;
          IF00010115000 -000000 0003001001;


          In TX:

          FA;
          FA00010115000;
          FB;
          FB00010117700;
          IF;
          IF00010115000 -000000 0013001001;


          So, the question is, why does Skimmer jump to the VFO B frequency when
          it sees that the K3 is TXing, and can that be suppressed somehow?

          ~Iain / N6ML



          On 3/22/10 12:55 PM, Dave AA6YQ wrote:
          > Sounds like the OmniRig built into Skimmer is polling too slowly. Try
          > reducing the polling interval to 100 ms.
          > 73,
          > Dave, AA6YQ
          > -----Original Message-----
          > *From:* dseven@... [mailto:dseven@...]*On Behalf Of *Iain
          > MacDonnell - N6ML
          > *Sent:* Monday, March 22, 2010 3:13 PM
          > *To:* dxatlas_group@yahoogroups.com
          > *Cc:* Dave AA6YQ
          > *Subject:* Re: [dxatlas] Re: CW Skimmer 1.6
          >
          >
          > On a somewhat related note....
          >
          > One of the biggest frustrations I have at the moment is when using CW
          > Skimmer to track DX pileups, when I transmit (on my K3 (w/
          > LP-Pan/LP-Bridge), skimmer jumps to the TX frequency, and sticks there
          > for a while after I stop sending, then jumps back to the RX frequency.
          > In the window between returning to RX, and skimmer catching up, the
          > waterfall is offset by the QSX, making it a pain to line up the guy
          > sending "5NN TU" with the actual frequency that I want to call on next.
          >
          > I haven't spent a lot of time trying to diagnose this yet - I assume the
          > K3 must be reporting the TX frequency in response to some polling
          > command.... but wondering if anyone has come up with a solution for this...?
          >
          > ~Iain / N6ML
          >
          >
          >
          > On Mon, Mar 22, 2010 at 12:05 PM, Greg - AB7R <ab7r@...
          > <mailto:ab7r@...>> wrote:
          >
          > A program called RigSync by Ed Russell handles split with Skimmer.
          > It has a checkbox
          > that when checked clicking a new freq on Skimmer will change the TX
          > freq but leave
          > the RX freq alone.
          >
          > Still. It would be nice to have as part of DXL since it does just
          > about everything
          > else. :)
          >
          > -------------------------
          > 73,
          > Greg - AB7R
          > Whidbey Island WA
          > NA-065
          >
          >
          > On Mon Mar 22 11:48 , "Dave AA6YQ" sent:
          >
          >
          > >
          > > Alex, several users of CW Skimmer and DXLab have requested this
          > capability.
          > >
          > >
          > >
          > >Does CW Skimmer know whether the transceiver is in Split mode? If
          > so, your
          > >
          > >providing a "use VFO B when in split mode" option would benefit
          > all CW
          > >
          > >Skimmer users.
          > >
          > >
          > >
          > >If you don't plan to implement this capability, I will -- in
          > combination
          > >
          > >with DXLab Commander, which does know whether or not the
          > transceiver is in
          > >
          > >Split mode. Please let me know one way or the other.
          > >
          > >
          > >
          > >Nice to work you from 8P9RY...
          > >
          > >
          > >
          > >73,
          > >
          > >
          > >
          > >Dave, AA6YQ
          > >
          > >
          > >
          > >-----Original Message-----
          > >
          > >From: dxatlas_group@yahoogroups.com
          > <mailto:dxatlas_group%40yahoogroups.com>
          > [mailto:dxatlas_group@yahoogroups.com
          > <mailto:dxatlas_group%40yahoogroups.com>]On
          > >
          > >Behalf Of jim_w8wy
          > >
          > >Sent: Monday, March 22, 2010 2:35 PM
          > >
          > >To: dxatlas_group@yahoogroups.com
          > <mailto:dxatlas_group%40yahoogroups.com>
          > >
          > >Subject: [dxatlas] Re: CW Skimmer 1.6
          > >
          > >
          > >
          > >Thanks Alex for the update:
          > >
          > >Any chance for VFOB selection? Many users, I think, beside nyself
          > use VFOB
          > >
          > >in split mode to find a clear frequency or to clamp on the last
          > station
          > >
          > >called in pile-ups while we have VFOA on the DX signal; using all
          > filters
          > >
          > >possible to hear him. 73, Jim w8wy
          > >
          > >
          > >
          > >--- In dxatlas_group@yahoogroups.com
          > <mailto:dxatlas_group%40yahoogroups.com>, "alshovk" <alshovk@...>
          > wrote:
          > >
          > >>
          > >
          > >> CW Skimmer 1.6 has been released. New in this version:
          > >
          > >>
          > >
          > >> - improved frequency calibration;
          > >
          > >> - improved CQ/DE detection;
          > >
          > >> - a few bug fixes.
          > >
          > >>
          > >
          > >> The upgrade is free for the registered users, all other users
          > have a new
          > >
          > >30-day trial period.
          > >
          > >>
          > >
          > >> 73 Alex VE3NEA
          > >
          > >>
          > >
          > >
          > >
          > >[Non-text portions of this message have been removed]
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          >
          >
          >
          >
          >
        • Alex, VE3NEA
          Hi Iain, To find out what is going on between the radio and CW Skimmer, you can enable logging in OmniRig. To do so, stop OmniRig add the following lines to
          Message 4 of 14 , Mar 22, 2010
          • 0 Attachment
            Hi Iain,

            To find out what is going on between the radio and CW Skimmer, you can
            enable logging in OmniRig. To do so, stop OmniRig add the following lines to
            the OmniRig.ini file:

            [Debug]
            Log=1

            With these commands in the ini file, OmniRig generates the OmniRig.log file
            upon exit. The log shows not only the data coming in and out, but also how
            OmniRig interprets these data.

            73 Alex VE3NEA



            ----- Original Message -----
            From: "Iain MacDonnell - N6ML" <ar@...>
            To: <dxatlas_group@yahoogroups.com>
            Cc: "Dave AA6YQ" <aa6yq@...>
            Sent: Monday, March 22, 2010 3:12 PM
            Subject: Re: [dxatlas] Re: CW Skimmer 1.6


            > On a somewhat related note....
            >
            > One of the biggest frustrations I have at the moment is when using CW
            > Skimmer to track DX pileups, when I transmit (on my K3 (w/
            > LP-Pan/LP-Bridge), skimmer jumps to the TX frequency, and sticks there for
            > a
            > while after I stop sending, then jumps back to the RX frequency. In the
            > window between returning to RX, and skimmer catching up, the waterfall is
            > offset by the QSX, making it a pain to line up the guy sending "5NN TU"
            > with
            > the actual frequency that I want to call on next.
            >
            > I haven't spent a lot of time trying to diagnose this yet - I assume the
            > K3
            > must be reporting the TX frequency in response to some polling command....
            > but wondering if anyone has come up with a solution for this...?
            >
            > ~Iain / N6ML
          • Alex, VE3NEA
            Hi Jim, This could be achieved by creating a new ini file for your radio, with the VfoA and VfoB commands swapped. You would then switch between VFO A and VFO
            Message 5 of 14 , Mar 22, 2010
            • 0 Attachment
              Hi Jim,

              This could be achieved by creating a new ini file for your radio, with the
              VfoA and VfoB commands swapped. You would then switch between VFO A and VFO
              B by selecting either the standard or modified ini file. Such files already
              exist for some radios and can be easily created for others. See also my
              reply to Dave's AA6YQ posting.

              73 Alex VE3NEA



              ----- Original Message -----

              Thanks Alex for the update:
              Any chance for VFOB selection? Many users, I think, beside nyself use VFOB
              in split mode to find a clear frequency or to clamp on the last station
              called in pile-ups while we have VFOA on the DX signal; using all filters
              possible to hear him. 73, Jim w8wy
            • Iain MacDonnell - N6ML
              HI Alex, In the log, I see this when I go into TX: 22:57:03.098 RIG1 reply received:
              Message 6 of 14 , Mar 22, 2010
              • 0 Attachment
                HI Alex,

                In the log, I see this when I go into TX:

                22:57:03.098 RIG1 reply received:
                4946303030313031313530303020202020202D3030303030302030303133303031303231203B
                22:57:03.098 RIG1 status changed: pmTx enabled
                22:57:03.098 RIG1 status changed: pmVfoBA enabled
                22:57:03.098 RIG1 sending status command: 46413B
                22:57:03.098 RIG1 data sent
                22:57:03.098 RIG1 data sent

                and on return to RX:

                22:57:05.726 RIG1 reply received:
                4946303030313031313530303020202020202D3030303030302030303033303031303231203B
                22:57:05.727 RIG1 status changed: pmRx enabled
                22:57:05.727 RIG1 status changed: pmVfoAB enabled
                22:57:05.727 RIG1 sending status command: 46413B
                22:57:05.727 RIG1 data sent
                22:57:05.727 RIG1 data sent


                I'm not sure what exactly "pmVfoAB" signifies, but seems to always be
                "enabled", so it still seems to be the TX status that causes Skimmer to jump
                the the VFO B frequency... ?

                ~Iain / N6ML


                On Mon, Mar 22, 2010 at 10:49 PM, Alex, VE3NEA <alshovk@...> wrote:

                >
                >
                > Hi Iain,
                >
                > To find out what is going on between the radio and CW Skimmer, you can
                > enable logging in OmniRig. To do so, stop OmniRig add the following lines
                > to
                > the OmniRig.ini file:
                >
                > [Debug]
                > Log=1
                >
                > With these commands in the ini file, OmniRig generates the OmniRig.log file
                >
                > upon exit. The log shows not only the data coming in and out, but also how
                > OmniRig interprets these data.
                >
                > 73 Alex VE3NEA
                >
                >
                > ----- Original Message -----
                > From: "Iain MacDonnell - N6ML" <ar@... <ar%40dseven.org>>
                > To: <dxatlas_group@yahoogroups.com <dxatlas_group%40yahoogroups.com>>
                > Cc: "Dave AA6YQ" <aa6yq@... <aa6yq%40ambersoft.com>>
                > Sent: Monday, March 22, 2010 3:12 PM
                > Subject: Re: [dxatlas] Re: CW Skimmer 1.6
                >
                > > On a somewhat related note....
                > >
                > > One of the biggest frustrations I have at the moment is when using CW
                > > Skimmer to track DX pileups, when I transmit (on my K3 (w/
                > > LP-Pan/LP-Bridge), skimmer jumps to the TX frequency, and sticks there
                > for
                > > a
                > > while after I stop sending, then jumps back to the RX frequency. In the
                > > window between returning to RX, and skimmer catching up, the waterfall is
                > > offset by the QSX, making it a pain to line up the guy sending "5NN TU"
                > > with
                > > the actual frequency that I want to call on next.
                > >
                > > I haven't spent a lot of time trying to diagnose this yet - I assume the
                > > K3
                > > must be reporting the TX frequency in response to some polling
                > command....
                > > but wondering if anyone has come up with a solution for this...?
                > >
                > > ~Iain / N6ML
                >
                >
                >


                [Non-text portions of this message have been removed]
              • Iain MacDonnell - N6ML
                Oops .. I didn t read closely enough .. the first one is pmVfoBA!! Interesting... Poking around in the Elecraft K3.ini now... maybe I can fudge something in
                Message 7 of 14 , Mar 22, 2010
                • 0 Attachment
                  Oops .. I didn't read closely enough .. the first one is pmVfoBA!!
                  Interesting...

                  Poking around in the "Elecraft K3.ini" now... maybe I can fudge something
                  in here...

                  ~Iain / N6ML


                  On Mon, Mar 22, 2010 at 11:03 PM, Iain MacDonnell - N6ML <ar@...>wrote:

                  >
                  > HI Alex,
                  >
                  > In the log, I see this when I go into TX:
                  >
                  > 22:57:03.098 RIG1 reply received:
                  > 4946303030313031313530303020202020202D3030303030302030303133303031303231203B
                  > 22:57:03.098 RIG1 status changed: pmTx enabled
                  > 22:57:03.098 RIG1 status changed: pmVfoBA enabled
                  > 22:57:03.098 RIG1 sending status command: 46413B
                  > 22:57:03.098 RIG1 data sent
                  > 22:57:03.098 RIG1 data sent
                  >
                  > and on return to RX:
                  >
                  > 22:57:05.726 RIG1 reply received:
                  > 4946303030313031313530303020202020202D3030303030302030303033303031303231203B
                  > 22:57:05.727 RIG1 status changed: pmRx enabled
                  > 22:57:05.727 RIG1 status changed: pmVfoAB enabled
                  > 22:57:05.727 RIG1 sending status command: 46413B
                  > 22:57:05.727 RIG1 data sent
                  > 22:57:05.727 RIG1 data sent
                  >
                  >
                  > I'm not sure what exactly "pmVfoAB" signifies, but seems to always be
                  > "enabled", so it still seems to be the TX status that causes Skimmer to jump
                  > the the VFO B frequency... ?
                  >
                  > ~Iain / N6ML
                  >
                  >
                  >
                  > On Mon, Mar 22, 2010 at 10:49 PM, Alex, VE3NEA <alshovk@...>wrote:
                  >
                  >>
                  >>
                  >> Hi Iain,
                  >>
                  >> To find out what is going on between the radio and CW Skimmer, you can
                  >> enable logging in OmniRig. To do so, stop OmniRig add the following lines
                  >> to
                  >> the OmniRig.ini file:
                  >>
                  >> [Debug]
                  >> Log=1
                  >>
                  >> With these commands in the ini file, OmniRig generates the OmniRig.log
                  >> file
                  >> upon exit. The log shows not only the data coming in and out, but also how
                  >>
                  >> OmniRig interprets these data.
                  >>
                  >> 73 Alex VE3NEA
                  >>
                  >>
                  >> ----- Original Message -----
                  >> From: "Iain MacDonnell - N6ML" <ar@... <ar%40dseven.org>>
                  >> To: <dxatlas_group@yahoogroups.com <dxatlas_group%40yahoogroups.com>>
                  >> Cc: "Dave AA6YQ" <aa6yq@... <aa6yq%40ambersoft.com>>
                  >> Sent: Monday, March 22, 2010 3:12 PM
                  >> Subject: Re: [dxatlas] Re: CW Skimmer 1.6
                  >>
                  >> > On a somewhat related note....
                  >> >
                  >> > One of the biggest frustrations I have at the moment is when using CW
                  >> > Skimmer to track DX pileups, when I transmit (on my K3 (w/
                  >> > LP-Pan/LP-Bridge), skimmer jumps to the TX frequency, and sticks there
                  >> for
                  >> > a
                  >> > while after I stop sending, then jumps back to the RX frequency. In the
                  >> > window between returning to RX, and skimmer catching up, the waterfall
                  >> is
                  >> > offset by the QSX, making it a pain to line up the guy sending "5NN TU"
                  >> > with
                  >> > the actual frequency that I want to call on next.
                  >> >
                  >> > I haven't spent a lot of time trying to diagnose this yet - I assume the
                  >>
                  >> > K3
                  >> > must be reporting the TX frequency in response to some polling
                  >> command....
                  >> > but wondering if anyone has come up with a solution for this...?
                  >> >
                  >> > ~Iain / N6ML
                  >>
                  >>
                  >>
                  >
                  >


                  [Non-text portions of this message have been removed]
                • Iain MacDonnell - N6ML
                  Incase anyone s interested; in my Elecraft K3.ini , I changed: Flag17=(............................0.0.1.....)|pmVfoAB
                  Message 8 of 14 , Mar 22, 2010
                  • 0 Attachment
                    Incase anyone's interested; in my "Elecraft K3.ini", I changed:

                    Flag17=(............................0.0.1.....)|pmVfoAB
                    Flag18=(............................0.1.1.....)|pmVfoBA
                    Flag19=(............................1.0.1.....)|pmVfoBA
                    Flag20=(............................1.1.1.....)|pmVfoAB

                    to:

                    Flag17=(............................0.0.1.....)|pmVfoAB
                    Flag18=(............................0.1.1.....)|pmVfoBA
                    Flag19=(............................1.0.1.....)|pmVfoAB
                    Flag20=(............................1.1.1.....)|pmVfoBA

                    I'm not sure what that logic was for switching to "receive on VFO B,
                    transmit on VFO A" when transmitting (Flag19) and back on receive (Flag17)
                    when in split mode, but I doesn't make sense to me. The change seems to do
                    what I want, with no adverse side-effects so-far.

                    Thanks for the nudge in the right direction, Alex!

                    As a side-note, there are two "Flag21"s in my K3 file - looks like a bug?

                    ~Iain / N6ML




                    On Mon, Mar 22, 2010 at 11:06 PM, Iain MacDonnell - N6ML <ar@...>wrote:

                    >
                    > Oops .. I didn't read closely enough .. the first one is pmVfoBA!!
                    > Interesting...
                    >
                    > Poking around in the "Elecraft K3.ini" now... maybe I can fudge something
                    > in here...
                    >
                    > ~Iain / N6ML
                    >
                    >
                    >
                    > On Mon, Mar 22, 2010 at 11:03 PM, Iain MacDonnell - N6ML <ar@...>wrote:
                    >
                    >>
                    >> HI Alex,
                    >>
                    >> In the log, I see this when I go into TX:
                    >>
                    >> 22:57:03.098 RIG1 reply received:
                    >> 4946303030313031313530303020202020202D3030303030302030303133303031303231203B
                    >> 22:57:03.098 RIG1 status changed: pmTx enabled
                    >> 22:57:03.098 RIG1 status changed: pmVfoBA enabled
                    >> 22:57:03.098 RIG1 sending status command: 46413B
                    >> 22:57:03.098 RIG1 data sent
                    >> 22:57:03.098 RIG1 data sent
                    >>
                    >> and on return to RX:
                    >>
                    >> 22:57:05.726 RIG1 reply received:
                    >> 4946303030313031313530303020202020202D3030303030302030303033303031303231203B
                    >> 22:57:05.727 RIG1 status changed: pmRx enabled
                    >> 22:57:05.727 RIG1 status changed: pmVfoAB enabled
                    >> 22:57:05.727 RIG1 sending status command: 46413B
                    >> 22:57:05.727 RIG1 data sent
                    >> 22:57:05.727 RIG1 data sent
                    >>
                    >>
                    >> I'm not sure what exactly "pmVfoAB" signifies, but seems to always be
                    >> "enabled", so it still seems to be the TX status that causes Skimmer to jump
                    >> the the VFO B frequency... ?
                    >>
                    >> ~Iain / N6ML
                    >>
                    >>
                    >>
                    >> On Mon, Mar 22, 2010 at 10:49 PM, Alex, VE3NEA <alshovk@...>wrote:
                    >>
                    >>>
                    >>>
                    >>> Hi Iain,
                    >>>
                    >>> To find out what is going on between the radio and CW Skimmer, you can
                    >>> enable logging in OmniRig. To do so, stop OmniRig add the following lines
                    >>> to
                    >>> the OmniRig.ini file:
                    >>>
                    >>> [Debug]
                    >>> Log=1
                    >>>
                    >>> With these commands in the ini file, OmniRig generates the OmniRig.log
                    >>> file
                    >>> upon exit. The log shows not only the data coming in and out, but also
                    >>> how
                    >>> OmniRig interprets these data.
                    >>>
                    >>> 73 Alex VE3NEA
                    >>>
                    >>>
                    >>> ----- Original Message -----
                    >>> From: "Iain MacDonnell - N6ML" <ar@... <ar%40dseven.org>>
                    >>> To: <dxatlas_group@yahoogroups.com <dxatlas_group%40yahoogroups.com>>
                    >>> Cc: "Dave AA6YQ" <aa6yq@... <aa6yq%40ambersoft.com>>
                    >>> Sent: Monday, March 22, 2010 3:12 PM
                    >>> Subject: Re: [dxatlas] Re: CW Skimmer 1.6
                    >>>
                    >>> > On a somewhat related note....
                    >>> >
                    >>> > One of the biggest frustrations I have at the moment is when using CW
                    >>> > Skimmer to track DX pileups, when I transmit (on my K3 (w/
                    >>> > LP-Pan/LP-Bridge), skimmer jumps to the TX frequency, and sticks there
                    >>> for
                    >>> > a
                    >>> > while after I stop sending, then jumps back to the RX frequency. In the
                    >>> > window between returning to RX, and skimmer catching up, the waterfall
                    >>> is
                    >>> > offset by the QSX, making it a pain to line up the guy sending "5NN TU"
                    >>>
                    >>> > with
                    >>> > the actual frequency that I want to call on next.
                    >>> >
                    >>> > I haven't spent a lot of time trying to diagnose this yet - I assume
                    >>> the
                    >>> > K3
                    >>> > must be reporting the TX frequency in response to some polling
                    >>> command....
                    >>> > but wondering if anyone has come up with a solution for this...?
                    >>> >
                    >>> > ~Iain / N6ML
                    >>>
                    >>>
                    >>>
                    >>
                    >>
                    >


                    [Non-text portions of this message have been removed]
                  • Alex, VE3NEA
                    Hi Iain, The pmVfoAB flag indicates that the currently used VFO is VfoA, and a switch between TX and RX would switch the radio to VfoB. It looks like most of
                    Message 9 of 14 , Mar 22, 2010
                    • 0 Attachment
                      Hi Iain,

                      The pmVfoAB flag indicates that the currently used VFO is VfoA, and a switch
                      between TX and RX would switch the radio to VfoB. It looks like most of the
                      commands in the Elecraft ini file were copied from the Kenwood file.
                      However, while the Kenwood radios send the transmit frequency in the IF
                      response when transmitting, the excerpts from the log you have posted
                      indicate that K3 always sends the receive frequency, regardless of the tx/rx
                      state. Your fix seems address this difference.

                      You are right, the second Flag21 must be renamed to Flag22.

                      Thank you for your corrections! Please send me the corrected ini file, I
                      will upload it to the OmniRig web page (when I return from the trip to VE7).

                      73 Alex VE3NEA



                      ----- Original Message -----
                      From: "Iain MacDonnell - N6ML" <ar@...>
                      To: <dxatlas_group@yahoogroups.com>
                      Sent: Monday, March 22, 2010 7:47 PM
                      Subject: Re: [dxatlas] Re: CW Skimmer 1.6


                      > Incase anyone's interested; in my "Elecraft K3.ini", I changed:
                      >
                      > Flag17=(............................0.0.1.....)|pmVfoAB
                      > Flag18=(............................0.1.1.....)|pmVfoBA
                      > Flag19=(............................1.0.1.....)|pmVfoBA
                      > Flag20=(............................1.1.1.....)|pmVfoAB
                      >
                      > to:
                      >
                      > Flag17=(............................0.0.1.....)|pmVfoAB
                      > Flag18=(............................0.1.1.....)|pmVfoBA
                      > Flag19=(............................1.0.1.....)|pmVfoAB
                      > Flag20=(............................1.1.1.....)|pmVfoBA
                      >
                      > I'm not sure what that logic was for switching to "receive on VFO B,
                      > transmit on VFO A" when transmitting (Flag19) and back on receive (Flag17)
                      > when in split mode, but I doesn't make sense to me. The change seems to do
                      > what I want, with no adverse side-effects so-far.
                      >
                      > Thanks for the nudge in the right direction, Alex!
                      >
                      > As a side-note, there are two "Flag21"s in my K3 file - looks like a bug?
                      >
                      > ~Iain / N6ML
                    Your message has been successfully submitted and would be delivered to recipients shortly.