Loading ...
Sorry, an error occurred while loading the content.

Faros, Omnirig and the IC-PCR1000 receiver.

Expand Messages
  • Dave Baxter
    A question for Alex I think, unless anyone else can answer with authority. I m working on getting Faros via OmniRig, to control and use an Icom IC-PCR1000.
    Message 1 of 1 , Oct 29, 2009
    • 0 Attachment
      A question for Alex I think, unless anyone else can answer with
      authority.

      I'm working on getting Faros via OmniRig, to control and use an Icom
      IC-PCR1000. This is for another user, and yet another person has
      kindly loaned me a PCR1000 to work with.

      So far, so good, I've got a driver that allows it to power it up,
      configure it, set the frequency, mode, filter etc just fine, and the RX
      seems to do the job.

      But Faros is not happy, showing a Yellow Radio legend at the bottom left
      of it's window. This indicates that Faros canot determine that the
      radio's frequency is what was set. Indeed, it cant (for a good reason!)

      The IC-PCR1000 cannot (as far as I can determine) report back it's
      current frequency (& oh how I've tried!) Or for that matter, its
      operating mode, or filter settings. A whole load of other stuff yes
      (squelch settings, signal strengh, decoded DTMF etc etc) but not the
      obvious stuff.

      I'm also going to ask on the PCR1000 list about this too, in case there
      is extra info about this radio, that I don't yet know, but of all the
      info I have so far, none makes any menion about being able to read back
      the working frequency.

      I can see (using a serial intercept program "Bill Serial Monitor" truly
      magic!) that Faros & Omnirig are sending the correct frequency, mode,
      filter settings to the PCR, and also that the simple status poll is
      working, but I cannot pursuade the thing to report back it's cuttently
      set working frequency.

      I've setup a simple Poll in the driver, so that OmniRig every 2 seconds
      sends a 'H1?' query, and the radio returns a string indicating it's
      powered up. The driver is configured to light up the 'RX' indicator in
      OmniRig, if the Client is loaded too. That works fine. (Thinking,
      querying the Squelch status would be more logical...)

      As earlier, is there any way to configure Omnirig to report back the
      same frequency an application set, or is there a way to set Faros to
      ignore any frequency setting error?

      Or, do I need to stoke up Delphi again, and craft an intermediary to
      "pretend" to do all that.

      Best Regards etc.

      Dave G0WBX.
    Your message has been successfully submitted and would be delivered to recipients shortly.