Loading ...
Sorry, an error occurred while loading the content.

TS-870 vs OmniRig

Expand Messages
  • Eike, DM3ML
    Hi, I have been asked by Manfred, DL1DWL, to put this entry in the forum : Manfred tries to use a program from HB9MTN to control a magnetic loop by the
    Message 1 of 2 , Feb 20, 2009
    • 0 Attachment
      Hi,
      I have been asked by Manfred, DL1DWL, to put this entry in the forum :
      Manfred tries to use a program from HB9MTN to control a magnetic loop
      by the frequency reading of his TS-870. The loop pogram uses OmniRig
      to read the CAT of transceivers. Everything (TX/RX switching, VFO A/B,
      mode control) works, only the frequency readout does'nt work. He
      tested the data exchange with client.exe. The status field jumps
      between 'online' and 'Rig is not responding'. He used the right
      settings 4800 Baud and 8N2 with different polling times. With other
      CAT programs the control works as expected.
      Any advice for Manfred ??
      Thanks in advance an 73 de Eike, DM3ML
    • Dave Baxter
      Hi Eike... I use OmniRig with Faros, and a TS-870S, and had no problems for over a year, I m now using an old Icom IC-R70 RX for Faros (that was a project all
      Message 2 of 2 , Feb 20, 2009
      • 0 Attachment
        Hi Eike...

        I use OmniRig with Faros, and a TS-870S, and had no problems for over a
        year, I'm now using an old Icom IC-R70 RX for Faros (that was a project
        all of it's own) so the TS-870s is now used for general shack use.

        I run the radio at 9600,N,8,1 I also have had to make a custom serial
        cable to connect to the PC. The details were found in the Kenwood
        manual, so no secrets.

        I also have it connected to one PC, and old Toshiba laptop, and have the
        serial port of that machine redirected over the shack network, to other
        PC's that have the controling software on (OmniRig and the application)
        All the serial port <> network stuff, is done with the Eterlogic VSPE
        tool. (Another Free tool, and very good!)

        I have used all this to great effect, for developing a "glue" program to
        control my Yaesu FC1000, that in essance takes the radio's frequency,
        and selects a pre-learnt ATU setting as needed.

        The prototype program, runs on the machine I use for development, while
        all the hardware is connected to the old Tosh laptop, that will
        ultimately do it all "local" to the radio/ATU. (The ATU is controled
        via the LPT port)

        I have other problems getting all this working, but OmniRig reading the
        radio's frequency is not one of them!

        Try checking your serial cable has all the correct wires in the
        appropriate places, and the polling times are OK. Start with a long
        period, 2000ms Poll Interval, 4000ms Timeout. Make sure too, that
        there is not a program trying to set the 870's frequency all the time.

        I found that running the radio's serial port faster than the "standard"
        4800bd, is a great help, but too fast, and HRD wont work reliably. 9600
        seems to suit everything at the moment.

        Other than that, I can't think of anything else right now.

        If you want/need, let me know, and I'll figure out what I did with the
        all important serial cable. All I can tell you at the moment, is it's a
        9 pin to 9 pin cable, but not standard PC type wiring.

        Let me know...

        Hmm.. HB9MTN website. Interesting!

        Regards..

        Dave G0WBX
        IO 92 ma




        > -----Original Message-----
        > __________
        3b. TS-870 vs OmniRig
        Posted by: "Eike, DM3ML" dm3ml@... eikebs
        Date: Fri Feb 20, 2009 8:21 am ((PST))

        Hi,
        I have been asked by Manfred, DL1DWL, to put this entry in the forum :
        Manfred tries to use a program from HB9MTN to control a magnetic loop by
        the frequency reading of his TS-870. The loop pogram uses OmniRig to
        read the CAT of transceivers. Everything (TX/RX switching, VFO A/B, mode
        control) works, only the frequency readout does'nt work. He tested the
        data exchange with client.exe. The status field jumps between 'online'
        and 'Rig is not responding'. He used the right settings 4800 Baud and
        8N2 with different polling times. With other CAT programs the control
        works as expected.
        Any advice for Manfred ??
        Thanks in advance an 73 de Eike, DM3ML
      Your message has been successfully submitted and would be delivered to recipients shortly.