Loading ...
Sorry, an error occurred while loading the content.

question about eclipse content output

Expand Messages
  • Andrew Hall
    Hi all, I am using DITA OT 1.3 and I generating eclipse *content* (not eclipse help). I am a raw novice at Eclipse. I went and did a basic test of the Eclipse
    Message 1 of 3 , Nov 1, 2006
    • 0 Attachment

      Hi all,

      I am using DITA OT 1.3 and I generating eclipse content (not eclipse help). I am a raw novice at Eclipse. I went and did a basic test of the Eclipse help functionality according to Arthur Barr's article (http://www-128.ibm.com/developerworks/opensource/library/os-echelp/) and his source files worked fine. His topic files are HTML.

      I have generated eclipse content just fine, I think. When I run my ant process, I get a plugin.xml, a toc.xml, dita.list, and my topic files (in XML format).

      When I open my toc file in Eclipse and then select Help > Help Contents, I get unexpected results.

      My topic structure is correct when I drill-down into my document. That's good.

      My content files appear blank. I can see nothing except for some XML content for one topic (see bottom of TOC sample for table_test.xml).

      My TOC file looks like this:

      <?xml version="1.0" encoding="utf-8"?>

      <?NLS  TYPE="org.eclipse.help.toc"?>

      <toc label="A User's Guide to NICE" topic="concepts/about_nice.html?srcext=xml">

         <topic label="About NICE" href="concepts/about_nice.html?srcext=xml">

            <topic label="Available finance functions" href="references/functions_supported.html?srcext=xml"/>

            <topic label="NICE workflow" href="tasks/workflow_overview.html?srcext=xml"/>

            <topic label="Limitations" href="concepts/limitations.html?srcext=xml"/>

         </topic>

         <topic label="Working with hierarchies">

            <topic label="Generating NICE-format hierarchy files" href="concepts/generating_hierarchy_files.html?srcext=xml"/>

            <topic label="Converting ARE hierarchies for NICE" href="tasks/converting_ARE_hierarchies.html?srcext=xml"/>

         </topic>

         <topic label="NICE maps">

            <topic label="About NICE maps" href="concepts/about_nice_maps.html?srcext=xml"/>

            <topic label="Structure of a NICE map" href="references/nice_map_structure.html?srcext=xml"/>

         </topic>

         <topic label="DITA Testing">

            <topic label="Testing tables" href="references/table_test.xml"/>

         </topic>

      </toc>

       

      My questions are:

      1. Why am I not able to view my topics in the Eclipse help window?
      2. Why are the topics not rendered as HTML, and why are they output as XML and then referred to as follows: href="concepts/about_nice_maps.html?srcext=xml"? Should that be OK?
      3. Why is the final reference in my ditamap output as xml (i.e., <topic label="Testing tables" href="references/table_test.xml"/>)? The topic href is different from those above?

       
      Any help is appreciated. Thanks in advance.

       
      Andy Hall

      Algorithmics, Inc

    • Don Day
      Andrew, for the kind of rendering you want, try the eclipsehelp transtype parameter value. The eclipsecontent transform is a specialty transform for those
      Message 2 of 3 , Nov 1, 2006
      • 0 Attachment
        Andrew, for the kind of rendering you want, try the "eclipsehelp" transtype
        parameter value. The "eclipsecontent" transform is a specialty transform
        for those who want to test rendering of XML directly, as your ToC
        indicates. There is no current client code available for that rendering,
        but the transform was provided in the hope of encouraging some development
        in that direction. If you use the eclipsehelp output, your topics will end
        up in HTML as you expected, and the content should render fine in the
        help/information center.

        Regards,
        --
        Don Day
        Chair, OASIS DITA Technical Committee
        IBM Lead DITA Architect
        Email: dond@...
        11501 Burnet Rd. MS9033E015, Austin TX 78758
        Phone: +1 512-838-8550
        T/L: 678-8550

        "Where is the wisdom we have lost in knowledge?
        Where is the knowledge we have lost in information?"
        --T.S. Eliot



        "Andrew Hall"
        <achall@...
        > To
        Sent by: dita-users@yahoogroups.com
        dita-users@yahoog cc
        roups.com
        Subject
        [dita-users] question about eclipse
        11/01/2006 07:13 content output
        AM


        Please respond to
        dita-users@yahoog
        roups.com











        Hi all,


        I am using DITA OT 1.3 and I generating eclipse content (not eclipse help). I am a
        raw novice at Eclipse. I went and did a basic test of the Eclipse help
        functionality according to Arthur Barr's article (
        http://www-128.ibm.com/developerworks/opensource/library/os-echelp/) and his
        source files worked fine. His topic files are HTML.


        I have generated eclipse content just fine, I think. When I run my ant process, I
        get a plugin.xml, a toc.xml, dita.list, and my topic files (in XML format).


        When I open my toc file in Eclipse and then select Help > Help Contents, I get
        unexpected results.


        My topic structure is correct when I drill-down into my document. That's good.


        My content files appear blank. I can see nothing except for some XML content for
        one topic (see bottom of TOC sample for table_test.xml).


        My TOC file looks like this:


        <?xml version="1.0" encoding="utf-8"?>


        <?NLS TYPE="org.eclipse.help.toc"?>


        <toc label="A User's Guide to NICE" topic="concepts/about_nice.html?srcext=xml">


        <topic label="About NICE" href="concepts/about_nice.html?srcext=xml">


        <topic label="Available finance functions"
        href="references/functions_supported.html?srcext=xml"/>


        <topic label="NICE workflow"
        href="tasks/workflow_overview.html?srcext=xml"/>


        <topic label="Limitations" href="concepts/limitations.html?srcext=xml"/>


        </topic>


        <topic label="Working with hierarchies">


        <topic label="Generating NICE-format hierarchy files"
        href="concepts/generating_hierarchy_files.html?srcext=xml"/>


        <topic label="Converting ARE hierarchies for NICE"
        href="tasks/converting_ARE_hierarchies.html?srcext=xml"/>


        </topic>


        <topic label="NICE maps">


        <topic label="About NICE maps"
        href="concepts/about_nice_maps.html?srcext=xml"/>


        <topic label="Structure of a NICE map"
        href="references/nice_map_structure.html?srcext=xml"/>


        </topic>


        <topic label="DITA Testing">


        <topic label="Testing tables" href="references/table_test.xml"/>


        </topic>


        </toc>





        My questions are:
        1. Why am I not able to view my topics in the Eclipse help window?
        2. Why are the topics not rendered as HTML, and why are they output as XML and
        then referred to as follows:
        href="concepts/about_nice_maps.html?srcext=xml"? Should that be OK?
        3. Why is the final reference in my ditamap output as xml (i.e., <topic
        label="Testing tables" href="references/table_test.xml"/>)? The topic href
        is different from those above?



        Any help is appreciated. Thanks in advance.



        Andy Hall


        Algorithmics, Inc
      • Andy Hall
        Thank you, Don. The eclipsehelp transformation works quite nicely. Best, Andy BTW I still have an issue with the last topic in my ditamap being rendered as XML
        Message 3 of 3 , Nov 1, 2006
        • 0 Attachment
          Thank you, Don.
          The eclipsehelp transformation works quite nicely.

          Best,
          Andy

          BTW I still have an issue with the last topic in my ditamap being
          rendered as XML and not HTML, but I'll investigate further. I figure
          it is my error.

          --- In dita-users@yahoogroups.com, Don Day <dond@...> wrote:
          >
          > Andrew, for the kind of rendering you want, try the "eclipsehelp"
          transtype
          > parameter value. The "eclipsecontent" transform is a specialty
          transform
          > for those who want to test rendering of XML directly, as your ToC
          > indicates. There is no current client code available for that rendering,
          > but the transform was provided in the hope of encouraging some
          development
          > in that direction. If you use the eclipsehelp output, your topics
          will end
          > up in HTML as you expected, and the content should render fine in the
          > help/information center.
          >
          > Regards,
          > --
          > Don Day
          > Chair, OASIS DITA Technical Committee
          > IBM Lead DITA Architect
          > Email: dond@...
          > 11501 Burnet Rd. MS9033E015, Austin TX 78758
          > Phone: +1 512-838-8550
          > T/L: 678-8550
          >
          > "Where is the wisdom we have lost in knowledge?
          > Where is the knowledge we have lost in information?"
          > --T.S. Eliot
          >
          >
          >

          > "Andrew Hall"

          > <achall@...
          > >
          To
          > Sent by: dita-users@yahoogroups.com

          > dita-users@yahoog
          cc
          > roups.com

          >
          Subject
          > [dita-users] question about
          eclipse
          > 11/01/2006 07:13 content output

          > AM

          >

          >

          > Please respond to

          > dita-users@yahoog

          > roups.com

          >

          >

          >
          >
          >
          >
          >

          >

          >

          >

          >

          > Hi all,

          >

          >

          > I am using DITA OT 1.3 and I generating eclipse content (not
          eclipse help). I am a
          > raw novice at Eclipse. I went and did a basic test of the Eclipse
          help
          > functionality according to Arthur Barr's article (

          >
          http://www-128.ibm.com/developerworks/opensource/library/os-echelp/)
          and his
          > source files worked fine. His topic files are HTML.

          >

          >

          > I have generated eclipse content just fine, I think. When I run my
          ant process, I
          > get a plugin.xml, a toc.xml, dita.list, and my topic files (in XML
          format).
          >

          >

          > When I open my toc file in Eclipse and then select Help > Help
          Contents, I get
          > unexpected results.

          >

          >

          > My topic structure is correct when I drill-down into my document.
          That's good.
          >

          >

          > My content files appear blank. I can see nothing except for some
          XML content for
          > one topic (see bottom of TOC sample for table_test.xml).

          >

          >

          > My TOC file looks like this:

          >

          >

          > <?xml version="1.0" encoding="utf-8"?>

          >

          >

          > <?NLS TYPE="org.eclipse.help.toc"?>

          >

          >

          > <toc label="A User's Guide to NICE"
          topic="concepts/about_nice.html?srcext=xml">
          >

          >

          > <topic label="About NICE"
          href="concepts/about_nice.html?srcext=xml">
          >

          >

          > <topic label="Available finance functions"

          > href="references/functions_supported.html?srcext=xml"/>

          >

          >

          > <topic label="NICE workflow"

          > href="tasks/workflow_overview.html?srcext=xml"/>

          >

          >

          > <topic label="Limitations"
          href="concepts/limitations.html?srcext=xml"/>
          >

          >

          > </topic>

          >

          >

          > <topic label="Working with hierarchies">

          >

          >

          > <topic label="Generating NICE-format hierarchy files"

          > href="concepts/generating_hierarchy_files.html?srcext=xml"/>

          >

          >

          > <topic label="Converting ARE hierarchies for NICE"

          > href="tasks/converting_ARE_hierarchies.html?srcext=xml"/>

          >

          >

          > </topic>

          >

          >

          > <topic label="NICE maps">

          >

          >

          > <topic label="About NICE maps"

          > href="concepts/about_nice_maps.html?srcext=xml"/>

          >

          >

          > <topic label="Structure of a NICE map"

          > href="references/nice_map_structure.html?srcext=xml"/>

          >

          >

          > </topic>

          >

          >

          > <topic label="DITA Testing">

          >

          >

          > <topic label="Testing tables"
          href="references/table_test.xml"/>
          >

          >

          > </topic>

          >

          >

          > </toc>

          >

          >

          >

          >

          >

          > My questions are:

          > 1. Why am I not able to view my topics in the Eclipse help
          window?
          > 2. Why are the topics not rendered as HTML, and why are they
          output as XML and
          > then referred to as follows:

          > href="concepts/about_nice_maps.html?srcext=xml"? Should that
          be OK?
          > 3. Why is the final reference in my ditamap output as xml (i.e.,
          <topic
          > label="Testing tables" href="references/table_test.xml"/>)?
          The topic href
          > is different from those above?

          >

          >

          >

          > Any help is appreciated. Thanks in advance.

          >

          >

          >

          > Andy Hall

          >

          >

          > Algorithmics, Inc
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.