Loading ...
Sorry, an error occurred while loading the content.

Re: suppress blank pages in DITA Open Toolkit output?

Expand Messages
  • jeofree@ymail.com
    Just wanted to say thanks for this. It s amazing how many little things can be found online, once I had chased down how to frame the online search anyway.
    Message 1 of 3 , Apr 21 6:23 AM
    View Source
    • 0 Attachment
      Just wanted to say thanks for this. It's amazing how many little things can be found online, once I had chased down how to frame the online search anyway.

      Kudos for coming back to note how you had resolved it, so that two years later someone could quickly find the answer!

      Just to note for others: in my case, commenting out either all or any part of this attribute set led to build failure, but I just changed "even" to "auto" in the first "value-of-select=" shown below, and that did the trick. 


      <xsl:attribute-set name="__force__page__count">
              <xsl:attribute name="force-page-count">
                  <xsl:choose>
                      <xsl:when test="name(/*) = 'bookmap'">
                          <xsl:value-of select="'even'"/>
                      </xsl:when>
                      <xsl:otherwise>
                          <xsl:value-of select="'auto'"/>
                      </xsl:otherwise>
                  </xsl:choose>
              </xsl:attribute>
          </xsl:attribute-set>




      --- In dita-users@yahoogroups.com, "philregion" <bducharme@...> wrote:
      >
      > I figured it out: it's the setting of the force-page-count attribute in demo/fo/cfg/fo/attrs/commons-attr.xsl. I commented out the part that sets it to "even" for bookmap.
      >
      > Bob
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.