Loading ...
Sorry, an error occurred while loading the content.

Re: Expanded Psionics Question

Expand Messages
  • kevlord@att.net
    I am anxiously awaiting the expanded psionics. Any psionics I have used with 3.5 I have had to manually upgrade to 3.5 which was more work than I wanted to do.
    Message 1 of 9 , Oct 13, 2004
    • 0 Attachment

      I am anxiously awaiting the expanded psionics. Any psionics I have used with 3.5 I have had to manually upgrade to 3.5 which was more work than I wanted to do. I don't see the point in supporting the old psionics with 3.5 after the expandied psionics. Anyone needing the old ones could keep the old version in a separate folder.

       

      -------------- Original message from cw@yahoogroups.com: --------------

      > Date: Mon, 11 Oct 2004 16:05:59 -0500
      > From: Bruce Kvam
      > Subject: Expanded Psionics Question
      >
      > We're in the process of implementing the Expanded Psionics SRD and have
      > a question about how we might implement it.
      >
      > The Expanded Psionics SRD came out long after 3.5, so when we
      > implemented 3.5 we simply included the existing Third Edition psionics
      > rules. However, the Expanded Psionics SRD is essentially incompatible
      > with Third Edition psionics.
      >
      > Now that the new rules are out, does anyone see a need to support the
      > Third Edition psionics rules under the 3.5 template, or can we support
      > only the Expanded Psionics rules on the 3.5 template going forward?
      > (Providing a conversion for the 3.5 characters that use the 3E classes?)
      >
      > Thanks for your input.
      >
      > Bruce

    Your message has been successfully submitted and would be delivered to recipients shortly.