Loading ...
Sorry, an error occurred while loading the content.

Problem with the 1802 emulator

Expand Messages
  • Ray
    I have the current version 1.03 and I think I found a bug. Every time I go into the Cosmac emulator my whole system freezes up as soon as I start it and
    Message 1 of 2 , Jun 23, 2009
    • 0 Attachment
      I have the current version 1.03 and I think I found a bug. Every time I go into the Cosmac emulator my whole system freezes up as soon as I start it and select help. I am running Windows XP Media Center Edition with SP3 on a 3 year old HP with an Athlon 64 3200+ processor. (I am running the 32-bit version of Windows XP.) Any help would be appreciated.

      Thanks

      Ray
    • Marcel van Tongeren
      Thanks for the bug report Ray! I found the problem which is in the i8275 (for the Elf 2000) handling. As soon as a special character is used (blinking, reverse
      Message 2 of 2 , Jun 24, 2009
      • 0 Attachment
        Thanks for the bug report Ray!

        I found the problem which is in the i8275 (for the Elf 2000) handling. As soon as a special character is used (blinking, reverse etc) the i8275 screen will be updated constantly which takes a lot of processor load. This happens indeed when typing 'help' or also with 'te vt' etc.

        Anyway I will try to release a new v1.04 version ASAP, either late this week or early next.

        Cheers, Marcel.

        --- In cosmacelf@yahoogroups.com, "Ray" <daventhalas1@...> wrote:
        >
        > I have the current version 1.03 and I think I found a bug. Every time I go into the Cosmac emulator my whole system freezes up as soon as I start it and select help. I am running Windows XP Media Center Edition with SP3 on a 3 year old HP with an Athlon 64 3200+ processor. (I am running the 32-bit version of Windows XP.) Any help would be appreciated.
        >
        > Thanks
        >
        > Ray
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.