Loading ...
Sorry, an error occurred while loading the content.

Re: Nubee Loading ElfOS.

Expand Messages
  • wb1exg
    Looks like my lower half is different as well ... 0CD00H R0 Current sector: 0000 0CD00H L 0000: 90 B3 F8 06 A3 D3 F8 FF B4 F8 E0 A4 F8 FF B5 F8
    Message 1 of 31 , May 18 5:59 PM
    • 0 Attachment
      Looks like my lower half is different as well

      >>>sedit
      0CD00H>R0
      Current sector: 0000
      0CD00H>L

      0000: 90 B3 F8 06 A3 D3 F8 FF B4 F8 E0 A4 F8 FF B5 F8 ................
      0010: F1 A5 F8 00 B2 F8 F0 A2 F8 01 A7 F8 03 BF F8 00 ................
      0020: AF E2 87 52 64 22 73 F8 00 B7 A8 F8 E0 B8 D4 FF ...Rd"s.........
      0030: 3C 60 72 A7 17 87 FF 0F 3A 22 F8 03 B0 F8 00 A0 <`r.....:"......
      0040: D0 FF 00 00 FF 00 00 FF 00 00 FF 00 00 FF 00 00 ................
      0050: FF 00 00 FF 00 00 FF 00 00 FF 00 00 FF 00 00 FF ................
      0060: 00 00 FF 00 00 FF 00 00 FF 00 00 FF 00 00 FF 00 ................
      0070: 00 FF 00 00 FF 00 00 FF 00 00 FF 00 00 FF 00 00 ................
      0080: FF 00 00 FF 00 00 FF 00 00 FF 00 00 FF 00 00 FF ................
      0090: 00 00 FF 00 00 FF 00 00 FF 00 00 FF 00 00 FF 00 ................
      00A0: 00 FF 00 00 FF 00 00 FF 00 00 FF 00 00 FF 00 00 ................
      00B0: FF 00 00 FF 00 00 FF 00 00 FF 00 00 FF 00 00 FF ................
      00C0: 00 00 FF 00 00 FF 00 00 FF 00 00 FF 00 00 FF 00 ................
      00D0: 00 FF 00 00 FF 00 00 FF 00 00 FF 00 00 FF 00 00 ................
      00E0: FF 00 00 FF 00 00 FF 00 00 FF 00 00 FF 00 00 FF ................
      00F0: 00 00 FF 00 00 FF 00 00 FF 00 00 FF 00 00 FF A6 ................
      0CD00H>



      --- In cosmacelf@yahoogroups.com, rileym65 <no_reply@...> wrote:
      >
      > Another thing to look at, using sedit, look at sector 0, low half, it
      > should look exactly like:
      >
      > 0000: 90 B3 F8 06 A3 D3 F8 FF B4 F8 E0 A4 F8 FF B5 F8 ................
      > 0010: F1 A5 F8 00 B2 F8 F0 A2 F8 01 A7 F8 03 BF F8 00 ................
      > 0020: AF E2 87 52 64 22 73 F8 00 B7 A8 F8 E0 B8 D4 FF ...Rd"s.........
      > 0030: 3C 60 72 A7 17 87 FF 0F 3A 22 F8 03 B0 F8 00 A0 <`r.....:"......
      > 0040: D0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
      > 0050: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
      > 0060: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
      > 0070: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
      > 0080: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
      > 0090: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
      > 00A0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
      > 00B0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
      > 00C0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
      > 00D0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
      > 00E0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
      > 00F0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
      >
      > This should again confirm whether there is no problem with the CF card
      > if your sector 0 looks like this.
      > Mike
      >
      >
      >
      > --- In cosmacelf@yahoogroups.com, "wb1exg" <tconst@> wrote:
      > >
      > > I am now using a 256MB card I was using a 8MB card which had 0's for
      > > the total sectors and total AU's. With the 256MB card I get:
      > >
      > > IDE File System Gen Utility
      > > Total Sectors: 41984
      > > AU Size: 8
      > > Total AUs: 62592
      > > Master Dir Sector: 264
      > > File system generation complete
      > >
      > > Step 3 finishes
      > > Step 4 hangs the same way (I also tried booting without doing this
      > > step as you suggested, results the same)
      > >
      > > COSMAC ELF 2000 EPROM V87 CHECKSUM 78AD SRAM 32K CONTENTS OK
      > > Copyright (C) 2004-2006 by Spare Time Gizmos. All rights reserved.
      > > ElfOS BIOS Copyright (C) 2004 by Mike Riley.
      > >
      > > IDE Master: 244Mb KODAK TB
      > > 05/18/2007 16:32:17
      > > For help type HELP
      > > >>>BOOT
      > > Booting primary IDE ...
      > >
      > > and just sits there with FCF7 in the address display, the same
      > > address I get when picking option 5 on the Elf/OS install.
      > >
      > > Regards
      > > Tim
      > >
      > >
      > >
      > >
      > > --- In cosmacelf@yahoogroups.com, rileym65 <no_reply@> wrote:
      > > >
      > > > Hello,
      > > > Also, what size CF card are you using... When running the
      > > > installation, on step 1 always use the <Q>uick mode! The Elf2k
      > > > version of the diskinit (step 1) has a bug in <F>ull mode. For a CF
      > > > card the <Q>uick mode is all that is needed. If you used full mode
      > > > then turn the computer completely off and then back on and then redo
      > > > the installation. Before doing step 4, also try to boot into
      Elf/OS.
      > > > if the filesystem was generated correctly and the kernel installed,
      > > > then you will at least get the kernel boot message even if no
      binaries
      > > > are yet installed. If you let me know the size of the CF card
      then I
      > > > can let you know what the approximate numbers for step 2 should be.
      > > > Mike
      > > >
      > > > --- In cosmacelf@yahoogroups.com, "wb1exg" <tconst@> wrote:
      > > > >
      > > > > I am trying to install ElfOS version 0.2.6
      > > > > Which I believe is my only option for the ELF2k.
      > > > > My ROM version is 87 with BIOS 1.0.6
      > > > > Regards
      > > > > Tim
      > > > >
      > > > > --- In cosmacelf@yahoogroups.com, rileym65 <no_reply@> wrote:
      > > > > >
      > > > > > Which version are you trying to install???
      > > > > > Mike
      > > > > >
      > > > > > --- In cosmacelf@yahoogroups.com, "wb1exg" <tconst@> wrote:
      > > > > > >
      > > > > > > Thank you Bob that was it, I got a clean upload.
      > > > > > >
      > > > > > > After a clean upload I did:
      > > > > > > >>>call 3000
      > > > > > >
      > > > > > > Then a Full format on a 8mb card with # Sectors formatted =
      > 15744
      > > > > > > (quick format did not seem to work)
      > > > > > >
      > > > > > > Option 2 returned:
      > > > > > > Total sectors=65280
      > > > > > > AU size=8
      > > > > > > Total AU's=8160
      > > > > > > Master Dir Sector=56
      > > > > > >
      > > > > > > Option 3 worked
      > > > > > > Then option 4 hung after
      > > > > > > typing "Binary utilities installer"
      > > > > > > The address display on the ELF stops at: FCF7
      > > > > > >
      > > > > > > The very first time I did a quick format and was able to
      > > install the
      > > > > > > system utilities but could not BOOT the OS either from
      > option 5, a
      > > > > > > call or a reboot.
      > > > > > >
      > > > > > > Not sure if this is a hardware or software problem. I can
      write
      > > > test
      > > > > > > bytes to the CF card via SEDIT but after a quick format an
      init
      > > > > > > returns 0 total sectors?? I am using a 74HC245 on the disk
      > > card if
      > > > > > > that matters any.
      > > > > > >
      > > > > > > Regards
      > > > > > > Tim
      > > > > > >
      > > > > > >
      > > > > > > --- In cosmacelf@yahoogroups.com, "Robert Armstrong" <bob@>
      > wrote:
      > > > > > > >
      > > > > > > >
      > > > > > > > > >>>:03800000c0f900C4
      > > > > > > > > ?MEMORY ERROR
      > > > > > > >
      > > > > > > > The address you're trying to write with this HEX record is
      > > > $8000 -
      > > > > > > that's
      > > > > > > > in EPROM, and hence the memory error.
      > > > > > > >
      > > > > > > > Your problem is that there is a special version of the
      ElfOS
      > > > > > > loader for
      > > > > > > > the Elf2K, and you need to be using that one. The regular
      > ElfOS
      > > > > > > file is for
      > > > > > > > Mike's machines, which have a different memory map.
      > > > > > > >
      > > > > > > > Bob
      > > > > > > >
      > > > > > >
      > > > > >
      > > > >
      > > >
      > >
      >
    • wb1exg
      Only JP4 on the Disk card is installed - so no interrupt enables ... in a few ... jumped into ... jumpers on ... Elf2K -
      Message 31 of 31 , May 19 8:41 PM
      • 0 Attachment
        Only JP4 on the Disk card is installed - so no interrupt enables


        --- In cosmacelf@yahoogroups.com, "Robert Armstrong" <bob@...> wrote:
        >
        > >So check with Robert and see what it is supposed to be doing at that
        > address.
        >
        > What address? FCF7? It's one byte beyond the end of initcall:,
        in a few
        > bytes of presently unused space. It seems that the program has
        jumped into
        > never-never land for some reason.
        >
        > Hmmm.. Tim - you aren't installing any of the interrupt enable
        jumpers on
        > your disk card, are you???
        >
        > Mike - I emailed you the source of the bios version that's in the
        Elf2K -
        > did you get it??
        >
        > Bob
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.