Loading ...
Sorry, an error occurred while loading the content.

Might have Missed the TQSL UPDATE?...

Expand Messages
  • ** N8NOE **
    http://www.arrl.org/logbook-of-the-world New Trusted QSL Software You must have this latest software version to request or renew certificates. The most recent
    Message 1 of 1 , Nov 2, 2010
    • 0 Attachment
      http://www.arrl.org/logbook-of-the-world




      New Trusted QSL Software

      You must have this latest software version to request or renew certificates.

      The most recent version is TQSL 1.13

      To check your software version

      1. Open either program TQSL or TQSL CERT

      2. Select HELP

      3. Select ABOUT to view the software information.

      If you do not have TQSL 1.13 you may download the software here.

      Download Trusted QSL 1.13 for Windows.

      Download Trusted QSL 1.13 for Mac OSX

      Do not uninstall existing software.

      New files will overwrite older files.


      Jeff-N8NOE
    Your message has been successfully submitted and would be delivered to recipients shortly.