Loading ...
Sorry, an error occurred while loading the content.

Re: [ce-gnu-lug] Re: Idea of 100% CPU Usage on Particular time

Expand Messages
  • mayukmok00@yahoo.com
    Have you tried to use htop (http://htop.sourceforge.net/) there is an arpm package available in rpmforge.   -- ________________________________ From: codbla
    Message 1 of 5 , Dec 4, 2012
    • 0 Attachment
      Have you tried to use htop (http://htop.sourceforge.net/) there is an arpm package available in rpmforge.
       
      --



      From: codbla <codbla@...>
      To: ce-gnu-lug@yahoogroups.com
      Sent: Thursday, November 29, 2012 5:36 AM
      Subject: [ce-gnu-lug] Re: Idea of 100% CPU Usage on Particular time

       
      I used to check the crons but nothing is scheduled to run. I used to run unhide there are only some warnings (5). My move is to upgrade or maybe clone and isolate it.

      --- In ce-gnu-lug@yahoogroups.com, alcher <alcher@...> wrote:
      >
      > Did you check your cron and logs for any scheduled task?
      >
      > Maybe run a ps -eo or ps axwwo with options and sort by cpu usage or try the unhide to view the hidden process @ http://www.unhide-forensics.info/?Linux
      >
      > Regards,
      >
      > Alcher
      >
      >
      >
      > ________________________________
      > From: codbla <codbla@...>
      > To: ce-gnu-lug@yahoogroups.com
      > Sent: Tuesday, November 27, 2012 3:00 PM
      > Subject: [ce-gnu-lug] Idea of 100% CPU Usage on Particular time
      >
      >
      >  
      > Hi,
      >
      > Do have any ideas how to find a hidden process? coz I could not trace the problems of our server which gave high cpu usage until you can't do anything at around quarter to seven in the evening and in the morning. To solve the problem is to reset. It is a PDC - OpenLDAP 2.3 and Samba 2.3, and using Centos 5.3. But my manager afraid of the upgrades. I used to try to disable/stop the services like CUPS (which I thought the main cause but still doing something). I also used TOP commands to logs but it was 10-20 mins late (maybe because of 100% cpu usage) in 5 min interval same as using the SAR commands.
      >
      > Any suggestions on what to do? Thank you for your time.
      >
      > Regards,
      > MarioBro
      >



    • codbla
      For how many trials of the configs and troubleshooting, finally confirmed the main cause was on IPV6 as the first assumption when randomly display the printk
      Message 2 of 5 , Dec 4, 2012
      • 0 Attachment
        For how many trials of the configs and troubleshooting, finally confirmed the main cause was on IPV6 as the first assumption when randomly display the printk on the screen but initial config didn't completely disabled it.
        Even added the monitoring logs like top/htop and sar but once it was on high cpu usage (almost 100%) can't record the events. Disabling one at a time, the services, but still problem occurred. It was found out the problem was in network when the replica (the backup copy) run in parallel with the production one but disabled the ethernet and no problem arises.

        Solution:
        Disabled completely the IPV6, from the kernel networking settings, module that link to ipv6, ssh config, and the initialization script.

        and to check using the command
        lsmod | grep ipv6


        Daghang salamat,
        MarioBro

        --- In ce-gnu-lug@yahoogroups.com, mayukmok00@... wrote:
        >
        > Have you tried to use htop (http://htop.sourceforge.net/) there is an arpm package available in rpmforge.
        >  
        >
        > --
        >
        >
        >
        >
        > ________________________________
        > From: codbla <codbla@...>
        > To: ce-gnu-lug@yahoogroups.com
        > Sent: Thursday, November 29, 2012 5:36 AM
        > Subject: [ce-gnu-lug] Re: Idea of 100% CPU Usage on Particular time
        >
        >
        >  
        > I used to check the crons but nothing is scheduled to run. I used to run unhide there are only some warnings (5). My move is to upgrade or maybe clone and isolate it.
        >
        > --- In ce-gnu-lug@yahoogroups.com, alcher <alcher@> wrote:
        > >
        > > Did you check your cron and logs for any scheduled task?
        > >
        > > Maybe run a ps -eo or ps axwwo with options and sort by cpu usage or try the unhide to view the hidden process @ http://www.unhide-forensics.info/?Linux
        > >
        > > Regards,
        > >
        > > Alcher
        > >
        > >
        > >
        > > ________________________________
        > > From: codbla <codbla@>
        > > To: ce-gnu-lug@yahoogroups.com
        > > Sent: Tuesday, November 27, 2012 3:00 PM
        > > Subject: [ce-gnu-lug] Idea of 100% CPU Usage on Particular time
        > >
        > >
        > >  
        > > Hi,
        > >
        > > Do have any ideas how to find a hidden process? coz I could not trace the problems of our server which gave high cpu usage until you can't do anything at around quarter to seven in the evening and in the morning. To solve the problem is to reset. It is a PDC - OpenLDAP 2.3 and Samba 2.3, and using Centos 5.3. But my manager afraid of the upgrades. I used to try to disable/stop the services like CUPS (which I thought the main cause but still doing something). I also used TOP commands to logs but it was 10-20 mins late (maybe because of 100% cpu usage) in 5 min interval same as using the SAR commands.
        > >
        > > Any suggestions on what to do? Thank you for your time.
        > >
        > > Regards,
        > > MarioBro
        > >
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.