Loading ...
Sorry, an error occurred while loading the content.
 

internal flash fix was Re: HELP! flash Canon 10D firmware problems

Expand Messages
  • dressageguy
    Thanks... All custom functions setto zero & reset (still set to zero) Camera returned to default Removed both clock & camera battery overnight & reflashed on a
    Message 1 of 8 , Jun 2, 2008
      Thanks...

      All custom functions setto zero & reset (still set to zero)
      Camera returned to default
      Removed both clock & camera battery overnight & reflashed on a Canon
      32meg flash card (was reformatted on camera) as before
      Firmware reflashed ok from V2.0.2 to V2.0.1

      In both full auto and program mode, internal flash still doesn't
      work...
      Unable to get flash icon to appear...
      Flash button doesn't do anything...
      Pulling the pop-up flash out manually-still nothing

      External flash still works

      Thanks Stefan!
      Also found this other link on fixing error 5 on EOS cameras and other
      problems with internal and external flash though
      http://www.conraderb.com/flashrepair/
      Cleaned out some crud..
      Both "microswitch plungers" on my 10D were sticking, with the left
      one (lens facing forward) totally stuck
      With both microswitch plungers up, still no internal flash
      Put a little solvent on the plungers overnight and decided to tackle
      it again in the morning
      With the left microswitch plunger pulled all the way up - WOOHOO!
      internal flash works! (with flash popped up)

      Hints: Use a pair of tweezers to move the microswitch plunger up-
      down. If plunger stuck down, try using the point of a sewing needle
      to coax it up. I used the tip of a flat jewelers screwdriver tip to
      transport some solvent (had Rapid Tap cutting fluid handy) around the
      plunger and then used the tweezers to move it up & down, Also let the
      solvent sit there for a while & repeat. Then finished by transporting
      a little WD-40.

      External flash still working

      But the flash button nor low light condition automatically (full auto
      mode) will pop up the flash...
      Any ideas? If getting off topic, please email me privately
      equine@...
      .
      Thanks,
      Phillip
      ----------------------------------------------------------------------
      ------

      --- In canondigicamhacking@yahoogroups.com, "Deisz, Stefan"
      <stefan.deisz@...> wrote:
      >
      > Does the camera work with a hot-shoe mounted flash? There was a
      hardware
      > problem with the old EOS 5: sometimes the microswitches hidden
      under the
      > metal spring in the hot-shoe mount were stuck, making the camera
      think a
      > flash was mounted and the preventing the built-in flash from
      popping up.
      > Although this mostly was an EOS 5 problem, there have been reports
      from
      > other bodies showing the same problem.
      > (http://photonotes.org/forum/viewtopic.php?
      p=1155&sid=b7c654867c94410856
      > 99c403bbb2ba07)
      >
      > Cheers! Stefan.
      >
      > ________________________________
      >
      > From: canondigicamhacking@yahoogroups.com
      > [mailto:canondigicamhacking@yahoogroups.com] On Behalf Of Steve
      Sprengel
      > Sent: vrijdag 30 mei 2008 0:47
      > To: canondigicamhacking@yahoogroups.com
      > Subject: Re: [canondigicamhacking] HELP! flash Canon 10D firmware
      > problems
      >
      >
      >
      > From the procedure you've described, it seems as though your pop-up
      > flash problem is unrelated to your firmware-flash procedure, and
      the one
      > not working after the other is just coincidence.
      >
      > In general:
      >
      > Check your camera-menu and custom-function settings to make sure the
      > flash is enabled.
      >
      > Check for camera's mode dial to make sure it is not in No Flash
      mode.
      >
      > Check the camera's operating manual to review how to disable the
      flash,
      > so you understand what to do to re-enabled it.
      >
      > If necessary, download a copy of the 10D manual from
      > http://www.usa.canon.com/ <http://www.usa.canon.com/>
      >
      > ----- Original Message -----
      > From: dressageguy
      > To: canondigicamhacking@yahoogroups.com
      > <mailto:canondigicamhacking%40yahoogroups.com>
      > Sent: Thursday, May 29, 2008 4:16 PM
      > Subject: [canondigicamhacking] HELP! flash Canon 10D firmware
      problems
      >
      > HELP! flash Canon 10D firmware problems
      >
      > loaded V2 to upgrade my Canon 10D...
      > appears to be successful-no errors, camera shows as V2
      >
      > But after that the internal flash stopped working, cannot get flash
      > icon to appear in any mode, nor activate with flash button, nor
      does
      > it work with the flash popped up in a totally dark room. Also
      shutter
      > sounds sluggish, but seems to be functional.
      >
      > Reloaded V2 on memory card in an attempt to reflash-but it didn't
      let
      > me...
      > Found a V1 on the net, flash to V1 appear successful-but same
      > problems.
      > Reloaded V2 again, reflash appears to be sucessful-but same
      problems
      > again...
      >
      > BTW, PictBridge worked each time with V2 (and not with V1 as not
      > supported)
      >
      > HELP!!
      > Suggestions?
      > Anybody have other Canon 10D versions to try?
      >
      > Thanks!
      > Phillip
      >
      > [Non-text portions of this message have been removed]
      >
      >
      >
      >
      >
      > ----------
      >
      > ÿþD
      >
      > [Non-text portions of this message have been removed]
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.