Loading ...
Sorry, an error occurred while loading the content.

85 Seville heater and fan problems

Expand Messages
  • case1133
    I have an 85 Seville that has extremely low mileage (59000 kilometers) and is in very nice shape. I very seldom used the car.....till my 76 Fleetwood (my
    Message 1 of 1 , Aug 25 9:04 AM
    • 0 Attachment
      I have an 85 Seville that has extremely low mileage (59000
      kilometers) and is in very nice shape. I very seldom used the
      car.....till my 76 Fleetwood (my regular driver) was hit from behind
      as it sat parked, and was written off. Now the Seville has become my
      driver.
      The problem is in the fan.
      The AC doesn't work......the car sat for quite some time and it got
      low, but the heater/blower always worked well. It has the temp set
      and blower direction on a little digital display in the center of the
      dash. One day, the fan stopped working. I ran a wire from the fan to
      the fuse panel and into a blank plug ang the fan worked fine. I left
      it like that. I could still determine where to direct the air flow
      and heat or fresh air, by the dash control. Now, even that has
      stopped. The dash control still shows what it should, and appears to
      be functioning, but I can only get air to blow at my feet....and it
      is only heated air too.....and we are in a warm summer (averaging 75
      to 85 degrees F. every day) Well......my feet are cooking. Does
      anyone know what module/piece/relay/whatever..I have to change to
      correct this problem?
      I would like to try fixing it myself (being the cheapie that I am)
      first, before taking it to the garage, but I am lost on this one.
      Any suggestions would be greatly appreciated, and could get me out of
      the heat.........
    Your message has been successfully submitted and would be delivered to recipients shortly.