Loading ...
Sorry, an error occurred while loading the content.

Re: [booksbybibin,www.booksbybibin.tk] How does an ATMEGA16 programmer works?

Expand Messages
  • nitin chaudhary
    When you reset the system through command in ponyprog, the reset led should blink only once. For wrong connection reset led will blink more than one ... From:
    Message 1 of 5 , Jun 30, 2009
    • 0 Attachment
      When you reset the system through command in ponyprog, the reset led should blink only once. For wrong connection reset led will blink more than one

      --- On Sun, 28/6/09, im_shield <im_shield@...> wrote:

      From: im_shield <im_shield@...>
      Subject: [booksbybibin,www.booksbybibin.tk] How does an ATMEGA16 programmer works?
      To: booksbybibin@yahoogroups.com
      Date: Sunday, 28 June, 2009, 7:06 PM

      Hi there! I've made a programmer but is not working(don' t know if is the uC or the programmer fault) . Sice i can't test if the uC is fried, i want to test if the programmer do its job. For that I attached some leds coresponding to the MOSI, MISO, SCK, RESET and VCC. I use Pony Prog for reading the device.
      The serial Probe test inside PonyProg said "Test ok". When i try to read or Write, the MOSI and SCK led start to flash (alternate, with MOSI more brighter). VCC led is on. The other 2 leds (RST and MISO) are not doing anything. Can somenone please tell me how those leds should behave so the programmer work well? Or do u know any onther method to test it? Thank you!



      Looking for local information? Find it on Yahoo! Local
    • im_shield
      Ok it s done..It reads the microcontroller, serial probe is ok, but when i write it finishes 100% and the message Write failed appears. I saw FAQ on
      Message 2 of 5 , Jul 2, 2009
      • 0 Attachment
        Ok it's done..It reads the microcontroller, serial probe is ok, but when i write it finishes 100% and the message "Write failed" appears.
        I saw FAQ on lancos.com and they sayd there to modify some values inside ponyprog.ini (file found where ponyprog is installed).I modified the values but still the same problem.I use a USB to serial converter since i don;t have serial ports. Fuse bits can be responsable for something like that? Thank you for your answers!

        --- In booksbybibin@yahoogroups.com, nitin chaudhary <nitin2162000@...> wrote:
        >
        > When you reset the system through command in ponyprog, the reset led should blink only once. For wrong connection reset led will blink more than one
        >
        > --- On Sun, 28/6/09, im_shield <im_shield@...> wrote:
        >
        > From: im_shield <im_shield@...>
        > Subject: [booksbybibin,www.booksbybibin.tk] How does an ATMEGA16 programmer works?
        > To: booksbybibin@yahoogroups.com
        > Date: Sunday, 28 June, 2009, 7:06 PM
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        > Hi there! I've made a programmer but is not working(don' t know if is the uC or the programmer fault) . Sice i can't test if the uC is fried, i want to test if the programmer do its job. For that I attached some leds coresponding to the MOSI, MISO, SCK, RESET and VCC. I use Pony Prog for reading the device.
        >
        > The serial Probe test inside PonyProg said "Test ok". When i try to read or Write, the MOSI and SCK led start to flash (alternate, with MOSI more brighter). VCC led is on. The other 2 leds (RST and MISO) are not doing anything. Can somenone please tell me how those leds should behave so the programmer work well? Or do u know any onther method to test it? Thank you!
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
        > ICC World Twenty20 England '09 exclusively on YAHOO! CRICKET http://cricket.yahoo.com
        >
      • im_shield
        Done...I won t use USB to Serial converter ever..It s working great with serial only :D..One more question: i did not attached to my programmer a crystal
        Message 3 of 5 , Jul 4, 2009
        • 0 Attachment
          Done...I won't use USB to Serial converter ever..It's working great with serial only :D..One more question: i did not attached to my programmer a crystal oscillator, but i have it on the board i want to use the microcontroller ( is a 7.3728 crystal). So my question is: can i program my uC with the fuses set so that my uC work with an external 7.3728 crystal, even if i use a programmer that don't use such a crystal? To be more clear, after i program my atmega16 on a programmer without external crystal (but with fuses set for external 7.3728), i want to take it out the socket and place it on a board that uses external 7.3728..Is it ok? Or should I have to attach an external 7.3728 to the programmer also?



          --- In booksbybibin@yahoogroups.com, "im_shield" <im_shield@...> wrote:
          >
          > Ok it's done..It reads the microcontroller, serial probe is ok, but when i write it finishes 100% and the message "Write failed" appears.
          > I saw FAQ on lancos.com and they sayd there to modify some values inside ponyprog.ini (file found where ponyprog is installed).I modified the values but still the same problem.I use a USB to serial converter since i don;t have serial ports. Fuse bits can be responsable for something like that? Thank you for your answers!
          >
          > --- In booksbybibin@yahoogroups.com, nitin chaudhary <nitin2162000@> wrote:
          > >
          > > When you reset the system through command in ponyprog, the reset led should blink only once. For wrong connection reset led will blink more than one
          > >
          > > --- On Sun, 28/6/09, im_shield <im_shield@> wrote:
          > >
          > > From: im_shield <im_shield@>
          > > Subject: [booksbybibin,www.booksbybibin.tk] How does an ATMEGA16 programmer works?
          > > To: booksbybibin@yahoogroups.com
          > > Date: Sunday, 28 June, 2009, 7:06 PM
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > > Hi there! I've made a programmer but is not working(don' t know if is the uC or the programmer fault) . Sice i can't test if the uC is fried, i want to test if the programmer do its job. For that I attached some leds coresponding to the MOSI, MISO, SCK, RESET and VCC. I use Pony Prog for reading the device.
          > >
          > > The serial Probe test inside PonyProg said "Test ok". When i try to read or Write, the MOSI and SCK led start to flash (alternate, with MOSI more brighter). VCC led is on. The other 2 leds (RST and MISO) are not doing anything. Can somenone please tell me how those leds should behave so the programmer work well? Or do u know any onther method to test it? Thank you!
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > > ICC World Twenty20 England '09 exclusively on YAHOO! CRICKET http://cricket.yahoo.com
          > >
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.