Loading ...
Sorry, an error occurred while loading the content.

Atmel mcu test guide needed

Expand Messages
  • tharrenos_d
    Could anyone please tell me where and what I should look for in order to spot any faults on the mcu board? I get an error (Alert: Device missing or unknown
    Message 1 of 2 , Feb 1, 2008
    • 0 Attachment
      Could anyone please tell me where and what I should look for in order
      to spot any faults on the mcu board? I get an error (Alert: Device
      missing or unknown device (-24)) when I try to download a hex file on
      the microcontroller via Ponyprog.

      ps. the ucontroller is an atmel mega 64u and I am not sure about the
      pins as they are tiny and the solder bath didnt work very well.

      cheers
      Tharrenos
    • Mihai Galos
      Hey. The problem could be anywhere. First of all, what board are you using? Check if it gets the supply voltage and no short-circuit between the V+ and Gnd is
      Message 2 of 2 , Feb 2, 2008
      • 0 Attachment
        Hey.

        The problem could be anywhere. First of all, what board are you
        using? Check if it gets the supply voltage and no short-circuit
        between the V+ and Gnd is present. Also, try to use Atmels that are
        PDIP, in a combination with a breadboard, to allow for easy acces to
        the ports and programming features.

        I use the Atmel's C compiler and the WinAvr package. Winavr has a
        neat program called AvrDude. You can program your uController with it
        using just the breadboard and a parallel printer cable. No
        development board or other hardware required.

        If you still insist on using ponyprog and your board, you must find
        the fault, but most of the guys here probally use breadboards or
        atmel dev boards such as the stk-500.

        Regards,
        Mihai G.

        --- In booksbybibin@yahoogroups.com, "tharrenos_d" <tharrenos@...>
        wrote:
        >
        > Could anyone please tell me where and what I should look for in
        order
        > to spot any faults on the mcu board? I get an error (Alert: Device
        > missing or unknown device (-24)) when I try to download a hex file
        on
        > the microcontroller via Ponyprog.
        >
        > ps. the ucontroller is an atmel mega 64u and I am not sure about
        the
        > pins as they are tiny and the solder bath didnt work very well.
        >
        > cheers
        > Tharrenos
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.