Loading ...
Sorry, an error occurred while loading the content.

-to problems

Expand Messages
  • willis3140@yahoo.com
    hello, I can t send mail with blat. I am using my personal machine from home, the name of my smtp server is the same as my machine, will . if i send mail to
    Message 1 of 8 , Sep 4, 2001
    • 0 Attachment
      hello, I can't send mail with blat. I am using my personal machine
      from home, the name of my smtp server is the same as my
      machine, 'will'. if i send mail to say.... '-to greg' . The smtp
      srver thinks it sends the message. and i see the message in my 'sent
      items' dir C:\Inetpub\mailroot\Drop. well if i try using an email
      addy with say and '@' sign, ie, greg@... it wigs out. and
      gives me an error:


      The mail server doesn't like the name greg@....
      Have you set the 'To:' field correctly.

      Do I need to set up alias names somehow? IF so how do i do that?

      I am really getting frustrated, I am doing some perl stuff on my pc
      and I can't seem to send mail with blat and it seems to be one of my
      best alternitaves.

      please help.

      will
    • Gordon Stewart
      if youre using perl try sending it to greg @domain.com - The @ sign needs the before it (the correct term is escaping the character . G. ... hello, I
      Message 2 of 8 , Sep 4, 2001
      • 0 Attachment
        if youre using perl

        try sending it to greg\@... - The @ sign needs the \ before it (the correct term is 'escaping' the character'.

        G.


        >>> willis3140@... 09/05/01 02:45 >>>
        hello, I can't send mail with blat. I am using my personal machine
        from home, the name of my smtp server is the same as my
        machine, 'will'. if i send mail to say.... '-to greg' . The smtp
        srver thinks it sends the message. and i see the message in my 'sent
        items' dir C:\Inetpub\mailroot\Drop. well if i try using an email
        addy with say and '@' sign, ie, greg@... it wigs out. and
        gives me an error:
      • willis3140@yahoo.com
        Gordon, well, I am using blat from the command line, I tried escaping the @ sign and i didn t get an error, however, after 10 min i haven t recieved the email
        Message 3 of 8 , Sep 4, 2001
        • 0 Attachment
          Gordon,

          well, I am using blat from the command line, I tried escaping the @
          sign and i didn't get an error, however, after 10 min i haven't
          recieved the email i sent myself.


          -- this is hopeless.
          Will


          --- In blat@y..., "Gordon Stewart" <Gordon.Stewart@i...> wrote:
          > if youre using perl
          >
          > try sending it to greg\@... - The @ sign needs the \ before
          it (the correct term is 'escaping' the character'.
          >
          > G.
          >
          >
          > >>> willis3140@y... 09/05/01 02:45 >>>
          > hello, I can't send mail with blat. I am using my personal machine
          > from home, the name of my smtp server is the same as my
          > machine, 'will'. if i send mail to say.... '-to greg' . The smtp
          > srver thinks it sends the message. and i see the message in
          my 'sent
          > items' dir C:\Inetpub\mailroot\Drop. well if i try using an email
          > addy with say and '@' sign, ie, greg@d... it wigs out. and
          > gives me an error:
        • Pound Brett 6364 BPOUND
          ... my sent ... To me, this sounds like another SMTP server setup problem, not a BLAT problem. Does your SMTP server work, and how did you test it? Try the
          Message 4 of 8 , Sep 4, 2001
          • 0 Attachment
            Will said:
            >well, I am using blat from the command line, I tried escaping the @
            >sign and i didn't get an error, however, after 10 min i haven't
            >recieved the email i sent myself.

            and earlier said:

            > hello, I can't send mail with blat. I am using my personal machine
            > from home, the name of my smtp server is the same as my
            > machine, 'will'. if i send mail to say.... '-to greg' . The smtp
            > srver thinks it sends the message. and i see the message in
            my 'sent
            > items' dir C:\Inetpub\mailroot\Drop. well if i try using an email
            > addy with say and '@' sign, ie, greg@d... it wigs out. and
            > gives me an error:

            To me, this sounds like another SMTP server setup problem, not a BLAT
            problem. Does your SMTP server work, and how did you test it?

            Try the -debug switch of BLAT to see if there's any additional information
            coming back from the server. My guess is that the SMTP server can't resolve
            how to forward the message, so reports this error.

            Let us know what that shows.

            Brett
            <# exclude corporate disclaimer> ' If only it was that simple.....



            NOTICE
            If you are not an authorised recipient of this e-mail, please contact Blake Dawson Waldron immediately by return e-mail or by telephone on 61-2-9258-6000.
            In this case, you should not read, print, re-transmit, store or act in reliance on this e-mail or any attachments, and should destroy all copies of them.
            This e-mail and any attachments are confidential and may contain legally privileged information and/or copyright material of Blake Dawson Waldron or third parties.
            You should only re-transmit, distribute or commercialise the material if you are authorised to do so.
            Where applicable, liability limited by the Solicitors' Scheme, approved under the Professional Standards Act 1994 [NSW].
            This notice should not be removed.


            [Non-text portions of this message have been removed]
          • Gordon Stewart
            ... To me, this sounds like another SMTP server setup problem, not a BLAT problem. Does your SMTP server work, and how did you test it? Try the -debug switch
            Message 5 of 8 , Sep 4, 2001
            • 0 Attachment
              >>> brett.pound@... 09/05/01 03:42 >>>
              >

              To me, this sounds like another SMTP server setup problem, not a BLAT
              problem. Does your SMTP server work, and how did you test it?

              Try the -debug switch of BLAT to see if there's any additional information
              coming back from the server. My guess is that the SMTP server can't resolve
              how to forward the message, so reports this error.

              Let us know what that shows.
              Brett
              <

              Anyway, Ive got "sendmail" to work on my server - (even though the people on the mailing list said it couldnt be done for my machine).

              when i tried it. Ive never managed to get the -body command in Blat to work.

              Whats the latest version, & what website ?

              My version hasnt got the -body or the -debug commands (as far as i read in the help text - didnt mention any of them).

              G.
            • willis3140@yahoo.com
              Thanks for the suggestion, I did what you said and this is the results I got, maybe you could help me make something out of this. Thanks - Will Sending
              Message 6 of 8 , Sep 4, 2001
              • 0 Attachment
                Thanks for the suggestion, I did what you said and this is the
                results I got, maybe you could help me make something out of this.

                Thanks - Will


                Sending blat.txt to willis3140\@...
                Login name is administrator
                <<<getline<<< 220 will Microsoft ESMTP MAIL Service, Version:
                5.0.2195.2966 ready at Tue, 4 Sep 2001 22:54:40 -0500


                >>>putline>>> EHLO will

                <<<getline<<< 250-will Hello [192.168.1.100]
                250-AUTH GSSAPI NTLM LOGIN
                250-AUTH=LOGIN
                250-SIZE 2097152
                250-PIPELINING
                250-DSN
                250-ENHANCEDSTATUSCODES
                250-8bitmime
                250-BINARYMIME
                250-CHUNKING
                250-VRFY
                250 OK

                >>>putline>>> MAIL From:<administrator>

                <<<getline<<< 250 2.1.0 administrator@will....Sender OK

                >>>putline>>> RCPT To: <willis3140\@...>

                <<<getline<<< 250 2.1.5 willis3140\@...@will

                >>>putline>>> DATA

                <<<getline<<< 354 Start mail input; end with <CRLF>.<CRLF>

                <<<getline<<< 250 2.6.0 <WILLhGGrKwLMkyKamhX0000000a@will> Queued
                mail for delivery

                >>>putline>>> QUIT

                <<<getline<<< 221 2.0.0 will Service closing transmission channel


                Thanks for the help!!!! --- Will



                --- In blat@y..., Pound Brett 6364 BPOUND <brett.pound@b...> wrote:
                > Will said:
                > >well, I am using blat from the command line, I tried escaping the
                @
                > >sign and i didn't get an error, however, after 10 min i haven't
                > >recieved the email i sent myself.
                >
                > and earlier said:
                >
                > > hello, I can't send mail with blat. I am using my personal
                machine
                > > from home, the name of my smtp server is the same as my
                > > machine, 'will'. if i send mail to say.... '-to greg' . The smtp
                > > srver thinks it sends the message. and i see the message in
                > my 'sent
                > > items' dir C:\Inetpub\mailroot\Drop. well if i try using an email
                > > addy with say and '@' sign, ie, greg@d... it wigs out. and
                > > gives me an error:
                >
                > To me, this sounds like another SMTP server setup problem, not a
                BLAT
                > problem. Does your SMTP server work, and how did you test it?
                >
                > Try the -debug switch of BLAT to see if there's any additional
                information
                > coming back from the server. My guess is that the SMTP server
                can't resolve
                > how to forward the message, so reports this error.
                >
                > Let us know what that shows.
                >
                > Brett
                > <# exclude corporate disclaimer> ' If only it was that simple.....
                >
                >
                >
                > NOTICE
                > If you are not an authorised recipient of this e-mail, please
                contact Blake Dawson Waldron immediately by return e-mail or by
                telephone on 61-2-9258-6000.
                > In this case, you should not read, print, re-transmit, store or act
                in reliance on this e-mail or any attachments, and should destroy all
                copies of them.
                > This e-mail and any attachments are confidential and may contain
                legally privileged information and/or copyright material of Blake
                Dawson Waldron or third parties.
                > You should only re-transmit, distribute or commercialise the
                material if you are authorised to do so.
                > Where applicable, liability limited by the Solicitors' Scheme,
                approved under the Professional Standards Act 1994 [NSW].
                > This notice should not be removed.
                >
                >
                > [Non-text portions of this message have been removed]
              • Romson Christer
                ... Sending blat.txt to willis3140 @yahoo.com ...
                Message 7 of 8 , Sep 5, 2001
                • 0 Attachment
                  Will:
                  > I [used the -debug switch] and this is the
                  > results I got, maybe you could help me make something out of this.

                  Sending blat.txt to willis3140\@...
                  >>>putline>>> RCPT To: <willis3140\@...>
                  <<<getline<<< 250 2.1.5 willis3140\@...@will

                  The suggestion to quote the at sign with a backslash only applied
                  to calling blat from perl. In this case you want blat to be started with
                  an unquoted atsign. Backslash is a quote character in email addresses,
                  so you requested blat to send a mail to the account named "" at local
                  machine "willis3140@..." rather than to the account "willis3140"
                  at yahoo.com.

                  <<<getline<<< 250 2.6.0 <WILLhGGrKwLMkyKamhX0000000a@will> Queued
                  mail for delivery

                  Teh 250 status code is the mail server saying it has received the message
                  and is asuming the responsibilty of sending it further on. The line "Queued
                  mail for delivery" is intended for mail server admins debug email problems.
                  In all likelyhood it means the mail server queued the mail in a file, in
                  order to
                  be transferred later. There could be many reasons why it chose to queue the
                  mail.

                  Yahoo.com might have been unreachable for a number of reasons. In that
                  case the only options are to queue or error out. Clearly queueing the mail
                  for some time (up tp a week or so) is better than erroring out on you.

                  The mail server might have configured to always queue mail. In some
                  scenarios this is the right thing to do, but that's probably not your
                  intentions.

                  You should re-configure the mail server to handle the queued messages
                  every so often (5 minutes or something) to handle the connectivity problem
                  and you should probably configure it to try connecting at once rather than
                  always queue.

                  Someone asked if/how you verified that the mail server is working. Have you
                  done that at all?

                  Finally there is one other problem. The mail server seems to think you
                  domain is named "will". Look again at the RCPT TO line and the 250 response.
                  When you quoted the at sign, you told the mail server that the address was
                  a local address without a domain. The mail server then attached the local
                  email domain name to the address in order to create a standards compliant
                  email address: willis3140\@...@will. Now we have an email address
                  with a valid syntax, but there is no "will" domain. The domain is probably
                  something like will.com, so the mail server should have been configured to
                  generate something like willis3140\@yahoo.com@... in this case.

                  I hope this helps,
                  Christer
                • willis3140@yahoo.com
                  Thanks again for the ideas! Will ... with ... addresses, ... local ... Queued ... message ... line Queued ... problems. ... file, in ... queue the ... that
                  Message 8 of 8 , Sep 5, 2001
                  • 0 Attachment
                    Thanks again for the ideas!

                    Will

                    --- In blat@y..., Romson Christer <christer.romson@e...> wrote:
                    > Will:
                    > > I [used the -debug switch] and this is the
                    > > results I got, maybe you could help me make something out of this.
                    >
                    > Sending blat.txt to willis3140\@...
                    > >>>putline>>> RCPT To: <willis3140\@...>
                    > <<<getline<<< 250 2.1.5 willis3140\@...@will
                    >
                    > The suggestion to quote the at sign with a backslash only applied
                    > to calling blat from perl. In this case you want blat to be started
                    with
                    > an unquoted atsign. Backslash is a quote character in email
                    addresses,
                    > so you requested blat to send a mail to the account named "" at
                    local
                    > machine "willis3140@y..." rather than to the account "willis3140"
                    > at yahoo.com.
                    >
                    > <<<getline<<< 250 2.6.0 <WILLhGGrKwLMkyKamhX0000000a@will>
                    Queued
                    > mail for delivery
                    >
                    > Teh 250 status code is the mail server saying it has received the
                    message
                    > and is asuming the responsibilty of sending it further on. The
                    line "Queued
                    > mail for delivery" is intended for mail server admins debug email
                    problems.
                    > In all likelyhood it means the mail server queued the mail in a
                    file, in
                    > order to
                    > be transferred later. There could be many reasons why it chose to
                    queue the
                    > mail.
                    >
                    > Yahoo.com might have been unreachable for a number of reasons. In
                    that
                    > case the only options are to queue or error out. Clearly queueing
                    the mail
                    > for some time (up tp a week or so) is better than erroring out on
                    you.
                    >
                    > The mail server might have configured to always queue mail. In some
                    > scenarios this is the right thing to do, but that's probably not
                    your
                    > intentions.
                    >
                    > You should re-configure the mail server to handle the queued
                    messages
                    > every so often (5 minutes or something) to handle the connectivity
                    problem
                    > and you should probably configure it to try connecting at once
                    rather than
                    > always queue.
                    >
                    > Someone asked if/how you verified that the mail server is working.
                    Have you
                    > done that at all?
                    >
                    > Finally there is one other problem. The mail server seems to think
                    you
                    > domain is named "will". Look again at the RCPT TO line and the 250
                    response.
                    > When you quoted the at sign, you told the mail server that the
                    address was
                    > a local address without a domain. The mail server then attached the
                    local
                    > email domain name to the address in order to create a standards
                    compliant
                    > email address: willis3140\@...@will. Now we have an email
                    address
                    > with a valid syntax, but there is no "will" domain. The domain is
                    probably
                    > something like will.com, so the mail server should have been
                    configured to
                    > generate something like willis3140\@...@w... in this case.
                    >
                    > I hope this helps,
                    > Christer
                  Your message has been successfully submitted and would be delivered to recipients shortly.