Loading ...
Sorry, an error occurred while loading the content.

Re: MS-DOS Bug?

Expand Messages
  • Laurence
    ... run this ... line would ... Works for me in MS-DOS 6.22.
    Message 1 of 5 , Oct 3, 2000
    • 0 Attachment
      --- In batchworld@egroups.com, "Alex Peters" <petersa@m...> wrote:
      > Hi guys,
      >
      > Can anyone give me a good reason as to why a DOS box crashes when I
      run this
      > code?
      >
      > I have intentionally made it so that it doesn't work; the second
      line would
      > normally read:
      >
      > IF %1!==!! GOTO PROCESS
      >
      > Here's the batch file:
      >
      > @ECHO OFF
      > IF %1!==:! GOTO PROCESS
      > FOR %%A IN (*.*) DO CALL %0 ! %%A
      >
      > GOTO END
      >
      > :PROCESS
      > ECHO %2
      >
      > :END
      >
      > I'm running Windows 95.

      Works for me in MS-DOS 6.22.
    • Alex Peters
      Hi guys, Can anyone give me a good reason as to why a DOS box crashes when I run this code? I have intentionally made it so that it doesn t work; the second
      Message 2 of 5 , Oct 4, 2000
      • 0 Attachment
        Hi guys,
         
        Can anyone give me a good reason as to why a DOS box crashes when I run this code?
         
        I have intentionally made it so that it doesn't work; the second line would normally read:
         
        IF %1!==!! GOTO PROCESS
         
        Here's the batch file:
         
        @ECHO OFF
        IF %1!==:! GOTO PROCESS
        FOR %%A IN (*.*) DO CALL %0 ! %%A
         
        GOTO END
         
        :PROCESS
        ECHO %2
         
        :END
        I'm running Windows 95.
         
        Alex
         
      Your message has been successfully submitted and would be delivered to recipients shortly.