Loading ...
Sorry, an error occurred while loading the content.

php error not displaying

Expand Messages
  • Prashanth
    i am using fedora 6, my php compiler is not showing errors if i use browser to open the file (http://localhost/file.php is not showing error and i get a blank
    Message 1 of 4 , Dec 27, 2006
    • 0 Attachment
      i am using fedora 6, my php compiler is not showing errors if i use
      browser to open the file (http://localhost/file.php is not showing
      error and i get a blank page), but when i run it in terminal (php
      file.php) it throws error.
      can anyone pls tell me how to make php display errors in browsers
    • Vinu Thomas
      Prashanth, Make sure the following is present in your php.ini file: error_reporting = E_ALL & ~E_NOTICE This will enable all errors except notices to come up
      Message 2 of 4 , Dec 27, 2006
      • 0 Attachment
        Prashanth,

        Make sure the following is present in your php.ini file:
        error_reporting = E_ALL & ~E_NOTICE
        This will enable all errors except notices to come up on the browser.

        One point to note is that PHP is an interpreted language and doesn't
        have a compiler .

        Regards,
        Vinu

        On 12/27/06, Prashanth <hprashi.blore@...> wrote:
        > i am using fedora 6, my php compiler is not showing errors if i use
        > browser to open the file (http://localhost/file.php is not showing
        > error and i get a blank page), but when i run it in terminal (php
        > file.php) it throws error.
        > can anyone pls tell me how to make php display errors in browsers
        >
      • Ankur Dave
        Dude, Chk the php.ini setting that this must be enable. error_reporting = E_ALL & ~E_NOTICE and you can chk your err here also /var/log/apache2/* just do tail
        Message 3 of 4 , Dec 27, 2006
        • 0 Attachment
          Dude,

          Chk the php.ini setting that this must be enable.
          error_reporting = E_ALL & ~E_NOTICE

          and you can chk your err here also /var/log/apache2/*
          just do "tail -f :/var/log/apache2/error.log" and this will gv you
          error here
          (This is for my debian machine)

          Hope this will work for you now.

          -=-=-=-=-=-=-=-=-=-
          ankur dave,
          my blog :: http://ullu.wordpress.com


          -----Original Message-----
          From: bang-phpug@yahoogroups.com [mailto:bang-phpug@yahoogroups.com] On
          Behalf Of Prashanth
          Sent: Wednesday, December 27, 2006 5:26 PM
          To: bang-phpug@yahoogroups.com
          Subject: [bang-phpug] php error not displaying

          i am using fedora 6, my php compiler is not showing errors if i use
          browser to open the file (http://localhost/file.php is not showing
          error and i get a blank page), but when i run it in terminal (php
          file.php) it throws error.
          can anyone pls tell me how to make php display errors in browsers




          Yahoo! Groups Links





          The information contained in, or attached to, this e-mail, contains confidential information and is intended solely for the use of the individual or entity to whom they are addressed and is subject to legal privilege. If you have received this e-mail in error you should notify the sender immediately by reply e-mail, delete the message from your system and notify your system manager. Please do not copy it for any purpose, or disclose its contents to any other person. The views or opinions presented in this e-mail are solely those of the author and do not necessarily represent those of the company. The recipient should check this e-mail and any attachments for the presence of viruses. The company accepts no liability for any damage caused, directly or indirectly, by any virus transmitted in this email.

          www.aztecsoft.com
        • Ved Prakash
          Hi Prashanth, Check for error_reporting tag in your php.ini set to E_ALL & ~E_NOTICE . Hope that may help.
          Message 4 of 4 , Dec 28, 2006
          • 0 Attachment
            Hi Prashanth,

            Check for "error_reporting" tag in your php.ini set to "E_ALL &
            ~E_NOTICE".

            Hope that may help.


            --- In bang-phpug@yahoogroups.com, "Prashanth" <hprashi.blore@...> wrote:
            >
            > i am using fedora 6, my php compiler is not showing errors if i use
            > browser to open the file (http://localhost/file.php is not showing
            > error and i get a blank page), but when i run it in terminal (php
            > file.php) it throws error.
            > can anyone pls tell me how to make php display errors in browsers
            >
          Your message has been successfully submitted and would be delivered to recipients shortly.