Loading ...
Sorry, an error occurred while loading the content.

Is PHP 5.x is stable?

Expand Messages
  • Mahabaleshwar
    Dear friends, I want to know whether PHP 5 is stable or not.If so please tel me which version is stable in the 5.x series. Recently I upgraded PHP 4.x to 5.1.x
    Message 1 of 2 , Nov 14, 2006
    • 0 Attachment
      Dear friends,

      I want to know whether PHP 5 is stable or not.If so please tel me which
      version is stable in the 5.x series.
      Recently I upgraded PHP 4.x to 5.1.x in my developement server.
      After upgrading I accessed some of the pages which uses functions with
      Call-time pass-by-reference, but it shows warning message given bellow:

      Warning: Call-time pass-by-reference has been deprecated - argument
      passed by value; If you would like to pass it by reference, modify the
      declaration of [runtime function name](). If you would like to enable
      call-time pass-by-reference, you can set allow_call_time_pass_reference
      to true in your INI file. However, future versions may not support this
      any longer.

      >From the above message we can find that PHP is going to remove some of

      the features which are available in older versions.If that hapens how
      can a programmer rely on the language and write version independent
      scripts.

      please help me...
    • Vinu Thomas
      PHP 5.1.x and above are quite stable. We re using that on some of our production servers. Some of the functionality in PHP4 has either been removed or disabled
      Message 2 of 2 , Nov 22, 2006
      • 0 Attachment
        PHP 5.1.x and above are quite stable. We're using that on some of our
        production servers. Some of the functionality in PHP4 has either been
        removed or disabled by default in PHP5. So you may want to thoroughly
        test your older code before deploying them to a PHP5 server.

        Here are things you may want to keep in mind:
        http://us2.php.net/manual/en/migration5.incompatible.php

        Regards,
        Vinu

        --- In bang-phpug@yahoogroups.com, "Mahabaleshwar" <mahihs2002@...> wrote:
        >
        > Dear friends,
        >
        > I want to know whether PHP 5 is stable or not.If so please tel me which
        > version is stable in the 5.x series.
        > Recently I upgraded PHP 4.x to 5.1.x in my developement server.
        > After upgrading I accessed some of the pages which uses functions with
        > Call-time pass-by-reference, but it shows warning message given bellow:
        >
        > Warning: Call-time pass-by-reference has been deprecated - argument
        > passed by value; If you would like to pass it by reference, modify the
        > declaration of [runtime function name](). If you would like to enable
        > call-time pass-by-reference, you can set allow_call_time_pass_reference
        > to true in your INI file. However, future versions may not support this
        > any longer.
        >
        > >From the above message we can find that PHP is going to remove some of
        >
        > the features which are available in older versions.If that hapens how
        > can a programmer rely on the language and write version independent
        > scripts.
        >
        > please help me...
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.