Loading ...
Sorry, an error occurred while loading the content.

Re: [bang-phpug] How to remove index.php from the URL in codeigniter

Expand Messages
  • Abdul Munim Kazia
    You ll need to use apache mod_rewrite in htacess.. It s documented here: http://codeigniter.com/wiki/mod_rewrite/ ... -- Abdul Munim Kazia mail@munimkazia.com
    Message 1 of 5 , Apr 13 3:28 AM
    • 0 Attachment
      You'll need to use apache mod_rewrite in htacess.. It's documented here:
      http://codeigniter.com/wiki/mod_rewrite/

      On 11 April 2011 15:48, Arockiaraj <askeerthan@...> wrote:

      >
      >
      > Hi,
      >
      > I am new to Codeigniter. I want to remove index.php from the URL.
      >
      > I tried in many ways , but i can't.
      >
      > Now i am using xampp 1.6.7
      >
      > Plz tell me step by step to achieve this.
      >
      > Thanks in Advance
      >
      > Regards,
      > Arockia Raj
      >
      >
      >



      --
      Abdul Munim Kazia
      mail@...


      [Non-text portions of this message have been removed]
    • Shweta
      To do this just follows the following steps: 1. Open config.php from system/application/config directory and replace $config[ index_page ] = index.php by
      Message 2 of 5 , Apr 13 5:04 AM
      • 0 Attachment
        To do this just follows the following steps:
        1. Open config.php from system/application/config directory and
        replace
        $config['index_page'] = "index.php" by
        $config['index_page'] = ""
        2. Create a ".htaccess" file in the root of CodeIgniter
        directory (where the system directory resides), open the file using your
        favorite text editor, write down the following script and save it:
        RewriteEngine on
        RewriteCond $1 !^(index\.php|resources|robots\.txt)
        RewriteCond %{REQUEST_FILENAME} !-f
        RewriteCond %{REQUEST_FILENAME} !-d
        RewriteRule ^(.*)$ index.php/$1 [L,QSA]

        3. In some case the default setting for uri_protocol does not work
        properly. To solve this problem just replace
        $config['uri_protocol'] = "AUTO" by
        $config['uri_protocol'] = "REQUEST_URI" from
        system/application/config/config.php





        --- In bang-phpug@yahoogroups.com, "Arockiaraj" <askeerthan@...> wrote:
        >
        > Hi,
        >
        > I am new to Codeigniter. I want to remove index.php from the URL.
        >
        > I tried in many ways , but i can't.
        >
        > Now i am using xampp 1.6.7
        >
        > Plz tell me step by step to achieve this.
        >
        > Thanks in Advance
        >
        >
        > Regards,
        > Arockia Raj
        >



        [Non-text portions of this message have been removed]
      • shreekar.shetty
        A crude but successful way - http://princesust.wordpress.com/2011/05/13/codeignite-htaccess/ Worked for me. Give it a shot !!
        Message 3 of 5 , May 18, 2011
        • 0 Attachment
          A crude but successful way -

          http://princesust.wordpress.com/2011/05/13/codeignite-htaccess/

          Worked for me. Give it a shot !!


          --- In bang-phpug@yahoogroups.com, "Arockiaraj" <askeerthan@...> wrote:
          >
          > Hi,
          >
          > I am new to Codeigniter. I want to remove index.php from the URL.
          >
          > I tried in many ways , but i can't.
          >
          > Now i am using xampp 1.6.7
          >
          > Plz tell me step by step to achieve this.
          >
          > Thanks in Advance
          >
          >
          > Regards,
          > Arockia Raj
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.