Loading ...
Sorry, an error occurred while loading the content.

image is not diplaying in email id

Expand Messages
  • udikeri_7373
    Hello everyone , This is Vinayakkumar here,I m new be to php, I m writing one php script that has to deliver e cards i.e images to specified e mail id. Problem
    Message 1 of 4 , Nov 1, 2010
    • 0 Attachment
      Hello everyone ,

      This is Vinayakkumar here,I m new be to php, I m writing one php
      script that has to deliver e cards i.e images to specified e mail id.

      Problem which i m facing is

      image is not displaying in email other works fine.

      i tried as following code of php


      <html><head><title></title ><body><?php$to =
      "vinayak.udikeri@...";$subject = "Test mail";$message = "<img src
      ='http://www.bletchley-park.com/wp-content/uploads/2009/05/php.png' /
      >";$from = "udikeri_7373@...";$headers = "From:
      $from";mail($to,$subject,$message,$headers);echo "Mail
      Sent.";?></body></html>
      check out this for reference
      http://www.4icards.com/getinfo.asp?im=6974
      try to give sol...

      thank you

      check out this for proper idea

      http://www.4icards.com/getinfo.asp?im=6974
      <http://www.4icards.com/getinfo.asp?im=6974>


      Regards ,vinayakkumar



      [Non-text portions of this message have been removed]
    • visit_at_vishal
      hi, I think you should use the proper headers info.
      Message 2 of 4 , Nov 3, 2010
      • 0 Attachment
        hi,
        I think you should use the proper headers info.



        --- In bang-phpug@yahoogroups.com, "udikeri_7373" <udikeri_7373@...> wrote:
        >
        > Hello everyone ,
        >
        > This is Vinayakkumar here,I m new be to php, I m writing one php
        > script that has to deliver e cards i.e images to specified e mail id.
        >
        > Problem which i m facing is
        >
        > image is not displaying in email other works fine.
        >
        > i tried as following code of php
        >
        >
        > <html><head><title></title ><body><?php$to =
        > "vinayak.udikeri@...";$subject = "Test mail";$message = "<img src
        > ='http://www.bletchley-park.com/wp-content/uploads/2009/05/php.png' /
        > >";$from = "udikeri_7373@...";$headers = "From:
        > $from";mail($to,$subject,$message,$headers);echo "Mail
        > Sent.";?></body></html>
        > check out this for reference
        > http://www.4icards.com/getinfo.asp?im=6974
        > try to give sol...
        >
        > thank you
        >
        > check out this for proper idea
        >
        > http://www.4icards.com/getinfo.asp?im=6974
        > <http://www.4icards.com/getinfo.asp?im=6974>
        >
        >
        > Regards ,vinayakkumar
        >
        >
        >
        > [Non-text portions of this message have been removed]
        >
      • Amardeep
        try setting the headers as mentioned in the PHP manual . you can take a look at the following code // To send HTML mail, the Content-type header must be set
        Message 3 of 4 , Nov 3, 2010
        • 0 Attachment
          try setting the headers as mentioned in the PHP manual . you can take a look
          at the following code

          // To send HTML mail, the Content-type header must be set
          $headers = 'MIME-Version: 1.0' . "\r\n";
          $headers .= 'Content-type: text/html; charset=iso-8859-1' . "\r\n";

          // Additional headers
          $headers .= 'To: Mary <mary@...>, Kelly <kelly@...>' .
          "\r\n";
          $headers .= 'From: Birthday Reminder <birthday@...>' . "\r\n";
          $headers .= 'Cc: birthdayarchive@...' . "\r\n";
          $headers .= 'Bcc: birthdaycheck@...' . "\r\n";

          mail($to, $subject, $message, $headers);


          One of the reason could be you are tried to send a HTML mail instead of
          plain/simple text, so need to set the proper content type.
          Hope this helps ..

          On Tue, Nov 2, 2010 at 1:42 AM, udikeri_7373 <udikeri_7373@...>wrote:

          >
          >
          > Hello everyone ,
          >
          > This is Vinayakkumar here,I m new be to php, I m writing one php
          > script that has to deliver e cards i.e images to specified e mail id.
          >
          > Problem which i m facing is
          >
          > image is not displaying in email other works fine.
          >
          > i tried as following code of php
          >
          > <html><head><title></title ><body><?php$to =
          > "vinayak.udikeri@... <vinayak.udikeri%40gmail.com>";$subject = "Test
          > mail";$message = "<img src
          > ='http://www.bletchley-park.com/wp-content/uploads/2009/05/php.png' /
          > >";$from = "udikeri_7373@... <udikeri_7373%40yahoo.co.in>";$headers
          > = "From:
          > $from";mail($to,$subject,$message,$headers);echo "Mail
          > Sent.";?></body></html>
          > check out this for reference
          > http://www.4icards.com/getinfo.asp?im=6974
          > try to give sol...
          >
          > thank you
          >
          > check out this for proper idea
          >
          > http://www.4icards.com/getinfo.asp?im=6974
          > <http://www.4icards.com/getinfo.asp?im=6974>
          >
          > Regards ,vinayakkumar
          >
          > [Non-text portions of this message have been removed]
          >
          >
          >



          --
          Amardeep Sarkar


          [Non-text portions of this message have been removed]
        • Shoan Motwani
          Hi, ... [Snip...] ... Instead of messing around with the headers, I would strongly recommend use of a framework like swiftmail[1] [1] http://swiftmailer.org/
          Message 4 of 4 , Nov 3, 2010
          • 0 Attachment
            Hi,

            On 03-Nov-2010, at 3:02 PM, Amardeep wrote:

            > try setting the headers as mentioned in the PHP manual . you can take a look
            > at the following code
            >
            > // To send HTML mail, the Content-type header must be set
            > $headers = 'MIME-Version: 1.0' . "\r\n";
            >

            [Snip...]

            >
            > One of the reason could be you are tried to send a HTML mail instead of
            > plain/simple text, so need to set the proper content type.
            > Hope this helps ..
            >

            Instead of messing around with the headers, I would strongly recommend use of a framework like swiftmail[1]

            [1] http://swiftmailer.org/

            Peace,
            Shoan.
          Your message has been successfully submitted and would be delivered to recipients shortly.