Loading ...
Sorry, an error occurred while loading the content.

Re: [AutoTrace] AutoTrace 0.27

Expand Messages
  • Stefan A. Deutscher
    Cool. Thanks. Please include a quick pointer to the web page with your messages, so one can go there right from the message. Built it on Tru64 (Alpha) with
    Message 1 of 7 , Mar 23, 2001
    • 0 Attachment
      Cool. Thanks. Please include a quick pointer to the web page with your
      messages, so one can go there right from the message.

      Built it on Tru64 (Alpha) with gcc. configures is fine, but it fails
      with make:

      Make: Don't know how to make ./configure.af. Stop.

      GNU make works, but fails to link:

      gcc -g -O2 -o autotrace atou.o main.o getopt.o getopt1.o
      libautotrace.a
      /usr/bin/ld:
      Unresolved:
      fmod
      sqrt
      hypot
      acos
      ceil
      collect2: ld returned 1 exit status
      gmake: *** [autotrace] Error 1

      It seems the makefile forgets to append the -lm for inclusion of the
      math library. Adding that by hand produces a working executable. (Let me
      know if you want it by separate email for your download section.)

      Will try OS/2 and FreeBSD later.

      Cheers,
      Stefan


      On Fri, Mar 23, 2001 at 07:01:49PM +0100, Martin Weber wrote:
      > A new release of AutoTrace is available:
      > What's new in AutoTrace 0.27

      --
      ============================================================================
      Stefan A. Deutscher |
      Donostia International Physics Center | office: ++34-943-018174
      Universidad del Pais Vasco, Facultad de Quimica | fax : ++34-943-015600
      Departamento de Fisica de Materiales | home : ++34-943-270647
      Apartado 1072, San Sebastian 20080, Spain | email : sad@...
      ============================================================================
      The early bird gets the worm but the second mouse gets the cheese.
    • Masatake YAMATO
      ... I can. How do we do about version number? I think we should not call the new version 0.27. 0.27a or 0.27.1 or...0.28? Masatake
      Message 2 of 7 , Mar 23, 2001
      • 0 Attachment
        > Hi Masatake,
        >
        > could you fix this problem?
        I can. How do we do about version number?
        I think we should not call the new version 0.27.
        0.27a or 0.27.1 or...0.28?

        Masatake
      • Martin Weber
        Hi Masatake, could you fix this problem? Martin
        Message 3 of 7 , Mar 23, 2001
        • 0 Attachment
          Hi Masatake,

          could you fix this problem?

          Martin

          "Stefan A. Deutscher" schrieb:

          > Cool. Thanks. Please include a quick pointer to the web page with your
          > messages, so one can go there right from the message.
          >
          > Built it on Tru64 (Alpha) with gcc. configures is fine, but it fails
          > with make:
          >
          > Make: Don't know how to make ./configure.af. Stop.
          >
          > GNU make works, but fails to link:
          >
          > gcc -g -O2 -o autotrace atou.o main.o getopt.o getopt1.o
          > libautotrace.a
          > /usr/bin/ld:
          > Unresolved:
          > fmod
          > sqrt
          > hypot
          > acos
          > ceil
          > collect2: ld returned 1 exit status
          > gmake: *** [autotrace] Error 1
          >
          > It seems the makefile forgets to append the -lm for inclusion of the
          > math library. Adding that by hand produces a working executable. (Let me
          > know if you want it by separate email for your download section.)
          >
          > Will try OS/2 and FreeBSD later.
          >
          > Cheers,
          > Stefan
          >
          > On Fri, Mar 23, 2001 at 07:01:49PM +0100, Martin Weber wrote:
          > > A new release of AutoTrace is available:
          > > What's new in AutoTrace 0.27
          >
          > --
          > ============================================================================
          > Stefan A. Deutscher |
          > Donostia International Physics Center | office: ++34-943-018174
          > Universidad del Pais Vasco, Facultad de Quimica | fax : ++34-943-015600
          > Departamento de Fisica de Materiales | home : ++34-943-270647
          > Apartado 1072, San Sebastian 20080, Spain | email : sad@...
          > ============================================================================
          > The early bird gets the worm but the second mouse gets the cheese.
          >
          >
          >
          >
          > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
        • Stefan A. Deutscher
          ... Well, if the only fix is the makefile I d say stick to the version number. Cheers, Stefan --
          Message 4 of 7 , Mar 23, 2001
          • 0 Attachment
            On Sat, Mar 24, 2001 at 03:37:13AM +0900, Masatake YAMATO wrote:
            > > Hi Masatake,
            > >
            > > could you fix this problem?
            > I can. How do we do about version number?
            > I think we should not call the new version 0.27.
            > 0.27a or 0.27.1 or...0.28?

            Well, if the only fix is the makefile I'd say stick to the version
            number. Cheers,
            Stefan


            --
            ============================================================================
            Stefan A. Deutscher |
            Donostia International Physics Center | office: ++34-943-018174
            Universidad del Pais Vasco, Facultad de Quimica | fax : ++34-943-015600
            Departamento de Fisica de Materiales | home : ++34-943-270647
            Apartado 1072, San Sebastian 20080, Spain | email : sad@...
            ============================================================================
            The early bird gets the worm but the second mouse gets the cheese.
          • Masatake YAMATO
            Here is the patch for 0.27(in CVS RELEASE_0_27 is tagged.). This patch fixes the problems reported by Stefan A. Deutscher in Message-ID:
            Message 5 of 7 , Mar 23, 2001
            • 0 Attachment
              Here is the patch for 0.27(in CVS RELEASE_0_27 is tagged.). This
              patch fixes the problems reported by Stefan A. Deutscher
              <sad@...> in Message-ID: <20010323192102.A3714@...>.

              I've already commited this patch to our CVS repository. If you
              use CVS, invoke cvs update.

              ---
              This patch is not updating configure and Makefile.in.
              Therefore you must invoke autorun.sh if you got the original source
              code from sourceforge cvs repository.

              If your base source code is 0.27 released version, run following
              shell script after installing autoconf, automake, autofig. About
              autofig, See HACKING in the distribution.

              Masatake
              ---
              #! /bin/sh

              (autofig --version) < /dev/null > /dev/null 2>&1 || {
              echo
              echo "**Error**: You must have \`autofig' installed to compile Autotrace."
              echo "See HACKING in autotrace soruce directory."
              echo "Abort..."
              exit 1
              }

              autofig autotrace-config.af
              aclocal $ACLOCAL_FLAGS
              automake -a
              autoconf
              ---
              Masatake


              Index: Makefile.am
              ===================================================================
              RCS file: /cvsroot/autotrace/autotrace/Makefile.am,v
              retrieving revision 1.30
              diff -u -r1.30 Makefile.am
              --- Makefile.am 2001/03/11 15:42:34 1.30
              +++ Makefile.am 2001/03/23 18:53:55
              @@ -103,7 +103,8 @@
              libautotrace.a \
              $(MAGICK_LDFLAGS) \
              $(LIBPNG_LDFLAGS) \
              - $(LIBSWF_LDFLAGS)
              + $(LIBSWF_LDFLAGS) \
              + -lm

              m4datadir = $(datadir)/aclocal
              m4data_DATA = autotrace.m4
              @@ -112,5 +113,5 @@
              BUILT_SOURCES=autotrace-config
              autotrace-config: autotrace-config.in

              -%.in: %.af
              +autotrace-config.in: autotrace-config.af
              autofig $<
            • Martin Weber
              Tell it 0.27a. Martin
              Message 6 of 7 , Mar 24, 2001
              • 0 Attachment
                Tell it 0.27a.

                Martin

                Masatake YAMATO schrieb:

                > > Hi Masatake,
                > >
                > > could you fix this problem?
                > I can. How do we do about version number?
                > I think we should not call the new version 0.27.
                > 0.27a or 0.27.1 or...0.28?
                >
                > Masatake
                >
                >
                >
                >
                > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
              Your message has been successfully submitted and would be delivered to recipients shortly.