Loading ...
Sorry, an error occurred while loading the content.

Re: Autotrace on Mac OS X

Expand Messages
  • Martin Weber
    I hope we can resolve some issues. Freetype2 for example is not used by AutoTrace at all but by ImageMagick. If you use ImageMagick you can run into such
    Message 1 of 1 , Aug 5, 2004
    • 0 Attachment
      I hope we can resolve some issues. Freetype2 for example is not used by
      AutoTrace at all but by ImageMagick. If you use ImageMagick you can run into
      such problems that cannot be solve by AutoTrace itself. I forward your mail
      to the AutoTrace mailing list.

      > I don't know if anyone has offered feedback in compiling autotrace under
      > OS X or Darwin... I did this today and ran into some glitches in the
      > First off, let me admit that I am not a terribly experienced open source
      > contributor so diff's and otherwise more direct methods of
      > correction-feedback are beyond me. But here are the things I ran into...
      > * Note I use Fink to install the supporting libs and such (since autotrace
      > is not a supported Fink package as of yet).
      > 1) Libs like libpng, libtiff, libjpeg, libxml2, etc were found in /sw/lib
      > with little issue by your configure script.
      > 2) The freetype lib was an issue in that not only did I need to Fink
      > freetype2, but I needed to modify the Makefile (all I know is how to
      > the fix unfortunately) so that the '-lfreetype' became
      > '-L/sw/lib/freetype2/lib' and this resolved some linkage issues during the
      > 3) I had to do much the same type of massaging to get libplotter to build
      > for pstoedit, and then the same to finally get pstoedit to build. This
      > installed straight from the source 'make install' so it was in the usual
      > /usr/local/bin and /usr/local/lib directories. Yet the makefile/configure
      > did not detect this and errored. I ended up taking the advice that was
      > emitted during the build and added the PSTOEDIT_CONFIG env variable and
      > solved this, but I am sure there is a more acceptable/clean way of doing
      > this.
      > 4) I didn't need to care, but I am scrolling back through the build and
      > realized that configure did not detect libpng or libming either. Both are
      > installed from Fink, both static and shared lib packages. It did find
      > imagemagik though which was done (and installed) to the same location as
      > other libs.
      > The end result of configure was as follows:
      > Configuration:
      > imagemagick output support: yes
      > libpng output support: no
      > swf output support by ming: no
      > pstoedit output support: no
      > Thus my above brute-force edits had to be done to solve the issue. I just
      > wanted to pass this back to you in case these were easy patches that could
      > be made to the configure script to cleanly build on OS X. Hopefully it
      > will be of some help... Sorry I couldn't be more useful with a diff
      > submission, etc, but at least something is better than nothing... :)
      > Jason J. Campbell
      > Production Systems Integrator
      > Day-Timers, Inc.
      > 1 Willow Lane
      > East Texas, PA 18046
      > p.610.530.6540
      > f.610.530.6524
      > e.jason_campbell@...

      NEU: WLAN-Router f�r 0,- EUR* - auch f�r DSL-Wechsler!
      GMX DSL = superg�nstig & kabellos http://www.gmx.net/de/go/dsl
    Your message has been successfully submitted and would be delivered to recipients shortly.