Loading ...
Sorry, an error occurred while loading the content.

Ldsped ERROR

Expand Messages
  • vk4bdj
    Hi..with APRSIS/32 running on AWG port via ldsped and i Transmit in APRSIS/32 i get an Error in the lpsed terminal.. ERROR : Sending data via this connection
    Message 1 of 8 , Jun 14, 2014
    • 0 Attachment
      Hi..with APRSIS/32 running on AWG port via ldsped and i Transmit in APRSIS/32 i get an Error in the lpsed terminal..

      ERROR : Sending data via this connection is not allowed

      anyone got an answer for this

      David VK4BDJ


    • Lee D Bengston
      That sounds familiar. Is ldsped running as root? Lee - K5DAT On Jun 15, 2014 12:15 AM, djmunn@bigpond.com [aprsisce]
      Message 2 of 8 , Jun 15, 2014
      • 0 Attachment

        That sounds familiar.  Is ldsped running as root? 

        Lee - K5DAT

        On Jun 15, 2014 12:15 AM, "djmunn@... [aprsisce]" <aprsisce@yahoogroups.com> wrote:
         

        Hi..with APRSIS/32 running on AWG port via ldsped and i Transmit in APRSIS/32 i get an Error in the lpsed terminal..

        ERROR : Sending data via this connection is not allowed

        anyone got an answer for this

        David VK4BDJ


      • Rob Giuliano
        The most likely cayuse of this error is file permissions. In Linux, every thing you access is a file, and if you don t havewrite access permission, when you
        Message 3 of 8 , Jun 15, 2014
        • 0 Attachment
          The most likely cayuse of this error is file permissions.

          In Linux, every thing you access is a file, and if you don't havewrite  access permission, when you try and write to the file, you will get an error.

          QUICKEST and most complete fix:  add your user name to the group DIALOUT which is commonly assigned to serial ports /dev/ttyS0 to about /dev/ttyS31 if it is a old fashion physical port.
          It may not be the same for ttyUSB0 - ttyUSB#, but I think it is.

          The change is as simple as:
             as ROOT, edit the file /etc/group
          and set
             dialout:x:20:{username}

          I do not recommend changing permissions,as it will get set back to the default by Linux on most upgrades or system changes. You could run as root, but since there is lots of access from outside (over RF), that is leaving yourself open to someone trying to get access (although not very likely to happen), and is not good practice on Linux, unless absolutely necessary.

          Another cause would be the default settings of Ldsped may be to listen only.  It has been a long time since I ran itm but it seems there is a setting in the config to allow transmitting. (I have a copy of v1.16 for the WRT54)

          Good luck!
          Robert Giuliano
          KB8RCO


          ---------------------------------------------


          From: "djmunn@... [aprsisce]" <aprsisce@yahoogroups.com>
          To: aprsisce@yahoogroups.com
          Sent: Sunday, June 15, 2014 12:15 AM
          Subject: [aprsisce] Ldsped ERROR

           
          Hi..with APRSIS/32 running on AWG port via ldsped and i Transmit in APRSIS/32 i get an Error in the lpsed terminal..

          ERROR : Sending data via this connection is not allowed

          anyone got an answer for this

          David VK4BDJ



        • Lee D Bengston
          To clarify, ldsped needs to run as root, i.e. use sudo ldsped. This is needed in order to have write access to an ax25 interface. It is indeed a permissions
          Message 4 of 8 , Jun 15, 2014
          • 0 Attachment

            To clarify, ldsped needs to run as root,  i.e. use sudo ldsped.  This is needed in order to have write access to an ax25 interface.  It is indeed a permissions issue as Rob said.  Joining the group dialout would work if you were accessing a serial port, but I don't think that will help with ax25 networking.

            Lee - K5DAT

            On Jun 15, 2014 8:17 AM, "Lee D Bengston" <kilo5dat@...> wrote:

            That sounds familiar.  Is ldsped running as root? 

            Lee - K5DAT

            On Jun 15, 2014 12:15 AM, "djmunn@... [aprsisce]" <aprsisce@yahoogroups.com> wrote:
             

            Hi..with APRSIS/32 running on AWG port via ldsped and i Transmit in APRSIS/32 i get an Error in the lpsed terminal..

            ERROR : Sending data via this connection is not allowed

            anyone got an answer for this

            David VK4BDJ


          • David
            Hi Rob and Lee........dailout set to my username permissions all set to root...starting sudo ldsped it happens when it tries to send a K frame on startup of
            Message 5 of 8 , Jun 15, 2014
            • 0 Attachment
              Hi Rob and Lee........dailout set to my username
              permissions all set to root...starting "sudo ldsped"

              it happens when it tries to send a K frame on startup of APRSIS/32 Beacon
              i wonder if i have that config set up correctly

              it will send ok with the L frame

              will keep on digging


              David VK4BDJ


              On 16/06/14 00:40, Rob Giuliano kb8rco@... [aprsisce] wrote:
               
              The most likely cayuse of this error is file permissions.

              In Linux, every thing you access is a file, and if you don't havewrite  access permission, when you try and write to the file, you will get an error.

              QUICKEST and most complete fix:  add your user name to the group DIALOUT which is commonly assigned to serial ports /dev/ttyS0 to about /dev/ttyS31 if it is a old fashion physical port.
              It may not be the same for ttyUSB0 - ttyUSB#, but I think it is.

              The change is as simple as:
                 as ROOT, edit the file /etc/group
              and set
                 dialout:x:20:{username}

              I do not recommend changing permissions,as it will get set back to the default by Linux on most upgrades or system changes. You could run as root, but since there is lots of access from outside (over RF), that is leaving yourself open to someone trying to get access (although not very likely to happen), and is not good practice on Linux, unless absolutely necessary.

              Another cause would be the default settings of Ldsped may be to listen only.  It has been a long time since I ran itm but it seems there is a setting in the config to allow transmitting. (I have a copy of v1.16 for the WRT54)

              Good luck!
              Robert Giuliano
              KB8RCO


              ---------------------------------------------


              From: "djmunn@... [aprsisce]" <aprsisce@yahoogroups.com>
              To: aprsisce@yahoogroups.com
              Sent: Sunday, June 15, 2014 12:15 AM
              Subject: [aprsisce] Ldsped ERROR

               
              Hi..with APRSIS/32 running on AWG port via ldsped and i Transmit in APRSIS/32 i get an Error in the lpsed terminal..

              ERROR : Sending data via this connection is not allowed

              anyone got an answer for this

              David VK4BDJ




            • Lee D Bengston
              Hi David, I don;t see that error in ldsped when I transmit with APRSIS32. Below is a copy of what is in my ldsped.conf file in case it helps. I have several
              Message 6 of 8 , Jun 15, 2014
              • 0 Attachment
                Hi David,

                I don;t see that error in ldsped when I transmit with APRSIS32.  Below is a copy of what is in my ldsped.conf file in case it helps.  I have several things commented out.

                #  ldsped.c - agwpe linux replacement
                #
                #  Copyright (C) 2006,2009 Lieven De Samblanx, ON7LDS. All rights reserved
                #
                #  This is the ldsped configuration file.

                #Loglevel, higher = more verbose.
                #Overrules the commandline setting
                #
                #The commandline setting will be replaced from the moment
                # this keyword is processed. If we set it here, in the beginning
                # of the config file, it will be applied immediately.

                loglevel 4

                # define packet engine ports
                rw *:8000
                rw *:8001
                rw *:8002

                #define passwords
                #password K5DAT LDS
                #password ON4DVT DVT

                #define traffic object :
                # - socket (for mrtg)
                # trafficport *:8005

                #station status text
                # stationtext $V (check www.on7lds.net)

                # - amount of traffic status beacons per hour
                # traffic 2

                # - Name of the object
                # trafficname TRAFMON
                # trafficpath WIDE3-3

                # - Owner call
                # trafficcall K5DAT

                # - position
                trafficpos 3907.01N\07733.30W?

                #       -1 = send traffic object on all ports
                # 0,1, ... = send traffic object on specified port
                # trafficsendport -1

                #define probe :

                probe 0

                # probestring PHG20301/ldsped probe
                # probepath WIDE2-2
                # probesendport -1
                # probecall K5DAT


                #If you use Paclink, set this to 1
                #It produces a less readable portinfo string,
                # but Paclink is expecting a rather strict string layout
                #No other programs have been mentioned to require this

                port_info_compatible 0


                #Since there seems to be no way for ldsped to find out
                # these parameters, you should put them here, so ldsped
                # can answer the 'g' frame.
                #If you application(s) do not use the 'g' frame, it
                # is not necessary to set the parameters here.
                #Again : these paramaters are ONLY informational for ldsped
                # they are not used anywhere (only for answering the 'g' frame)
                TX_DELAY  25
                TX_TAIL    4
                PERSIST  128
                SLOTTIME  15
                MAXFRAME   6


                #----- APRSQ query scripts :

                #scriptuser is the UID which will be used to execute the scripts.
                # if none set, 65534 (user nobody) will be used
                #scriptuser 1000

                #scriptgroup is the GID which will be used to execute the scripts.
                # if none set, 65534 (group nogroup) will be used
                #scriptgroup 1000

                #Here come the query / script pairs.
                #scriptpath datum /bin/date
                #scriptpath tijd /bin/date +%H:%M:%S
                #scriptpath up /usr/bin/uptime


                Regards,
                Lee - K5DAT

                On Sun, Jun 15, 2014 at 6:30 PM, David djmunn@... [aprsisce] <aprsisce@yahoogroups.com> wrote:
                 

                Hi Rob and Lee........dailout set to my username
                permissions all set to root...starting "sudo ldsped"

                it happens when it tries to send a K frame on startup of APRSIS/32 Beacon
                i wonder if i have that config set up correctly

                it will send ok with the L frame

                will keep on digging


                David VK4BDJ




                On 16/06/14 00:40, Rob Giuliano kb8rco@... [aprsisce] wrote:
                 
                The most likely cayuse of this error is file permissions.

                In Linux, every thing you access is a file, and if you don't havewrite  access permission, when you try and write to the file, you will get an error.

                QUICKEST and most complete fix:  add your user name to the group DIALOUT which is commonly assigned to serial ports /dev/ttyS0 to about /dev/ttyS31 if it is a old fashion physical port.
                It may not be the same for ttyUSB0 - ttyUSB#, but I think it is.

                The change is as simple as:
                   as ROOT, edit the file /etc/group
                and set
                   dialout:x:20:{username}

                I do not recommend changing permissions,as it will get set back to the default by Linux on most upgrades or system changes. You could run as root, but since there is lots of access from outside (over RF), that is leaving yourself open to someone trying to get access (although not very likely to happen), and is not good practice on Linux, unless absolutely necessary.

                Another cause would be the default settings of Ldsped may be to listen only.  It has been a long time since I ran itm but it seems there is a setting in the config to allow transmitting. (I have a copy of v1.16 for the WRT54)

                Good luck!
                Robert Giuliano
                KB8RCO


                ---------------------------------------------


                From: "djmunn@... [aprsisce]" <aprsisce@yahoogroups.com>
                To: aprsisce@yahoogroups.com
                Sent: Sunday, June 15, 2014 12:15 AM
                Subject: [aprsisce] Ldsped ERROR

                 
                Hi..with APRSIS/32 running on AWG port via ldsped and i Transmit in APRSIS/32 i get an Error in the lpsed terminal..

                ERROR : Sending data via this connection is not allowed

                anyone got an answer for this

                David VK4BDJ





              • David
                Hi Lee..tnx for your copy of config changed mine and it works no ERRORS David
                Message 7 of 8 , Jun 15, 2014
                • 0 Attachment
                  Hi Lee..tnx for your copy of config
                  changed mine and it works no ERRORS

                  David




                  On 16/06/14 10:14, Lee D Bengston kilo5dat@... [aprsisce] wrote:
                   
                  Hi David,

                  I don;t see that error in ldsped when I transmit with APRSIS32.  Below is a copy of what is in my ldsped.conf file in case it helps.  I have several things commented out.

                  #  ldsped.c - agwpe linux replacement
                  #
                  #  Copyright (C) 2006,2009 Lieven De Samblanx, ON7LDS. All rights reserved
                  #
                  #  This is the ldsped configuration file.

                  #Loglevel, higher = more verbose.
                  #Overrules the commandline setting
                  #
                  #The commandline setting will be replaced from the moment
                  # this keyword is processed. If we set it here, in the beginning
                  # of the config file, it will be applied immediately.

                  loglevel 4

                  # define packet engine ports
                  rw *:8000
                  rw *:8001
                  rw *:8002

                  #define passwords
                  #password K5DAT LDS
                  #password ON4DVT DVT

                  #define traffic object :
                  # - socket (for mrtg)
                  # trafficport *:8005

                  #station status text
                  # stationtext $V (check www.on7lds.net)

                  # - amount of traffic status beacons per hour
                  # traffic 2

                  # - Name of the object
                  # trafficname TRAFMON
                  # trafficpath WIDE3-3

                  # - Owner call
                  # trafficcall K5DAT

                  # - position
                  trafficpos 3907.01N\07733.30W?

                  #       -1 = send traffic object on all ports
                  # 0,1, ... = send traffic object on specified port
                  # trafficsendport -1

                  #define probe :

                  probe 0

                  # probestring PHG20301/ldsped probe
                  # probepath WIDE2-2
                  # probesendport -1
                  # probecall K5DAT


                  #If you use Paclink, set this to 1
                  #It produces a less readable portinfo string,
                  # but Paclink is expecting a rather strict string layout
                  #No other programs have been mentioned to require this

                  port_info_compatible 0


                  #Since there seems to be no way for ldsped to find out
                  # these parameters, you should put them here, so ldsped
                  # can answer the 'g' frame.
                  #If you application(s) do not use the 'g' frame, it
                  # is not necessary to set the parameters here.
                  #Again : these paramaters are ONLY informational for ldsped
                  # they are not used anywhere (only for answering the 'g' frame)
                  TX_DELAY  25
                  TX_TAIL    4
                  PERSIST  128
                  SLOTTIME  15
                  MAXFRAME   6


                  #----- APRSQ query scripts :

                  #scriptuser is the UID which will be used to execute the scripts.
                  # if none set, 65534 (user nobody) will be used
                  #scriptuser 1000

                  #scriptgroup is the GID which will be used to execute the scripts.
                  # if none set, 65534 (group nogroup) will be used
                  #scriptgroup 1000

                  #Here come the query / script pairs.
                  #scriptpath datum /bin/date
                  #scriptpath tijd /bin/date +%H:%M:%S
                  #scriptpath up /usr/bin/uptime


                  Regards,
                  Lee - K5DAT

                  On Sun, Jun 15, 2014 at 6:30 PM, David djmunn@... [aprsisce] <aprsisce@yahoogroups.com> wrote:
                   

                  Hi Rob and Lee........dailout set to my username
                  permissions all set to root...starting "sudo ldsped"

                  it happens when it tries to send a K frame on startup of APRSIS/32 Beacon
                  i wonder if i have that config set up correctly

                  it will send ok with the L frame

                  will keep on digging


                  David VK4BDJ




                  On 16/06/14 00:40, Rob Giuliano kb8rco@... [aprsisce] wrote:
                   
                  The most likely cayuse of this error is file permissions.

                  InLinux, every thing you access is a file, and if you don't havewrite  access permission, when you try and write to the file, you will get an error.

                  QUICKEST and most complete fix:  add your user name to the group DIALOUT which is commonly assigned to serial ports /dev/ttyS0 to about /dev/ttyS31 if it is a old fashion physical port.
                  It may not be the same for ttyUSB0 - ttyUSB#, but I think it is.

                  The change is as simple as:
                     as ROOT, edit the file /etc/group
                  and set
                     dialout:x:20:{username}

                  I do not recommend changing permissions,as it will get set back to the default by Linux on most upgrades or system changes. You could run as root, but since there is lots of access from outside (over RF), that is leaving yourself open to someone trying to get access (although not very likely to happen), and is not good practice on Linux, unless absolutely necessary.

                  Another cause would be the default settings of Ldsped may be to listen only.  It has been a long time since I ran itm but it seems there is a setting in the config to allow transmitting. (I have a copy of v1.16 for the WRT54)

                  Good luck!
                  Robert Giuliano
                  KB8RCO


                  ---------------------------------------------


                  From: "djmunn@... [aprsisce]" <aprsisce@yahoogroups.com>
                  To: aprsisce@yahoogroups.com
                  Sent: Sunday, June 15, 2014 12:15 AM
                  Subject: [aprsisce] Ldsped ERROR

                   
                  Hi..with APRSIS/32 running on AWG port via ldsped and i Transmit in APRSIS/32 i get an Error in the lpsed terminal..

                  ERROR : Sending data via this connection is not allowed

                  anyone got an answer for this

                  David VK4BDJ






                • Lee D Bengston
                  Good to hear! I first tried ldsped in 2011, and I ve been using essentially the same config ever since. It had been so long since I had figured out what
                  Message 8 of 8 , Jun 15, 2014
                  • 0 Attachment
                    Good to hear!  I first tried ldsped in 2011, and I've been using essentially the same config ever since.  It had been so long since I had figured out what worked that I could not remember any "silver bullets", but I thought there was at least one in there somewhere.

                    Lee


                    On Sun, Jun 15, 2014 at 8:43 PM, David djmunn@... [aprsisce] <aprsisce@yahoogroups.com> wrote:
                     

                    Hi Lee..tnx for your copy of config
                    changed mine and it works no ERRORS

                    David


                  Your message has been successfully submitted and would be delivered to recipients shortly.