Loading ...
Sorry, an error occurred while loading the content.

t3-micro

Expand Messages
  • wellmanl
    Am having trouble configuring my t3-micro to aprsis32. I am getting the following on the log Port(T3-Micro):2013-08-18T03:41:35.588 KISS:Ignoring SMACK
    Message 1 of 4 , Aug 17 8:48 PM
    • 0 Attachment
      Am having trouble configuring my t3-micro to aprsis32.
      I am getting the following on the log

      Port(T3-Micro):2013-08-18T03:41:35.588 KISS:Ignoring SMACK Checksum[73]:<C0 F0>$GPGGA,034143.085,3455.2724,N,12026.5183,W,0,0,,181.8,M,-31.8,M,,*76<0D 0A C0>

      Port(T3-Micro):2013-08-18T03:41:35.588 KISS:Processing MultiPort[7] as 0[73]:<C0 F0>$GPGGA,034143.085,3455.2724,N,12026.5183,W,0,0,,181.8,M,-31.8,M,,*76<C0 C0 C0>

      Port(T3-Micro):2013-08-18T03:41:35.693 KISS:Ignoring SMACK Checksum[73]:<C0 F0>$GPRMC,034143.085,V,3455.2724,N,12026.5183,W,0.00,0.00,180813,,,N*67<0D 0A C0>

      Port(T3-Micro):2013-08-18T03:41:35.693 KISS:Processing MultiPort[7] as 0[73]:<C0 F0>$GPRMC,034143.085,V,3455.2724,N,12026.5183,W,0.00,0.00,180813,,,N*67<C0 C0 C0>

      Port(T3-Micro):2013-08-18T03:41:36.293 Flushed[1]:<C0>


      what I normally xmit for lat/lon is
      3227.56N
      08625.76W

      Am I just not getting a fix or what?
    • Mark Petiford
      I don t have the NMEA spec close at hand right now, but I think yours is working.  This is what my T-3 Micro port log says: Before Lock-on: Port(T-3
      Message 2 of 4 , Aug 17 9:34 PM
      • 0 Attachment
        I don't have the NMEA spec close at hand right now, but I think yours is working.  This is what my T-3 Micro port log says:

        Before Lock-on:
        Port(T-3 Micro):2013-08-18T04:12:25.594 KISS:Ignoring SMACK Checksum[73]:<C0 F0>$GPRMC,041225.086,V,9000.0000,N,00000.0000,E,0.00,0.00,180813,,,N*72<0D 0A C0>
        Port(T-3 Micro):2013-08-18T04:12:25.594 KISS:Processing MultiPort[7] as 0[73]:<C0 F0>$GPRMC,041225.086,V,9000.0000,N,00000.0000,E,0.00,0.00,180813,,,N*72<C0 C0 C0>
        Port(T-3 Micro):2013-08-18T04:12:26.194 Flushed[1]:<C0>

        Note the values before the "N" and the "E".  Compare them to the after lock-on values:

        After Lock-on:
        Port(T-3 Micro):2013-08-18T04:12:55.432 KISS:Ignoring SMACK Checksum[73]:<C0 F0>$GPRMC,041255.000,A,3423.7484,N,11832.2384,W,0.09,0.00,180813,,,A*7C<0D 0A C0>
        Port(T-3 Micro):2013-08-18T04:12:55.432 KISS:Processing MultiPort[7] as 0[73]:<C0 F0>$GPRMC,041255.000,A,3423.7484,N,11832.2384,W,0.09,0.00,180813,,,A*7C<C0 C0 C0>
        Port(T-3 Micro):2013-08-18T04:12:56.032 Flushed[1]:<C0>

        Look in the lower right hand corner of the APRSIS32 screen, does it say it has a "FIX"?  It should also tell you how many satellites it is utilizing at the bottom of the screen (assuming you have Configure>Screen>Satellites checked).  It does not tell you the health of the individual satellites since it does not support the NMEA sentence that provids that info.  It works fine without it, though.  It looks to me like yours is locked on and is passing GPS data through as it should.

        Lynn or someone else here may be able to help with the "Ignoring SMACK Checksum", but it seems to work fine even with that message.

        Mark
        KE6BB


        From: wellmanl <wellmanl@...>
        To: aprsisce@yahoogroups.com
        Sent: Saturday, August 17, 2013 8:48 PM
        Subject: [aprsisce] t3-micro

         
        Am having trouble configuring my t3-micro to aprsis32...

        Am I just not getting a fix or what?



      • Mark Petiford
        Wow!  Just noticed the difference between you normal Lat/Lon and what the T3 is reporting.  How many satellites is it using (bottom of the screen with
        Message 3 of 4 , Aug 17 9:59 PM
        • 0 Attachment
          Wow!  Just noticed the difference between you normal Lat/Lon and what the T3 is reporting.  How many satellites is it using (bottom of the screen with Configure>Screen>Satellites checked)?

          Mark
          KE6BB



          From: wellmanl <wellmanl@...>
          To: aprsisce@yahoogroups.com
          Sent: Saturday, August 17, 2013 8:48 PM
          Subject: [aprsisce] t3-micro

           
          Am having trouble configuring my t3-micro to aprsis32.
          I am getting the following on the log

          Port(T3-Micro):2013-08-18T03:41:35.588 KISS:Ignoring SMACK Checksum[73]:<C0 F0>$GPGGA,034143.085,3455.2724,N,12026.5183,W,0,0,,181.8,M,-31.8,M,,*76<0D 0A C0>

          Port(T3-Micro):2013-08-18T03:41:35.588 KISS:Processing MultiPort[7] as 0[73]:<C0 F0>$GPGGA,034143.085,3455.2724,N,12026.5183,W,0,0,,181.8,M,-31.8,M,,*76<C0 C0 C0>

          Port(T3-Micro):2013-08-18T03:41:35.693 KISS:Ignoring SMACK Checksum[73]:<C0 F0>$GPRMC,034143.085,V,3455.2724,N,12026.5183,W,0.00,0.00,180813,,,N*67<0D 0A C0>

          Port(T3-Micro):2013-08-18T03:41:35.693 KISS:Processing MultiPort[7] as 0[73]:<C0 F0>$GPRMC,034143.085,V,3455.2724,N,12026.5183,W,0.00,0.00,180813,,,N*67<C0 C0 C0>

          Port(T3-Micro):2013-08-18T03:41:36.293 Flushed[1]:<C0>

          what I normally xmit for lat/lon is
          3227.56N
          08625.76W

          Am I just not getting a fix or what?



        • Lynn W Deffenbaugh (Mr)
          Your GPS doesn t have a fix yet, so APRSISCE/32 isn t using the data that s being displayed. That V near the start: ...5,V,34... will change to an A when it s
          Message 4 of 4 , Aug 18 3:25 AM
          • 0 Attachment
            Your GPS doesn't have a fix yet, so APRSISCE/32 isn't using the data
            that's being displayed. That V near the start:

            ...5,V,34...

            will change to an A when it's got a fix. Take it outside for a while,
            sometimes many minutes for the first time, and it should lock on.

            I suspect I need to suppress the SMACK and MultiPort prints, but for
            now, they're handy debug.

            I'm not sure if the T3-micro passes through the GPGSV and GPGSA
            sentences. If it does, you'll get the satellites at the bottom of your
            map. If it doesn't, they'll stay blank, but the Fix (your's probably
            says "No Fix") should show up.

            You also need to have the GPS/NMEA checked on your RF port, NO NMEA Port
            configured, and GPS will need to be enabled, just like for all
            passthrough sources of GPS information.

            Lynn (D) - KJ4ERJ - Author of APRSISCE for Windows Mobile and Win32

            On 8/17/2013 11:48 PM, wellmanl wrote:
            > Am having trouble configuring my t3-micro to aprsis32.
            > I am getting the following on the log
            >
            > Port(T3-Micro):2013-08-18T03:41:35.588 KISS:Ignoring SMACK Checksum[73]:<C0 F0>$GPGGA,034143.085,3455.2724,N,12026.5183,W,0,0,,181.8,M,-31.8,M,,*76<0D 0A C0>
            >
            > Port(T3-Micro):2013-08-18T03:41:35.588 KISS:Processing MultiPort[7] as 0[73]:<C0 F0>$GPGGA,034143.085,3455.2724,N,12026.5183,W,0,0,,181.8,M,-31.8,M,,*76<C0 C0 C0>
            >
            > Port(T3-Micro):2013-08-18T03:41:35.693 KISS:Ignoring SMACK Checksum[73]:<C0 F0>$GPRMC,034143.085,V,3455.2724,N,12026.5183,W,0.00,0.00,180813,,,N*67<0D 0A C0>
            >
            > Port(T3-Micro):2013-08-18T03:41:35.693 KISS:Processing MultiPort[7] as 0[73]:<C0 F0>$GPRMC,034143.085,V,3455.2724,N,12026.5183,W,0.00,0.00,180813,,,N*67<C0 C0 C0>
            >
            > Port(T3-Micro):2013-08-18T03:41:36.293 Flushed[1]:<C0>
            >
            >
            > what I normally xmit for lat/lon is
            > 3227.56N
            > 08625.76W
            >
            > Am I just not getting a fix or what?
            >
            >
            >
            >
            >
            > ------------------------------------
            >
            > Yahoo! Groups Links
            >
            >
            >
            >
          Your message has been successfully submitted and would be delivered to recipients shortly.