Loading ...
Sorry, an error occurred while loading the content.

Re: [aprsisce] Re: APRSIS32 running under WINE

Expand Messages
  • Rob Giuliano
    Yes, you can edit the XML file, but it becomes much easier if the port already exits.  Sounds like you do have a port already.   Couple of things first:   
    Message 1 of 22 , Jan 7, 2013
    • 0 Attachment
      Yes, you can edit the XML file, but it becomes much easier if the port already exits.  Sounds like you do have a port already.
       
      Couple of things first:
         Are you sure the COM1 file is linked to the proper device?
            typically something like /dev/ttyUSB0
             If Com1 points to the INCORRECT device, you can add a second link (COM2) to the correct /dev ffile.
       
      The port should look something like this:
       <!--RFPort[0]-->
         <RFPort Name="D710">
            <Protocol>KISS</Protocol>                               You said this was the protocol
            <Device>COM2:9600,N,8,1</Device>               Set the same as you {home}/.wine/dosdevices           
            <RfBaud>1200</RfBaud>
            <OpenCmd>~!!0</OpenCmd>                            These should match the WIKI for D710 KISS mode of 
            <CloseCmd>~!!0</CloseCmd>                            These should match the WIKI for D710 KISS mode of 
            <QuietTime>0</QuietTime>
            <Enabled>1</Enabled>
            <XmitEnabled>1</XmitEnabled>
            <ProvidesNMEA>0</ProvidesNMEA>
            <RFtoISEnabled>1</RFtoISEnabled>
            <IStoRFEnabled>1</IStoRFEnabled>
            <MyCallNot3rd>1</MyCallNot3rd>
            <BeaconingEnabled>1</BeaconingEnabled>
            <BeaconPath></BeaconPath>
            <BulletinObjectEnabled>1</BulletinObjectEnabled>
            <MessagesEnabled>1</MessagesEnabled>
             <MessagePath></MessagePath>
            <TelemetryEnabled>0</TelemetryEnabled>
            <TelemetryPath></TelemetryPath>
            <!--DigiXform-->
         </RFPort>
      <!--RFPort[0]-->
       
      The other part that helps is editing the registry according to the WIKI (don't have access to my Linux box to help here).
        
       
      Hope this helps.
       
      Robert Giuliano
      KB8RCO


      ---------------------------------------------
      From: jandgandjochem <vk2jng@...>
      To: aprsisce@yahoogroups.com
      Sent: Monday, January 7, 2013 6:54 PM
      Subject: [aprsisce] Re: APRSIS32 running under WINE
       
      Hi,

      Thanks for your reply. Followed your instruction to the letter but still no coms to the D710.

      After the second command executed I got:

      ln: com1: File exists

      I then fired up APRSIS32 and under configure > New Port I chose KISS and then in the new window I chose COMn Serial but the window this is in is so small and cannot be made larger. I cannot see where I can set the D710 to COM1.

      I used to run APRSIS32 under windows 7 but I cannot remember where the setting for COM1 was then.

      Maybe it is somewhere there but I cannot see it because that window is so small.

      Just wondering if I can set the port to COM1 by editing the XML file???

      Your help is much appreciated,

      Gerard VK2JNG

      --- In mailto:aprsisce%40yahoogroups.com, Matthew Willis wrote:
      >
      > In your home directory (/Users/yourname), there will be a hidden folder named .wine
      > Inside that folder will be another folder named dosdevices.
      > You need to make a symlink from com1 to the Keyspan /dev device
      >
      > Step by step would be:
      > 1. Launch /Applications/Utilities/Terminal
      > 2. In that Terminal window type the following:
      > cd ~/.wine/dosdevices
      > ln -s /dev/KeySerial1 com1
      >
      > Then in APRSIS set the serial port for the Kenwood to be COM1.
      >
      > You'll only have the /dev/KeySerial1 device while the Keyspan USB adapter is plugged in.
      >
      > Try that and let me know how it works.
      >
      > -lilmatt
      > N2PYI
      >
      >
      > On Jan 7, 2013, at 5:52 PM, "jandgandjochem" wrote:
      >
      > > Bumped up the list as I am still hoping to get this to work.
      > >
      > > APRSIS32 runs very well on my MACbook Pro under WINE but I cannot get the KeySpan USB to serial adaptor working. I have the Kenwood D710 hooked up in PACKET mode but when I configure the port for the D710 and then go to enable that same port it is "Greyed Out".
      > >
      > > When I run a terminal program (Z-Term) it talks happily with my D710 and I can put the D710 in KISS mode etc. Whilst hooked up to the terminal program I can see all the APRS station received via RF in the terminal window.
      > >
      > > Just cannot get the D710 port working under APRSIS32.
      > >
      > > Still hoping for a solution here as others have done it. Trouble is I know nothing about WINE or any setting associated with my problem.
      > >
      > > Hope someone will be able to guide me here,
      > >
      > > Thanks in advance,
      > >
      > > Gerard VK2JNG
      > >
      > > --- In mailto:aprsisce%40yahoogroups.com, "jandgandjochem" wrote:
      > > >
      > > > Hi all,
      > > >
      > > > With the help of this website: http://www.davidbaumgold.com/tutorials/wine-mac/
      > > > All credit to David Baumgold, the owner of the site.
      > > >
      > > >
      > > >
      > > > I got APRSIS32 running nicely under WINE on my MacBook pro.
      > > >
      > > > The thing I do not know how to get going is my Keyspan USB to serial converter so that I can hookup my D710.
      > > >
      > > > I have the Mac drivers for the Keyspan installed on my Mac (not under WINE) and the Keyspan converter is working fine when I use a terminal program to talk to my D710 in packet mode.
      > > >
      > > > However, I don't know how to get the Keyspan converter working for APRSIS32 when running under WINE.
      > > >
      > > > Can someone shine some light on this which would be very much appreciated.
      > > >
      > > > Thanks
      > > > Gerard VK2JNG
      > > >
      > >
      > >
      >

    Your message has been successfully submitted and would be delivered to recipients shortly.