Loading ...
Sorry, an error occurred while loading the content.

Re: [aprsisce] Re: Log playback?

Expand Messages
  • Keith VE7GDH
    Lynn K4JERJ wrote... ... Right, there is more than one kind of playback. Going by the subject, it could be playback of a log file. UI-View, can log everything,
    Message 1 of 25 , Jul 4, 2012
    • 0 Attachment
      Lynn K4JERJ wrote...

      > Help me out here, what does playback have to do with the
      > messaging interface? Got me confused here.

      Right, there is more than one kind of playback. Going by the
      subject, it could be playback of a log file. UI-View, can log
      everything, but not just one particular station. Perhaps you could
      add that ability. In relation to messages, perhaps he was referring
      to it having the messages read to him via a synthesized voice on the
      speaker. Kinda nice if you are multi-tasking or driving or otherwise
      occupied. Or he could just be referring to scrolling a list of past
      received (or sent) messages and viewing them... or having it
      save a copy of messages so they could be viewed after a restart.

      73 es cul - Keith VE7GDH
      --
      "I may be lost, but I know exactly where I am!"
    • Lynn W Deffenbaugh (Mr)
      ... Got a Win32/WinMo API for text-to-speech you can point me to? ... In my mind if not on my ToDo list. Especially saving and recalling/restarting
      Message 2 of 25 , Jul 4, 2012
      • 0 Attachment
        On 7/4/2012 3:52 PM, Keith VE7GDH wrote:
        > Lynn K4JERJ wrote...
        >
        >> Help me out here, what does playback have to do with the
        >> messaging interface? Got me confused here.
        > In relation to messages, perhaps he was referring
        > to it having the messages read to him via a synthesized voice on the
        > speaker. Kinda nice if you are multi-tasking or driving or otherwise
        > occupied. Or he could just be referring to scrolling a list of past
        > received (or sent) messages and viewing them...

        Got a Win32/WinMo API for text-to-speech you can point me to?

        > or having it
        > save a copy of messages so they could be viewed after a restart.

        In my mind if not on my ToDo list. Especially saving and
        recalling/restarting unacknowledged pending outbound messages.

        Lynn (D) - KJ4ERJ - Author of APRSISCE for Windows Mobile and Win32
      • Kim
        Hi All, I would find it very usefull to be able to revisit messages that have been previously read.. I often go back to old messages if I happen to remember
        Message 3 of 25 , Jul 4, 2012
        • 0 Attachment
          Hi All,

          I would find it very usefull to be able to revisit messages that have been previously read.. I often go back to old messages if I happen to remember the callsign of the station involved..

          So the useful feature would be single place to look at all old messages.. I am mainly interested in those that have been in the current run of the program... not woried so much about having them saved and reviewable over a restart.. It's more about remembering the call sign than any thing else..

          Once I have the call, If I need to see the actual messages I can access them on aprs.fi...

          ... For me this is NOT a high priority feature, but something for the todo list, to be done well after the IS-RF work....

          73 Kim

          --- In aprsisce@yahoogroups.com, "Lynn W Deffenbaugh (Mr)" <kj4erj@...> wrote:
          >
          > On 7/4/2012 3:52 PM, Keith VE7GDH wrote:
          > > Lynn K4JERJ wrote...
          > >
          > >> Help me out here, what does playback have to do with the
          > >> messaging interface? Got me confused here.
          > > In relation to messages, perhaps he was referring
          > > to it having the messages read to him via a synthesized voice on the
          > > speaker. Kinda nice if you are multi-tasking or driving or otherwise
          > > occupied. Or he could just be referring to scrolling a list of past
          > > received (or sent) messages and viewing them...
          >
          > Got a Win32/WinMo API for text-to-speech you can point me to?
          >
          > > or having it
          > > save a copy of messages so they could be viewed after a restart.
          >
          > In my mind if not on my ToDo list. Especially saving and
          > recalling/restarting unacknowledged pending outbound messages.
          >
          > Lynn (D) - KJ4ERJ - Author of APRSISCE for Windows Mobile and Win32
          >
        • Keith VE7GDH
          Lynn KJ4ERJ wrote... ... It s a standard feature in UI-View to be able to have it speak messages directed to the users callsign-SSID, but for it to actually
          Message 4 of 25 , Jul 4, 2012
          • 0 Attachment
            Lynn KJ4ERJ wrote...

            > Got a Win32/WinMo API for text-to-speech you can point me to?

            It's a standard feature in UI-View to be able to have it "speak"
            messages directed to the users callsign-SSID, but for it to actually
            work, the user must install Microsoft's MS Agent. There's a link
            in the help, so it's easy for the user to go and grab it. There's an
            option to have it also "speak" bulletins as well as messages.

            www.microsoft.com/msagent

            Without MS Agent installed, there is an option to play a WAV file
            when a new message comes in, or to play a custom WAV file... e.g.
            KJ4ERJ .WAV if a message from you was installed. The message
            window can also pop up to the foreground when a message comes
            in. This can be a nice feature or a nuisance if you are multi-tasking
            and trying to get something else done while someone else peppers
            you with a whole series of messages. 8-)

            There are also options to have it save messages. With this enabled,
            the user can view a folder where the messages are stored under
            the callsign of the sender. It can also save bulletins.

            To send a message, the user would either type in the callsign in
            the TO field, and select port I (Internet) or 1 (one) for RF if there's
            just one radio port and type the message in and hit send. Alternatively,
            they could double-click on a received message to automatically
            enter the callsign in the TO field. Yet another option is to right-click
            on a station on the map and choose "send message". Actually there
            are quite a right-click options for clicking on a station including
            the ability to add custom "right click URLs" such as to look up
            a particular callsign, or to view the station in findu.com or
            aprs.fi, or to view the raw data at either site. A station can be
            pinged or queried from a right click.

            73 es cul - Keith VE7GDH
            --
            "I may be lost, but I know exactly where I am!"
          • KE6BB
            Maybe the ability to scroll back thru previously received messages rather than the program forgetting them as soon as they are read, like it does now? That
            Message 5 of 25 , Jul 4, 2012
            • 0 Attachment
              Maybe the ability to scroll back thru previously received messages rather than the program forgetting them as soon as they are read, like it does now? That might be easy (at least in the minds of us non-programmers <grin>). Lynn might even be able to make it a user configurable parameter where you could set it, i.e. "Keep last XX messages", and once the buffer has XX messages in it, it would start deleting the oldest ones first. Maybe a time parameter would be better, "Keep messages less than YYY minutes old." Just a thought.

              Mark
              KE6BB

              --- In aprsisce@yahoogroups.com, "Kim" <vk2asy@...> wrote:
              >
              > Hi All,
              >
              > I would find it very usefull to be able to revisit messages that have been previously read.. I often go back to old messages if I happen to remember the callsign of the station involved..
              >
              > So the useful feature would be single place to look at all old messages.. I am mainly interested in those that have been in the current run of the program... not woried so much about having them saved and reviewable over a restart.. It's more about remembering the call sign than any thing else..
              >
              > Once I have the call, If I need to see the actual messages I can access them on aprs.fi...
              >
              > ... For me this is NOT a high priority feature, but something for the todo list, to be done well after the IS-RF work....
              >
              > 73 Kim
              >
            • Keith VE7GDH
              Mark KE6BB wrote... ... Just for those that haven t used UI-View, that program has a separate message window. Sent and received messages can be viewed, and
              Message 6 of 25 , Jul 4, 2012
              • 0 Attachment
                Mark KE6BB wrote...

                > Maybe the ability to scroll back thru previously received messages...

                Just for those that haven't used UI-View, that program has a separate
                "message" window. Sent and received messages can be viewed, and
                you can right-click on them to see the time of receipt. They disappear
                and are gone if the program is shut down, but there is an option to
                save received messages. From the "messages" window, you can
                "read messages" to view messages saved on the hard drive. They
                are saved in a folder named MESSAGES below where UI-View
                is installed. There is a separate file for each callsign that has sent
                you a message. Your sent messages are saved there too. The
                messages are saved in a text file and it uses Notepad to view the
                file. The date / time is shown, followed by the message. It must
                be hard-coded to use Notepad as it isn't my default text editor.
                One way of initiating a message is to right-click on a station on
                the map view and select "send a message" from the menu.

                73 es cul - Keith VE7GDH
                --
                "I may be lost, but I know exactly where I am!"
              • Kurt Savegnago
                Sat down today and tooled around with APRSIS32 on one screen and the wiki on the other.  Just had an internet connection up though I ve run it with a serial
                Message 7 of 25 , Jul 4, 2012
                • 0 Attachment
                  Sat down today and tooled around with APRSIS32 on one screen and the wiki on the other.  Just had an internet connection up though I've run it with a serial GPS and with a D7A(g) and a D72A attached in a simple mode.

                  Was messing with the filters and such and I somehow lost the ability to receive objects though APRS-IS is O.K.  It did receive objects from the IS before I sat down and starting banging away and making changes to some of the menu items. I do have a simple internet only setup at the office I could scroll through the menus and see what I've done but I've banged my head over a couple of hours and can't seem to get the objects to display.

                  I mean the objects transmitted by outside local stations.  I have an Xastir setup transmitting an object  I know is hitting the digi that's 400yds. away and making it to APRS.fi.  I'm not talking about objects generated locally on the APRSIS32 setup.  I do like the ability to turn the objects on and off actually.

                  Earlier in the day, I was receiving that object on this APRSIS32 setup over the internet but now that capability is gone and I don't know what I messed up in the menu!  Drat.      Is there a distance setting in the menu that I might have set incorrectly so Objects at a certain distance aren't displayed?   I'm racking my brain on this one.                        Kurt KC9LDH
                • Lynn W Deffenbaugh (Mr)
                  Please close your client and e-mail your APRSIS32.XML file to KJ4ERJ@arrl.net. I can check it out and see what I can make of it. But, there are some options:
                  Message 8 of 25 , Jul 4, 2012
                  • 0 Attachment
                    Please close your client and e-mail your APRSIS32.XML file to KJ4ERJ@....  I can check it out and see what I can make of it.  But, there are some options:

                    1) Make sure you have View / All checked.

                    2) Double-check your Configure / General / Range and remember that it is expressed in 1/10 mile increments.  50 is only 5 miles, 500 is 50 miles.

                    3) Make sure ME is in the right place, use Screen / Follow / ME to see where it is.  If it is wrong, then drag/zoom to where you should be, hit Transmit and then confirm the intent to Move ME to Center.

                    4) Check what all you might have in Configure / General / Add Filter.  In particular, watch out for minus (-) filter elements that would exclude certain things from coming from APRS-IS.  Especially look for -t/o which would eliminate all object packet.

                    Those are the ones that come quickly to mind.  If all else fails, just close the client, delete your APRSIS32.XML file, and restart.  Reconfigure and all should be well.

                    Lynn (D) - KJ4ERJ - Author of APRSISCE for Windows Mobile and Win32

                    On 7/5/2012 12:17 AM, Kurt Savegnago wrote:
                    Sat down today and tooled around with APRSIS32 on one screen and the wiki on the other.  Just had an internet connection up though I've run it with a serial GPS and with a D7A(g) and a D72A attached in a simple mode.

                    Was messing with the filters and such and I somehow lost the ability to receive objects though APRS-IS is O.K.  It did receive objects from the IS before I sat down and starting banging away and making changes to some of the menu items. I do have a simple internet only setup at the office I could scroll through the menus and see what I've done but I've banged my head over a couple of hours and can't seem to get the objects to display.

                    I mean the objects transmitted by outside local stations.  I have an Xastir setup transmitting an object  I know is hitting the digi that's 400yds. away and making it to APRS.fi.  I'm not talking about objects generated locally on the APRSIS32 setup.  I do like the ability to turn the objects on and off actually.

                    Earlier in the day, I was receiving that object on this APRSIS32 setup over the internet but now that capability is gone and I don't know what I messed up in the menu!  Drat.      Is there a distance setting in the menu that I might have set incorrectly so Objects at a certain distance aren't displayed?   I'm racking my brain on this one.                        Kurt KC9LDH

                  • Kurt Savegnago
                    Fixed,   It was the range I had set wrong.  Stupidhead here didn t get the 1/10th mile thing.:-0 I get it now and won t likely forget. :-)
                    Message 9 of 25 , Jul 4, 2012
                    • 0 Attachment
                      Fixed,

                        It was the range I had set wrong.  Stupidhead here didn't "get" the 1/10th mile thing.:-0
                      I "get" it now and won't likely forget. :-)

                                                        Kurt KC9LDH

                      --- On Wed, 7/4/12, Lynn W Deffenbaugh (Mr) <kj4erj@...> wrote:

                      From: Lynn W Deffenbaugh (Mr) <kj4erj@...>
                      Subject: Re: [aprsisce] Lost objects
                      To: aprsisce@yahoogroups.com
                      Date: Wednesday, July 4, 2012, 11:27 PM

                       

                      Please close your client and e-mail your APRSIS32.XML file to KJ4ERJ@....  I can check it out and see what I can make of it.  But, there are some options:

                      1) Make sure you have View / All checked.

                      2) Double-check your Configure / General / Range and remember that it is expressed in 1/10 mile increments.  50 is only 5 miles, 500 is 50 miles.

                      3) Make sure ME is in the right place, use Screen / Follow / ME to see where it is.  If it is wrong, then drag/zoom to where you should be, hit Transmit and then confirm the intent to Move ME to Center.

                      4) Check what all you might have in Configure / General / Add Filter.  In particular, watch out for minus (-) filter elements that would exclude certain things from coming from APRS-IS.  Especially look for -t/o which would eliminate all object packet.

                      Those are the ones that come quickly to mind.  If all else fails, just close the client, delete your APRSIS32.XML file, and restart.  Reconfigure and all should be well.

                      Lynn (D) - KJ4ERJ - Author of APRSISCE for Windows Mobile and Win32

                      On 7/5/2012 12:17 AM, Kurt Savegnago wrote:

                      Sat down today and tooled around with APRSIS32 on one screen and the wiki on the other.  Just had an internet connection up though I've run it with a serial GPS and with a D7A(g) and a D72A attached in a simple mode.

                      Was messing with the filters and such and I somehow lost the ability to receive objects though APRS-IS is O.K.  It did receive objects from the IS before I sat down and starting banging away and making changes to some of the menu items. I do have a simple internet only setup at the office I could scroll through the menus and see what I've done but I've banged my head over a couple of hours and can't seem to get the objects to display.

                      I mean the objects transmitted by outside local stations.  I have an Xastir setup transmitting an object  I know is hitting the digi that's 400yds. away and making it to APRS.fi.  I'm not talking about objects generated locally on the APRSIS32 setup.  I do like the ability to turn the objects on and off actually.

                      Earlier in the day, I was receiving that object on this APRSIS32 setup over the internet but now that capability is gone and I don't know what I messed up in the menu!  Drat.      Is there a distance setting in the menu that I might have set incorrectly so Objects at a certain distance aren't displayed?   I'm racking my brain on this one.                        Kurt KC9LDH

                    • Lynn W Deffenbaugh (Mr)
                      Glad you got it working and it was something simple. That 1/10 mile thing dates way back to my early APRS days when I thought people might like the fine
                      Message 10 of 25 , Jul 5, 2012
                      • 0 Attachment
                        Glad you got it working and it was something simple.  That 1/10 mile thing dates way back to my early APRS days when I thought people might like the fine control.  One of these days it might change, if I ever happen to have need to visit that particular dialog for some other purpose.

                        Lynn (D) - KJ4ERJ - Author of APRSISCE for Windows Mobile and Win32

                        On 7/5/2012 12:57 AM, Kurt Savegnago wrote:
                        Fixed,

                          It was the range I had set wrong.  Stupidhead here didn't "get" the 1/10th mile thing.:-0
                        I "get" it now and won't likely forget. :-)

                                                          Kurt KC9LDH

                        --- On Wed, 7/4/12, Lynn W Deffenbaugh (Mr) <kj4erj@...> wrote:

                        From: Lynn W Deffenbaugh (Mr) <kj4erj@...>
                        Subject: Re: [aprsisce] Lost objects
                        To: aprsisce@yahoogroups.com
                        Date: Wednesday, July 4, 2012, 11:27 PM

                         

                        Please close your client and e-mail your APRSIS32.XML file to KJ4ERJ@....  I can check it out and see what I can make of it.  But, there are some options:

                        1) Make sure you have View / All checked.

                        2) Double-check your Configure / General / Range and remember that it is expressed in 1/10 mile increments.  50 is only 5 miles, 500 is 50 miles.

                        3) Make sure ME is in the right place, use Screen / Follow / ME to see where it is.  If it is wrong, then drag/zoom to where you should be, hit Transmit and then confirm the intent to Move ME to Center.

                        4) Check what all you might have in Configure / General / Add Filter.  In particular, watch out for minus (-) filter elements that would exclude certain things from coming from APRS-IS.  Especially look for -t/o which would eliminate all object packet.

                        Those are the ones that come quickly to mind.  If all else fails, just close the client, delete your APRSIS32.XML file, and restart.  Reconfigure and all should be well.

                        Lynn (D) - KJ4ERJ - Author of APRSISCE for Windows Mobile and Win32

                        On 7/5/2012 12:17 AM, Kurt Savegnago wrote:

                        Sat down today and tooled around with APRSIS32 on one screen and the wiki on the other.  Just had an internet connection up though I've run it with a serial GPS and with a D7A(g) and a D72A attached in a simple mode.

                        Was messing with the filters and such and I somehow lost the ability to receive objects though APRS-IS is O.K.  It did receive objects from the IS before I sat down and starting banging away and making changes to some of the menu items. I do have a simple internet only setup at the office I could scroll through the menus and see what I've done but I've banged my head over a couple of hours and can't seem to get the objects to display.

                        I mean the objects transmitted by outside local stations.  I have an Xastir setup transmitting an object  I know is hitting the digi that's 400yds. away and making it to APRS.fi.  I'm not talking about objects generated locally on the APRSIS32 setup.  I do like the ability to turn the objects on and off actually.

                        Earlier in the day, I was receiving that object on this APRSIS32 setup over the internet but now that capability is gone and I don't know what I messed up in the menu!  Drat.      Is there a distance setting in the menu that I might have set incorrectly so Objects at a certain distance aren't displayed?   I'm racking my brain on this one.                        Kurt KC9LDH


                      • Krzysztof SQ5NWI
                        Lynn, it would be also handy for those of us familiar more with km than miles to have it scaled in km. If possible this parameter could be integrated in
                        Message 11 of 25 , Jul 5, 2012
                        • 0 Attachment
                          Lynn,

                          it would be also handy for those of us familiar more with km than miles to have it scaled in km.
                          If possible this parameter could be integrated in Configure -> Metrics menu for example.
                          --
                          Regards,

                          Krzysztof
                          SQ5NWI

                          From: aprsisce@yahoogroups.com [mailto:aprsisce@yahoogroups.com] On Behalf Of Lynn W Deffenbaugh (Mr)
                          Sent: Thursday, July 05, 2012 2:09 PM
                          To: aprsisce@yahoogroups.com
                          Subject: Re: [aprsisce] Lost objects


                          Glad you got it working and it was something simple. That 1/10 mile thing dates way back to my early APRS days when I thought people might like the fine control. One of these days it might change, if I ever happen to have need to visit that particular dialog for some other purpose.

                          Lynn (D) - KJ4ERJ - Author of APRSISCE for Windows Mobile and Win32

                          On 7/5/2012 12:57 AM, Kurt Savegnago wrote:
                          Fixed,

                          It was the range I had set wrong. Stupidhead here didn't "get" the 1/10th mile thing.:-0
                          I "get" it now and won't likely forget. :-)

                          Kurt KC9LDH

                          --- On Wed, 7/4/12, Lynn W Deffenbaugh (Mr) <kj4erj@...> wrote:


                          From: Lynn W Deffenbaugh (Mr) <kj4erj@...>
                          Subject: Re: [aprsisce] Lost objects
                          To: aprsisce@yahoogroups.com
                          Date: Wednesday, July 4, 2012, 11:27 PM

                          Please close your client and e-mail your APRSIS32.XML file to KJ4ERJ@.... I can check it out and see what I can make of it. But, there are some options:

                          1) Make sure you have View / All checked.

                          2) Double-check your Configure / General / Range and remember that it is expressed in 1/10 mile increments. 50 is only 5 miles, 500 is 50 miles.

                          3) Make sure ME is in the right place, use Screen / Follow / ME to see where it is. If it is wrong, then drag/zoom to where you should be, hit Transmit and then confirm the intent to Move ME to Center.

                          4) Check what all you might have in Configure / General / Add Filter. In particular, watch out for minus (-) filter elements that would exclude certain things from coming from APRS-IS. Especially look for -t/o which would eliminate all object packet.

                          Those are the ones that come quickly to mind. If all else fails, just close the client, delete your APRSIS32.XML file, and restart. Reconfigure and all should be well.

                          Lynn (D) - KJ4ERJ - Author of APRSISCE for Windows Mobile and Win32

                          On 7/5/2012 12:17 AM, Kurt Savegnago wrote:
                          Sat down today and tooled around with APRSIS32 on one screen and the wiki on the other. Just had an internet connection up though I've run it with a serial GPS and with a D7A(g) and a D72A attached in a simple mode.

                          Was messing with the filters and such and I somehow lost the ability to receive objects though APRS-IS is O.K. It did receive objects from the IS before I sat down and starting banging away and making changes to some of the menu items. I do have a simple internet only setup at the office I could scroll through the menus and see what I've done but I've banged my head over a couple of hours and can't seem to get the objects to display.

                          I mean the objects transmitted by outside local stations. I have an Xastir setup transmitting an object I know is hitting the digi that's 400yds. away and making it to APRS.fi. I'm not talking about objects generated locally on the APRSIS32 setup. I do like the ability to turn the objects on and off actually.

                          Earlier in the day, I was receiving that object on this APRSIS32 setup over the internet but now that capability is gone and I don't know what I messed up in the menu! Drat. Is there a distance setting in the menu that I might have set incorrectly so Objects at a certain distance aren't displayed? I'm racking my brain on this one. Kurt KC9LDH
                        Your message has been successfully submitted and would be delivered to recipients shortly.