Loading ...
Sorry, an error occurred while loading the content.
 

Re: [aprsisce] Re: Screen filters apply to all windows?

Expand Messages
  • Lynn W Deffenbaugh (Mr)
    Ok, that splains it. The issue happens when you re centered on a station that has embedded spaces. This causes an invalid automatic filter to be generated,
    Message 1 of 12 , Mar 28, 2012
      Ok, that 'splains it. The issue happens when you're centered on a
      station that has embedded spaces. This causes an invalid automatic
      filter to be generated, but you don't notice that because the APRS-IS
      server will continue to use your pre-centered filter. BUT, since you're
      connected to firenet.us AND that server restarts every morning about
      2:00am eastern time, when APRSISCE/32 reconnects after that restart the
      server has no filter and the automatic one is invalid, resulting in no
      APRS-IS packets coming in because there's no filter at the server.

      So, I need to detect the spaced-out centered station and replace the
      first embedded space with an *. Watch for a development release with
      notes to this effect and then give it another test.

      In the meantime, don't center any windows on a station with embedded
      spaces in the name and you'll survive the daily firenet.us server
      restart with filter intact.

      Lynn (D) - KJ4ERJ - Author of APRSISCE for Windows Mobile and Win32

      PS. Aren't trace logs wonderful?

      On 3/28/2012 11:08 AM, kf4lvz wrote:
      > It looks like it's the filter being sent to APRS-IS that is causing the trouble.
      >
      > When I got up this morning, the multitrack window was empty again even though it had over 50 stations on it when I left it for the night. The interesting thing was the IS log. Apparently the network was quiet so the connection was restarted. However, it appears that changed the filter string passed to the server which was something it didn't like and therefore nothing was sent from the server to me. I had to close and reopen the multitrack window to fix the filter.
      >
      > The station I had asked for in the Find dialog to open a multitrack was exactly "W4DOC A" (no quotes). That worked yesterday and the screen popped up with lots of traffic. I left it that way all night.
      >
      > This morning, the logs showed this:
      >
      > APRS-IS:2012-03-28T09:02:15.425 PortBTRead:recv(608) returned -1
      > APRS-IS:2012-03-28T09:02:15.425 Terminating after 3934 msec vs 60000 Quiet
      > APRS-IS:2012-03-28T09:02:15.425 Delaying Restart for 16066/20000 msec
      > APRS-IS:2012-03-28T09:02:32.330 Restarting Reader...
      > APRS-IS:2012-03-28T09:02:32.330 TcpReader Running on @... or firenet.us:14580 (0 OpenCmds, 0 CloseCmds)
      > APRS-IS:2012-03-28T09:02:32.393 firenet.us[0] = 165.91.140.47
      > APRS-IS:2012-03-28T09:02:32.393 Connecting(firenet.us[0/0]) or 165.91.140.47:14580
      > APRS-IS:2012-03-28T09:02:32.471 Connected(firenet.us)[0/0]=>165.91.140.47:14580
      > APRS-IS:2012-03-28T09:02:32.471 Firing NewConnection
      > APRS-IS:2012-03-28T09:02:32.471 Back from NewConnection
      > WinMain:2012-03-28T09:02:32.471 APRS-IS SubStatus 165.91.140.47:14580
      > APRS-IS:2012-03-28T09:02:32.549 # logresp KF4LVZ-15 verified, server Firenet, adjunct "filter m/160 r/34.24412/-118.26752/160 r/34.07243/-118.29760/160 -s/w t/n r/33.4/-84.23/200 r/26/-80.1/200 b/KF4LVZ p/FFC/LOX/MFL o/W4DOC A*" Error, contact SM5NRK with copy of the filter definition you tried
      > WinMain:2012-03-28T14:58:40.205 Logging Enabled
      >
      >
      > I don't know where the asterisk came from, I didn't type it. I also suspect it didn't like the space in the name but that's how the callsign/ssid comes across, with a space.
      >
      >
      > --- In aprsisce@yahoogroups.com, "KE6BB"<rv6amark@...> wrote:
      >> I attempted to duplicate this behavior on the two instances I had running today, but could not do it. The view filter only affected the window where I changed it. I also worked with the scroller filter to see if that would affect other windows, but it only affected the scroller. I believe everything was working as intended.
      >>
      >> I did consistently scare myself into thinking I had duplicated the problem when I opened multitrack windows and could only see the multitrack station. That is normal if you have Screen>Preferred>MultiTrack>View None checked, which I do. If you have this option checked, you have to check View>All after opening a multitrack window if you want to see anything other than the multitrack station.
      >>
      >> Mark
      >> KE6BB
      >>
      >>
      >>
      >> --- In aprsisce@yahoogroups.com, "Lynn W Deffenbaugh (Mr)"<kj4erj@> wrote:
      >>> Can anyone else corroborate this observation?
      >>>
      >
      >
      >
      > ------------------------------------
      >
      > Yahoo! Groups Links
      >
      >
      >
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.