Loading ...
Sorry, an error occurred while loading the content.

Re: [aprsisce] APRSIS32 Installed

Expand Messages
  • Lynn W. Deffenbaugh
    Jerome, The APRSIS32.xml file located in the current directory when the .EXE is executed is the only configuration information for the program. Are you
    Message 1 of 7 , Dec 30, 2009
    • 0 Attachment
      Jerome,

      The APRSIS32.xml file located in the current directory when the .EXE is
      executed is the only configuration information for the program. Are you
      double-clicking the .EXE directly or using a shortcut from somewhere
      else? It may be that the shortcut is specifying a different default
      directory and an .xml file in that directory is giving you grief.
      Although, if that were the case, it wouldn't prompt you for a new
      configuration when you run it. The lack of a configured callsign is
      what does that.

      If it were me, I'd just edit the APRSIS32.xml file with a plain text
      editor (Notepad works) and change the <OSM.Path> to something like:

      <OSM.Path>.\OSMTiles\</OSM.Path>

      Create a directory called OSMTiles in the directory along with the .EXE
      and .xml files and remember to only edit the .xml with the client NOT
      running. Otherwise your changes will get lost.

      There's other parameters in the .xml that you can mess with and others
      that will completely break the program, so please edit with caution and
      save a copy of the pre-edited file! One of these days I'll get around
      to documenting what all is in there and what is safe to change.

      Lynn (D) - KJ4ERJ


      Jerome wrote:
      > Lynn,
      >
      > I Installed APRSIS32 per your instructions; Entered my Call WD4CWG-2 and created a OSMTiles subdirectory from the Directory where the exe is located; Located Home and exited program to save.
      >
      > Program worked fine ... however
      >
      > The OSMTiles files seem to be "locked" into a location other than specified.
      >
      > I originally placed the APRSIS32.exe in my c:\My Documents\My Downloads\APRS\APRSIS32 Folder. Then I installed the program, as described ... Entered my Call WD4CWG-2 and created a OSMTiles subdirectory from the Directory where the exe is located; Located Home and exited program to save. When I started up the program everything ran fine, but when I checked for the OSMTiles files, the OSMTiles folder did not exist and the APRS00-thru-APRS18 folders were located at C:\My Documents\My Downloads.
      >
      > I then deleted ALL the APRS00-thru-APRS18 folders, deleted the APRSISCE.log, and deleted the APRSIS32.xml. I then repeated the above and got the same result.
      >
      > I then deleted ALL the APRS00-thru-APRS18 folders, deleted the APRSISCE.log, and deleted the APRSIS32.xml again, then I created and moved to C:\Program Files\APRSIS\ and copyied the APRSIS Folder with ONLY the EXE and repeated the install ... (Exe now in folder C:\Program Files\APRSIS\APRSIS). I again entered my Call WD4CWG-2 and created a OSMTiles subdirectory from the Directory where the exe is located (C:\Program Files\APRSIS32\APRSIS32\OSMTiles); Located Home and exited program to save. When I started up the program everything again ran fine, but when I checked for the OSMTiles files, the OSMTiles folder did exist this time, but the APRS00-thru-APRS18 folders were still located at C:\My Documents\My Downloads.
      >
      > Is there another file located somewhere else that is defining the directory structure that I failed to delete ? Any Ideas ?
      >
      > Thanks,
      > Jerome
      > WD4CWG
      >
    • Jerome
      Lynn, You are correct. I was using the Shortcut (inconsistantly). I did check the XML file and it was set for something other than the intended location ...
      Message 2 of 7 , Dec 30, 2009
      • 0 Attachment
        Lynn,

        You are correct. I was using the Shortcut (inconsistantly). I did check the XML file and it was set for something other than the intended location ... Changed it with WORDPAD, and it is working fine. Thanks.

        Can't wait to get the list to find out what else can be customized.

        73, Jerome
        WD4CWG

        --- In aprsisce@yahoogroups.com, "Lynn W. Deffenbaugh" <kj4erj@...> wrote:
        >
        > Jerome,
        >
        > The APRSIS32.xml file located in the current directory when the .EXE is
        > executed is the only configuration information for the program. Are you
        > double-clicking the .EXE directly or using a shortcut from somewhere
        > else? It may be that the shortcut is specifying a different default
        > directory and an .xml file in that directory is giving you grief.
        > Although, if that were the case, it wouldn't prompt you for a new
        > configuration when you run it. The lack of a configured callsign is
        > what does that.
        >
        > If it were me, I'd just edit the APRSIS32.xml file with a plain text
        > editor (Notepad works) and change the <OSM.Path> to something like:
        >
        > <OSM.Path>.\OSMTiles\</OSM.Path>
        >
        > Create a directory called OSMTiles in the directory along with the .EXE
        > and .xml files and remember to only edit the .xml with the client NOT
        > running. Otherwise your changes will get lost.
        >
        > There's other parameters in the .xml that you can mess with and others
        > that will completely break the program, so please edit with caution and
        > save a copy of the pre-edited file! One of these days I'll get around
        > to documenting what all is in there and what is safe to change.
        >
        > Lynn (D) - KJ4ERJ
        >
        >
        > Jerome wrote:
        > > Lynn,
        > >
        > > I Installed APRSIS32 per your instructions; Entered my Call WD4CWG-2 and created a OSMTiles subdirectory from the Directory where the exe is located; Located Home and exited program to save.
        > >
        > > Program worked fine ... however
        > >
        > > The OSMTiles files seem to be "locked" into a location other than specified.
        > >
        > > I originally placed the APRSIS32.exe in my c:\My Documents\My Downloads\APRS\APRSIS32 Folder. Then I installed the program, as described ... Entered my Call WD4CWG-2 and created a OSMTiles subdirectory from the Directory where the exe is located; Located Home and exited program to save. When I started up the program everything ran fine, but when I checked for the OSMTiles files, the OSMTiles folder did not exist and the APRS00-thru-APRS18 folders were located at C:\My Documents\My Downloads.
        > >
        > > I then deleted ALL the APRS00-thru-APRS18 folders, deleted the APRSISCE.log, and deleted the APRSIS32.xml. I then repeated the above and got the same result.
        > >
        > > I then deleted ALL the APRS00-thru-APRS18 folders, deleted the APRSISCE.log, and deleted the APRSIS32.xml again, then I created and moved to C:\Program Files\APRSIS\ and copyied the APRSIS Folder with ONLY the EXE and repeated the install ... (Exe now in folder C:\Program Files\APRSIS\APRSIS). I again entered my Call WD4CWG-2 and created a OSMTiles subdirectory from the Directory where the exe is located (C:\Program Files\APRSIS32\APRSIS32\OSMTiles); Located Home and exited program to save. When I started up the program everything again ran fine, but when I checked for the OSMTiles files, the OSMTiles folder did exist this time, but the APRS00-thru-APRS18 folders were still located at C:\My Documents\My Downloads.
        > >
        > > Is there another file located somewhere else that is defining the directory structure that I failed to delete ? Any Ideas ?
        > >
        > > Thanks,
        > > Jerome
        > > WD4CWG
        > >
        >
      • David Shrum
        Tonight I was tracking my son, W8TVI-12 with the APRSIS32 DeskTop version and with http://aprs.fi/ using Google maps; what I noticed with Google maps the SUV
        Message 3 of 7 , Dec 30, 2009
        • 0 Attachment
          Tonight I was tracking my son, W8TVI-12 with the APRSIS32 DeskTop version
          and with http://aprs.fi/ using Google maps; what I noticed with Google maps
          the SUV icon would show the direction of travel with the icon, but the
          APRSIS32 program, while keeping his icon centered, it didn't show the
          direction to travel in relationship to the map. Like I said, it was nothing
          more than curiosity to me.

          Dave N8PU

          No virus found in this outgoing message.
          Checked by AVG - www.avg.com
          Version: 9.0.722 / Virus Database: 270.14.123/2593 - Release Date: 12/30/09
          02:27:00
        • Lynn W. Deffenbaugh
          Long answer: I m hoping to latch onto some image rotation code to do the same thing with APRSISCE, but for now it just shows the simple icon. In addition, I m
          Message 4 of 7 , Dec 30, 2009
          • 0 Attachment
            Long answer: I'm hoping to latch onto some image rotation code to do the
            same thing with APRSISCE, but for now it just shows the simple icon. In
            addition, I'm hoping to do a dead-reckoning forecast of current position
            based on the previous heading and speed. I'll probably fade out the
            forecast icon and connect it to the last known position with a line in
            realtime.

            Short answer: it's on the ToDo list!

            Lynn (D) - KJ4ERJ

            PS. Coincidentally, I was also watching this evening as the icon
            changed from phone to SUV and the beacon rate slowed down. I have
            u/APWW*/APWM* in one of my filter strings to get a feel for how many
            people are actually using the client at any point in time. You can add
            the same and you'll see APRSISCE/32 users wherever they are.

            David Shrum wrote:
            > Tonight I was tracking my son, W8TVI-12 with the APRSIS32 DeskTop version
            > and with http://aprs.fi/ using Google maps; what I noticed with Google maps
            > the SUV icon would show the direction of travel with the icon, but the
            > APRSIS32 program, while keeping his icon centered, it didn't show the
            > direction to travel in relationship to the map. Like I said, it was nothing
            > more than curiosity to me.
            >
            > Dave N8PU
            >
          • David Shrum
            I guess I must be very thick headed; I still am not sure where to add the filters as you suggested. I know you explained it before but that went right over the
            Message 5 of 7 , Dec 30, 2009
            • 0 Attachment
              I guess I must be very thick headed; I still am not sure where to add the
              filters as you suggested. I know you explained it before but that went right
              over the top of my head. I don't have a clue where to add them, is it in the
              APRSIS32.xml where they are added? Thanks for your patience.

              Thanks again,

              Dave N8PU



              -----Original Message-----
              From: aprsisce@yahoogroups.com [mailto:aprsisce@yahoogroups.com] On Behalf
              Of Lynn W. Deffenbaugh
              Sent: Wednesday, December 30, 2009 10:03 PM
              To: aprsisce@yahoogroups.com
              Subject: Re: [aprsisce] APRSIS32 curiosity to me

              Lynn (D) - KJ4ERJ

              PS. Coincidentally, I was also watching this evening as the icon
              changed from phone to SUV and the beacon rate slowed down. I have
              u/APWW*/APWM* in one of my filter strings to get a feel for how many
              people are actually using the client at any point in time. You can add
              the same and you'll see APRSISCE/32 users wherever they are.


              No virus found in this outgoing message.
              Checked by AVG - www.avg.com
              Version: 9.0.722 / Virus Database: 270.14.123/2593 - Release Date: 12/30/09
              02:27:00
            • Lynn W. Deffenbaugh
              If you want to add any custom filters, you can find documentation at the following URLs: http://wa8lmf.net/aprs/JAVaprsFilters.htm
              Message 6 of 7 , Dec 30, 2009
              • 0 Attachment
                If you want to add any custom filters, you can find documentation at the
                following URLs:

                http://wa8lmf.net/aprs/JAVaprsFilters.htm
                http://www.aprs-is.net/javAPRSFilter.aspx

                Just figure out what you want to see and plug it into the "Add Filter:"
                box in the APRSISCE/32 configuration dialog.

                The client automatically does some filtering for you. It does:

                m/dist - My Range filter based on the configured Range (converted from
                1/10 mile to km)

                If you track or center on someone (right click or popup menu/Center), it
                adds a:

                f/call/dist - Friend Range filter using the same range

                This filter will be removed when you are no longer tracking a callsign.

                If you drag the map around to establish a center other than yourself or
                a specific station, it adds a:

                r/lat/lon/dist - Range filter using the map center and the configured range

                For any other filter, you can do your own. Here's a few of the Add
                Filter's I've got in a few instances of my APRSIS32 client:

                r/27.99673/-80.659072/1 b/KJ4DXK* b/KJ4ERJ* b/KJ4OVQ* u/APWW*/APWM* b/W4SGC*

                r/28.40/-81.50/2000 r/27.99673/-80.659072/1 -b/WINLINK -s/S/S -s//a/DW

                b/KJ4OVQ* b/KJ4ERJ* b/KJ4DXK* b/W4SGC* b/WI8H* -b/WINLINK -s/S/S -s//a/DW

                and my APRSISCE phone has the following filter:

                b/N4GVA* b/KJ4ERJ* b/KJ4DXK* b/KJ4OVQ* b/W4SGC* s/@/@ u/APWW*/APWM*
                -b/WINLINK

                Can you tell what callsigns I like to keep tabs on?

                Lynn (D) - KJ4ERJ

                PS. KJ4DXK is my son, KJ4OVQ is my wife, and N4GVA flies small planes
                here in Florida.

                David Shrum wrote:
                > I guess I must be very thick headed; I still am not sure where to add the
                > filters as you suggested. I know you explained it before but that went right
                > over the top of my head. I don't have a clue where to add them, is it in the
                > APRSIS32.xml where they are added? Thanks for your patience.
                >
                > Thanks again,
                >
                > Dave N8PU
                >
                >
                >
                > -----Original Message-----
                > From: aprsisce@yahoogroups.com [mailto:aprsisce@yahoogroups.com] On Behalf
                > Of Lynn W. Deffenbaugh
                > Sent: Wednesday, December 30, 2009 10:03 PM
                > To: aprsisce@yahoogroups.com
                > Subject: Re: [aprsisce] APRSIS32 curiosity to me
                >
                > Lynn (D) - KJ4ERJ
                >
                > PS. Coincidentally, I was also watching this evening as the icon
                > changed from phone to SUV and the beacon rate slowed down. I have
                > u/APWW*/APWM* in one of my filter strings to get a feel for how many
                > people are actually using the client at any point in time. You can add
                > the same and you'll see APRSISCE/32 users wherever they are.
                >
                >
              Your message has been successfully submitted and would be delivered to recipients shortly.