Loading ...
Sorry, an error occurred while loading the content.

21312Re: [aprsisce] Re: APRSIS32 running under WINE

Expand Messages
  • Greg D
    Dec 10, 2012
    • 0 Attachment
      Hi Rob,

      Your devil is a bit different than mine...  No colons here, but this is on a Linux system.

      greg@server:> ll ~/.wine/dosdevices/
      total 0
      lrwxrwxrwx 1 greg users  8 Dec 31  2011 a:: -> /dev/fd0
      lrwxrwxrwx 1 greg users 10 Dec 31  2011 c: -> ../drive_c
      lrwxrwxrwx 1 greg users 10 Dec 31  2011 com1 -> /dev/ttyS0
      lrwxrwxrwx 1 greg users 10 Jan  2  2012 com2 -> /dev/ttyS4
      lrwxrwxrwx 1 greg users 10 Jan  2  2012 com3 -> /dev/ttyS5

      lrwxrwxrwx 1 greg users  8 Dec 31  2011 d:: -> /dev/sr0
      lrwxrwxrwx 1 greg users  8 May  4  2012 e:: -> /dev/sdd
      lrwxrwxrwx 1 greg users  1 Dec 31  2011 z: -> /
      greg@server:>



      Greg  KO6TH


      Rob Giuliano wrote:
       
      As is most often the case, the devil is in the detail.

      Devices need the colon ':' at the end, so your symbolic link needs to be


      ln -s /dev/ttyUSB0 ~/.wine/dosdevices/com1:

      That is assuming the Keyspan device comes up as /dev/ttyUSB0.  Multiple USB devices can cause the actual ttyUSB# to changem so make sure you are only using one, or double check to ensure you are linking to the correct one.

      A quick check would be disconnect the Keysan device to do a
         "ls -l /dev/ttyUSB*"
      then plug it in and do it again.

      You can also add a udev rule in
        /etc/udev/rules.d
      which will create a symbolic link to the proper device.
      Write back if you (or anyone) are interested.

      Robert Giuliano
      KB8RCO

      ---------------------------------------------

      From: jandgandjochem <vk2jng@...>
      To: aprsisce@yahoogroups.com
      Sent: Monday, December 10, 2012 7:46 PM
      Subject: [aprsisce] Re: APRSIS32 running under WINE

       


      I still haven't got this going.
      APRSIS32 runs fine under WINE but I cannot get the Keyspan USB to serial adaptor to work. Googled everywhere and lots of info, some of it over my head.

      Tried setting the device with ln -s /dev/ttyUSB0 ~/.wine/dosdevices/com1 but APRSIS32 still does not recognise the port. (Or is it WINE not recognising it??)

      The keyspan device works fine under windows and also under Mountain Lion. No problems there.

      I must be missing something somewhere.

      Any step by step help appreciated. Love to get APRSIS32 configured with RF port back in operation on my MacBook.

      Thanks heaps



    • Show all 22 messages in this topic