Loading ...
Sorry, an error occurred while loading the content.

Re: mod_perl 2.0 compatibility?

Expand Messages
  • Joshua Chamas
    ... I am not sure whether Apache::ASP is thread safe, but probably would not take much work to get it that way. I have not set up mod_perl 2.0 and cannot
    Message 1 of 2 , Dec 9, 2001
    • 0 Attachment
      Philip Mak wrote:
      >
      > Is Apache::ASP compatible with mod_perl 2.0 and Apache 2.0? If so, are
      > there any problems I should be aware of?
      >

      I am not sure whether Apache::ASP is thread safe, but probably
      would not take much work to get it that way. I have not set up
      mod_perl 2.0 and cannot vouch for it, but if you were to get
      it running, I would recommend Apache::ASP to run in the mode
      that has been mentioned where each thread has its own perl
      interpreter, that should at least be safe, as long as other
      core modues are like:

      Digest::MD5
      MLDBM::Sync
      MLDBM
      Data::Dumper

      I would believe all of these latter modules to be thread safe
      as well, but won't know until they are tried.

      --Josh

      _________________________________________________________________
      Joshua Chamas Chamas Enterprises Inc.
      NodeWorks Founder Huntington Beach, CA USA
      http://www.nodeworks.com 1-714-625-4051

      ---------------------------------------------------------------------
      To unsubscribe, e-mail: asp-unsubscribe@...
      For additional commands, e-mail: asp-help@...
    Your message has been successfully submitted and would be delivered to recipients shortly.