Loading ...
Sorry, an error occurred while loading the content.

Re: Apache::ASP encounters with OpenBSD

Expand Messages
  • Josh Chamas
    ... Yes, this should be fixed in the next release 2.51, which I will be posting shortly to CPAN ( next few days I m sure ). ... I have a possible fix for this,
    Message 1 of 5 , Dec 10, 2002
    • 0 Attachment
      Peter Galbavy wrote:
      >
      > Set-up is OpenBSD/i386 (both 3.2 and -current - Apache/1.3.27), mod_perl
      > 1.27 and Apache::ASP 2.49 with this one patch:
      >
      > --- ASP.pm.orig Fri Nov 22 13:12:02 2002
      > +++ ASP.pm Fri Nov 22 13:12:11 2002
      > @@ -537,7 +537,7 @@ sub FileId {
      > my @inode_stat = ();
      > if($self->{inode_names}) {
      > @inode_stat = stat($file);
      > - unless($inode_stat[0] && $inode_stat[1]) {
      > + unless($inode_stat[0] || $inode_stat[1]) {
      > @inode_stat = ();
      > }
      > }
      >
      >
      > What I am hoping for is any instances of people saying that this stuff
      > sounds familir or that it is fixed in next release :)
      >
      >

      Yes, this should be fixed in the next release 2.51, which I will
      be posting shortly to CPAN ( next few days I'm sure ).

      > The symptoms, indicating maybe one or maybe more problems;
      >
      > 1. I get many many instances of:
      >
      > Use of uninitialized value in split at
      > /usr/local/libdata/perl5/site_perl/Apache
      > /ASP/Response.pm line 938 during global destruction.
      >

      I have a possible fix for this, and I will send you my
      latest 2.51 dev version for you to test separately.

      >
      > 2. Quite a few:
      >
      > Use of uninitialized value in string eq at
      > /usr/local/libdata/perl5/site_perl/Ap
      > ache/ASP/Session.pm line 236 during global destruction.
      >

      I have just fixed this as well, to be sent to you shortly.

      > 3. SEGV:
      >
      > I am getting a number of:
      >
      > [Tue Dec 10 08:50:09 2002] [notice] child pid 161 exit signal Segmentation
      > fault
      > (11)
      >

      Hmmm... don't know what that is.

      > Haven't looked at the core files yet. Will do soon. Not much else to go on.
      >
      > 4. 'Missing' environment
      >
      > Maybe related to the SEGV above, but I am seeing occasional failures in .asp
      > files to see any environment or ASP objects. I have code that does this:
      >
      > <% if (!defined $r->path_info) { %>
      > No category chosen.
      > ...
      > <% } else { %>
      >
      > But the URL most DEFINITELY had PATH_INFO... the access_log entries say
      > so...

      I'm not sure what is happening here, but is worth looking into.

      Thanks for the bug reports.

      --Josh
      ________________________________________________________________
      Josh Chamas, Founder phone:925-552-0128
      Chamas Enterprises Inc. http://www.chamas.com
      NodeWorks Link Checking http://www.nodeworks.com


      ---------------------------------------------------------------------
      To unsubscribe, e-mail: asp-unsubscribe@...
      For additional commands, e-mail: asp-help@...
    Your message has been successfully submitted and would be delivered to recipients shortly.