Loading ...
Sorry, an error occurred while loading the content.

Re: Apache-ASP on Apache2

Expand Messages
  • Josh Chamas
    ... Please post messages for Apache::ASP support to the mailing list. To get on the mailing list, send a message to asp-subscribe@perl.apache.org ... I have
    Message 1 of 7 , Dec 6, 2002
    • 0 Attachment
      CURTIS R. wrote:
      > I have been reading the posts on the Apache-ASP mailing
      > list, and see you have gotten apache-asp to run with
      > mod_perl1.99, and apache2.
      >
      > I have got everything compiled, but my httpd.conf gets
      > broken when I add in the PerlHandler and the rest of the
      > options from the apache-asp sites configuration section.
      >

      Please post messages for Apache::ASP support to the mailing
      list. To get on the mailing list, send a message to
      asp-subscribe@... ... I have cc'd the list
      to capture this thread in the archive.

      Apache::ASP should work the same underl mod_perl2/Apache2.
      That PerlHandler is broken implies that mod_perl is not
      installed correctly.

      > What are the correct strings to add to the httpd.conf ?
      > I am convinced all will be fine if I can only get the
      > httpd.conf working correctly.
      >

      The same as in mod_perl1, for example, I am driving chamas.com
      off of:

      <Files ~ \.html?$>
      SetHandler perl-script
      PerlModule Apache::ASP
      PerlHandler Apache::ASP
      PerlSetVar NoState 1
      PerlSetVar Global .
      PerlSetVar GlobalPackage Chamas::Site::Sun
      PerlSetVar UseStrict 1
      PerlSetVar StatScripts 1
      PerlSetVar XMLSubsMatch chamas:\w+

      # note the Off config will be available in 2.50 not yet released
      PerlSetVar XMLSubsPerlArgs Off
      </Files>

      > Would there be any chance of a small section on the
      > apache-asp site detailing the process for apache2 ?
      >

      If I find there to be differences, I will do so, but so
      far there have been none to my knowledge that affect
      an Apache::ASP user once mod_perl is set up correctly.
      Note however though Apache::ASP works under mod_perl2
      fine, it may be that mod_perl 1.9x / apache2 combo is yet unstable.
      Be sure to use the prefork mpm, and not worker mpm for now.
      MPM refers to a compilation option of apache2.

      Regards,

      Josh
      ________________________________________________________________
      Josh Chamas, Founder phone:925-552-0128
      Chamas Enterprises Inc. http://www.chamas.com
      NodeWorks Link Checking http://www.nodeworks.com


      ---------------------------------------------------------------------
      To unsubscribe, e-mail: asp-unsubscribe@...
      For additional commands, e-mail: asp-help@...
    • Richard Curtis
      I have now solved this problem and it was down to my pure stupidity. I forgot to add LoadModule perl_module modules/mod_perl.so to httpd.conf. Thanks
      Message 2 of 7 , Dec 7, 2002
      • 0 Attachment
        I have now solved this problem and it was down to my pure stupidity. I
        forgot to add "LoadModule perl_module modules/mod_perl.so" to httpd.conf.

        Thanks
        Richard

        >> I have been reading the posts on the Apache-ASP mailing list, and see
        >> you have gotten apache-asp to run with mod_perl1.99, and apache2.
        >>
        >> I have got everything compiled, but my httpd.conf gets broken when I
        >> add in the PerlHandler and the rest of the options from the
        >> apache-asp sites configuration section.
        >>
        >
        > Please post messages for Apache::ASP support to the mailing
        > list. To get on the mailing list, send a message to
        > asp-subscribe@... ... I have cc'd the list
        > to capture this thread in the archive.
        >
        > Apache::ASP should work the same underl mod_perl2/Apache2.
        > That PerlHandler is broken implies that mod_perl is not
        > installed correctly.
        >
        >> What are the correct strings to add to the httpd.conf ?
        >> I am convinced all will be fine if I can only get the httpd.conf
        >> working correctly.
        >>
        >
        > The same as in mod_perl1, for example, I am driving chamas.com
        > off of:
        >
        > <Files ~ \.html?$>
        > SetHandler perl-script
        > PerlModule Apache::ASP
        > PerlHandler Apache::ASP
        > PerlSetVar NoState 1
        > PerlSetVar Global .
        > PerlSetVar GlobalPackage Chamas::Site::Sun
        > PerlSetVar UseStrict 1
        > PerlSetVar StatScripts 1
        > PerlSetVar XMLSubsMatch chamas:\w+
        >
        > # note the Off config will be available in 2.50 not yet released
        > PerlSetVar XMLSubsPerlArgs Off
        > </Files>
        >
        >> Would there be any chance of a small section on the apache-asp site
        >> detailing the process for apache2 ?
        >>
        >
        > If I find there to be differences, I will do so, but so
        > far there have been none to my knowledge that affect
        > an Apache::ASP user once mod_perl is set up correctly.
        > Note however though Apache::ASP works under mod_perl2
        > fine, it may be that mod_perl 1.9x / apache2 combo is yet unstable.
        > Be sure to use the prefork mpm, and not worker mpm for now.
        > MPM refers to a compilation option of apache2.
        >
        > Regards,
        >
        > Josh
        > ________________________________________________________________
        > Josh Chamas, Founder phone:925-552-0128
        > Chamas Enterprises Inc. http://www.chamas.com
        > NodeWorks Link Checking http://www.nodeworks.com
        >
        >




        ---------------------------------------------------------------------
        To unsubscribe, e-mail: asp-unsubscribe@...
        For additional commands, e-mail: asp-help@...
      • Tim Moore <timj_moore@yahoo.co.uk>
        For info, I did get Apache::ASP to work on my RedHat 8 install at home which uses Apache2. I can t remember what I did but I think something did fail to
        Message 3 of 7 , Dec 9, 2002
        • 0 Attachment
          For info, I did get Apache::ASP to work on my RedHat 8 install at
          home which uses Apache2. I can't remember what I did but I think
          something did fail to install, possibly MLDBM, though that would
          suggest a Perl problem not Apache/mod_perl? (If so I probably turned
          off state support).

          I didn't have to rebuild or modify any of the Apache components that
          shipped with RedHat 8 though.


          ---------------------------------------------------------------------
          To unsubscribe, e-mail: asp-unsubscribe@...
          For additional commands, e-mail: asp-help@...
        • Richard Curtis
          I have finally gotten Apache::ASP to work, and once again, it was down to my error. I forgot to add PerlModule Apache2 to the httpd.conf. After adding this,
          Message 4 of 7 , Dec 9, 2002
          • 0 Attachment
            I have finally gotten Apache::ASP to work, and once again, it was down to my
            error.
            I forgot to add "PerlModule Apache2" to the httpd.conf.
            After adding this, everything worked as expected.

            Thanks
            Richard


            ---------------------------------------------------------------------
            To unsubscribe, e-mail: asp-unsubscribe@...
            For additional commands, e-mail: asp-help@...
          • Josh Chamas
            ... What was the error before adding PerlModule Apache2 ? I can have Apache::ASP automatically try to load that instead when it loads up. I thought I had that
            Message 5 of 7 , Dec 9, 2002
            • 0 Attachment
              Richard Curtis wrote:
              > I have finally gotten Apache::ASP to work, and once again, it was down to my
              > error.
              > I forgot to add "PerlModule Apache2" to the httpd.conf.
              > After adding this, everything worked as expected.
              >

              What was the error before adding PerlModule Apache2 ?
              I can have Apache::ASP automatically try to load that instead
              when it loads up. I thought I had that covered by loading
              Apache::compat ...

              Regards,

              Josh
              ________________________________________________________________
              Josh Chamas, Founder phone:925-552-0128
              Chamas Enterprises Inc. http://www.chamas.com
              NodeWorks Link Checking http://www.nodeworks.com


              ---------------------------------------------------------------------
              To unsubscribe, e-mail: asp-unsubscribe@...
              For additional commands, e-mail: asp-help@...
            • Richard Curtis
              ... to my ... Below is the error I receive without PerlModule Apache2: [Mon Dec 09 19:59:41 2002] [info] Server built: Dec 8 2002 14:56:25 No valid request
              Message 6 of 7 , Dec 9, 2002
              • 0 Attachment
                > > I have finally gotten Apache::ASP to work, and once again, it was down
                to my
                > > error.
                > > I forgot to add "PerlModule Apache2" to the httpd.conf.
                > > After adding this, everything worked as expected.
                > >
                >
                > What was the error before adding PerlModule Apache2 ?
                > I can have Apache::ASP automatically try to load that instead
                > when it loads up. I thought I had that covered by loading
                > Apache::compat ...

                Below is the error I receive without PerlModule Apache2:

                [Mon Dec 09 19:59:41 2002] [info] Server built: Dec 8 2002 14:56:25
                No valid request object (Apache::RequestRec=SCALAR(0x81a16ac)) passed to ASP
                handler; if you are getting
                this error message, you likely have a broken DSO version of mod_perl
                which often occurs when using RedHat RPMs. One fix reported is to
                configure "PerlSendHeader On". Another fix is to compile
                statically the apache + mod_perl build as RedHat RPMs have been trouble.
                Please check FAQ or mod_perl archives for more information.

                Placing PerlModule Apache2 in httpd.conf fixes all problems.

                Richard


                ---------------------------------------------------------------------
                To unsubscribe, e-mail: asp-unsubscribe@...
                For additional commands, e-mail: asp-help@...
              • beckts33 <beckts@beckts.com>
                I am new to Apache and ASP, but was successful in getting Apache2 to run on Windows. I have also been able to run aspx on the same machine using a proxy
                Message 7 of 7 , Jan 3, 2003
                • 0 Attachment
                  I am new to Apache and ASP, but was successful in getting Apache2 to
                  run on Windows.

                  I have also been able to run aspx on the same machine using a proxy
                  server, Cassini. I'll attach the link for that.

                  Here is the code I added to my config file that make ASP work with
                  Windows/Apache:

                  <Files *.asp>
                  SetHandler perl-script
                  PerlHandler Apache::ASP
                  PerlSetVar Global C:/Windows/temp
                  PerlSetVar CookiePath /
                  PerlSetVar AllowSessionState 1
                  PerlSetVar SessionTimeout 20
                  #PerlSetVar Debug 2
                  # have "use strict;" by default, recommended
                  PerlSetVar UseStrict 1
                  # when errors occur in ASP, print out debug info
                  PerlSetVar Debug 2
                  PerlSetVar BufferingOn 1
                  PerlSetVar StatINC 1
                  PerlSetVar SessionSerialize 0
                  PerlSetVar SoftRedirect 0
                  PerlSetVar NoState 1
                  PerlSetVar StateDir ./.state
                  PerlSetVar StateManager 10
                  PerlSetVar MaxThreadsPerChild 1
                  </Files>

                  Apache/aspx (asp.net):
                  http://www.codeproject.com/aspnet/cassini_apache_101.asp



                  --- In apache-asp@yahoogroups.com, Josh Chamas <josh@c...> wrote:
                  > CURTIS R. wrote:
                  > > I have been reading the posts on the Apache-ASP mailing
                  > > list, and see you have gotten apache-asp to run with
                  > > mod_perl1.99, and apache2.
                  > >
                  > > I have got everything compiled, but my httpd.conf gets
                  > > broken when I add in the PerlHandler and the rest of the
                  > > options from the apache-asp sites configuration section.
                  > >
                  >
                  > Please post messages for Apache::ASP support to the mailing
                  > list. To get on the mailing list, send a message to
                  > asp-subscribe@p... ... I have cc'd the list
                  > to capture this thread in the archive.
                  >
                  > Apache::ASP should work the same underl mod_perl2/Apache2.
                  > That PerlHandler is broken implies that mod_perl is not
                  > installed correctly.
                  >
                  > > What are the correct strings to add to the httpd.conf ?
                  > > I am convinced all will be fine if I can only get the
                  > > httpd.conf working correctly.
                  > >
                  >
                  > The same as in mod_perl1, for example, I am driving chamas.com
                  > off of:
                  >
                  > <Files ~ \.html?$>
                  > SetHandler perl-script
                  > PerlModule Apache::ASP
                  > PerlHandler Apache::ASP
                  > PerlSetVar NoState 1
                  > PerlSetVar Global .
                  > PerlSetVar GlobalPackage Chamas::Site::Sun
                  > PerlSetVar UseStrict 1
                  > PerlSetVar StatScripts 1
                  > PerlSetVar XMLSubsMatch chamas:\w+
                  >
                  > # note the Off config will be available in 2.50 not yet released
                  > PerlSetVar XMLSubsPerlArgs Off
                  > </Files>
                  >
                  > > Would there be any chance of a small section on the
                  > > apache-asp site detailing the process for apache2 ?
                  > >
                  >
                  > If I find there to be differences, I will do so, but so
                  > far there have been none to my knowledge that affect
                  > an Apache::ASP user once mod_perl is set up correctly.
                  > Note however though Apache::ASP works under mod_perl2
                  > fine, it may be that mod_perl 1.9x / apache2 combo is yet unstable.
                  > Be sure to use the prefork mpm, and not worker mpm for now.
                  > MPM refers to a compilation option of apache2.
                  >
                  > Regards,
                  >
                  > Josh
                  > ________________________________________________________________
                  > Josh Chamas, Founder phone:925-552-0128
                  > Chamas Enterprises Inc. http://www.chamas.com
                  > NodeWorks Link Checking http://www.nodeworks.com
                  >
                  >
                  > -------------------------------------------------------------------
                  --
                  > To unsubscribe, e-mail: asp-unsubscribe@p...
                  > For additional commands, e-mail: asp-help@p...


                  ---------------------------------------------------------------------
                  To unsubscribe, e-mail: asp-unsubscribe@...
                  For additional commands, e-mail: asp-help@...
                Your message has been successfully submitted and would be delivered to recipients shortly.