Loading ...
Sorry, an error occurred while loading the content.
 

Anecdote: misspelling "PerlSetVar GlobalPackage"

Expand Messages
  • Philip Mak
    [I hope I m subscribed to the list properly this time so that my post doesn t have to be manually approved. Apparently, ezmlm uses my SMTP MAIL FROM address
    Message 1 of 1 , Jan 10, 2002
      [I hope I'm subscribed to the list properly this time so that my post
      doesn't have to be manually approved. Apparently, ezmlm uses my SMTP
      MAIL FROM address instead of my "From:" address, which caused problems
      when the virtual host aaanime.net was moved to another machine.]

      I was setting up a new Apache::ASP site today, and I misspelled
      GlobalPackage in httpd.conf:

      PerlSetVar GlobalPackate main

      I then spent over 10 minutes scratching my head over why it seemed
      that the code in Script_OnStart was not being executed. Since I had
      not set the package name correctly, Apache::ASP could not find
      Script_OnStart in the global namespace. I finally noticed the typo
      when looking over my httpd.conf again.

      Conclusion: If Script_OnStart isn't being executed ("executing
      Script_OnStart" will show up in error_log if you "PerlSetVar Debug
      -2"), your setting of PerlSetVar GlobalPackage probably doesn't match
      the package that you set in global.asa.

      ---------------------------------------------------------------------
      To unsubscribe, e-mail: asp-unsubscribe@...
      For additional commands, e-mail: asp-help@...
    Your message has been successfully submitted and would be delivered to recipients shortly.