Loading ...
Sorry, an error occurred while loading the content.
 

PerlModule?

Expand Messages
  • Joel Hughes
    Hi, am trying to get Apache::ASP working on a RH7.1. box for the first time. The Apache is Red Hats 1.3.22 pre-built with Mod Perl. I (think) I have installed
    Message 1 of 4 , Jul 1, 2002
      Hi,
      am trying to get Apache::ASP working on a RH7.1. box for the first time.

      The Apache is Red Hats 1.3.22 pre-built with Mod Perl.

      I (think) I have installed Apache::ASP via the CPAN technique. It seemed to
      install fine.

      I have made the httpd.conf amendments as per the website.

      This is what I've added to my httpd.conf

      <Files ~(\.asp)>
      SetHandler perl-script
      PerlModule Apache::ASP
      PerlHandler Apache::ASP
      PerlSetVar Global .
      PerlSetVar StateDir /tmp/asp
      </Files>


      However, when I do a httpd -t I get

      "Invalid command PerlModule, perhaps mis-spelled or defined by a module not
      included in the server configuration".

      Any ideas? Am I doing something stupid here and/or have I missed a step(s)?

      any help appreciated

      joel



      ---------------------------------------------------------------------
      To unsubscribe, e-mail: asp-unsubscribe@...
      For additional commands, e-mail: asp-help@...
    • Joshua Chamas
      ... You need to have mod_perl activated. It may be that the default web server configuration does not have mod_perl loaded. Check your httpd.conf &
      Message 2 of 4 , Jul 1, 2002
        Joel Hughes wrote:
        > Hi,
        > am trying to get Apache::ASP working on a RH7.1. box for the first time.
        >
        > The Apache is Red Hats 1.3.22 pre-built with Mod Perl.
        >
        > I (think) I have installed Apache::ASP via the CPAN technique. It seemed to
        > install fine.
        > ...
        > However, when I do a httpd -t I get
        >
        > "Invalid command PerlModule, perhaps mis-spelled or defined by a module not
        > included in the server configuration".
        >
        > Any ideas? Am I doing something stupid here and/or have I missed a step(s)?
        >
        > any help appreciated
        >

        You need to have mod_perl activated. It may be that the default
        web server configuration does not have mod_perl loaded.
        Check your httpd.conf & /etc/init.d/httpd script to see how mod_perl
        gets started. In my redhat 7.2 /etc/httpd/conf/httpd.conf, it looked
        something like:

        <IfDefine HAVE_PERL>
        AddModule mod_perl.c
        </IfDefine>

        If you just delete the IfDefine tags, it will just always
        load mod_perl always. Note that at least the 7.2 redhat apache has
        XML/expat compiled it, which will conflict with XML::Parser
        modules ( like XML::XSLT ), so if you need to get those working,
        you will need to compile your own apache, with a ./configure like:

        ./configure \
        --prefix=/usr/local/apache \
        --activate-module=src/modules/perl/libperl.a \
        --enable-module=ssl \
        --enable-module=proxy \
        --enable-module=so \
        --disable-rule=EXPAT

        See the make_httpd/build_httpds.sh script in the distribution
        for the context in which this command would get run in
        building apache/mod_per/mod_ssl.

        --Josh
        _________________________________________________________________
        Joshua Chamas Chamas Enterprises Inc.
        NodeWorks Founder Huntington Beach, CA USA
        http://www.nodeworks.com 1-714-625-4051



        ---------------------------------------------------------------------
        To unsubscribe, e-mail: asp-unsubscribe@...
        For additional commands, e-mail: asp-help@...
      • Joel Hughes
        Thanks Joshua, I have changed httpd.conf as per your recomendation (to force mod perl on) and now httpd -t is saying its ok. I have restarted Apache. I have
        Message 3 of 4 , Jul 1, 2002
          Thanks Joshua,
          I have changed httpd.conf as per your recomendation (to force mod perl on)
          and now httpd -t is saying its ok. I have restarted Apache.

          I have created a test asp page (imaginatively called test.asp) but it is not
          getting processed by the server. The file, including ASP, is being returned
          to the the browser (not as a file download but as html).

          I'm not seeing anything odd in the apache logs.

          The only change I've made to httpd.conf (except as per your suggestion) is
          <FILES config.

          I haven't got the plethora of settings which seem to be in
          http://www.apache-asp.org/eg/.htaccess. Indeed I have not htaccess files.

          Any ideas?



          -----Original Message-----
          From: Joshua Chamas [mailto:joshua@...]
          Sent: 01 July 2002 20:29
          To: joel@...
          Cc: asp@...
          Subject: Re: PerlModule?


          Joel Hughes wrote:
          > Hi,
          > am trying to get Apache::ASP working on a RH7.1. box for the first time.
          >
          > The Apache is Red Hats 1.3.22 pre-built with Mod Perl.
          >
          > I (think) I have installed Apache::ASP via the CPAN technique. It seemed
          to
          > install fine.
          > ...
          > However, when I do a httpd -t I get
          >
          > "Invalid command PerlModule, perhaps mis-spelled or defined by a module
          not
          > included in the server configuration".
          >
          > Any ideas? Am I doing something stupid here and/or have I missed a
          step(s)?
          >
          > any help appreciated
          >

          You need to have mod_perl activated. It may be that the default
          web server configuration does not have mod_perl loaded.
          Check your httpd.conf & /etc/init.d/httpd script to see how mod_perl
          gets started. In my redhat 7.2 /etc/httpd/conf/httpd.conf, it looked
          something like:

          <IfDefine HAVE_PERL>
          AddModule mod_perl.c
          </IfDefine>

          If you just delete the IfDefine tags, it will just always
          load mod_perl always. Note that at least the 7.2 redhat apache has
          XML/expat compiled it, which will conflict with XML::Parser
          modules ( like XML::XSLT ), so if you need to get those working,
          you will need to compile your own apache, with a ./configure like:

          ./configure \
          --prefix=/usr/local/apache \
          --activate-module=src/modules/perl/libperl.a \
          --enable-module=ssl \
          --enable-module=proxy \
          --enable-module=so \
          --disable-rule=EXPAT

          See the make_httpd/build_httpds.sh script in the distribution
          for the context in which this command would get run in
          building apache/mod_per/mod_ssl.

          --Josh
          _________________________________________________________________
          Joshua Chamas Chamas Enterprises Inc.
          NodeWorks Founder Huntington Beach, CA USA
          http://www.nodeworks.com 1-714-625-4051



          ---------------------------------------------------------------------
          To unsubscribe, e-mail: asp-unsubscribe@...
          For additional commands, e-mail: asp-help@...




          ---------------------------------------------------------------------
          To unsubscribe, e-mail: asp-unsubscribe@...
          For additional commands, e-mail: asp-help@...
        • Joshua Chamas
          ... This is typical when the config you are using is not being triggered for the files in question. Try first to get the examples to work, see here:
          Message 4 of 4 , Jul 1, 2002
            Joel Hughes wrote:
            > Thanks Joshua,
            > I have changed httpd.conf as per your recomendation (to force mod perl on)
            > and now httpd -t is saying its ok. I have restarted Apache.
            >
            > I have created a test asp page (imaginatively called test.asp) but it is not
            > getting processed by the server. The file, including ASP, is being returned
            > to the the browser (not as a file download but as html).
            >
            > I'm not seeing anything odd in the apache logs.
            >
            > The only change I've made to httpd.conf (except as per your suggestion) is
            > <FILES config.
            >

            This is typical when the config you are using is not being
            triggered for the files in question. Try first to get the
            examples to work, see here:

            http://www.apache-asp.org/install.html#Quick%20Start

            Once you see things working there, I would start experimenting
            with your own <Files> configs.

            --Josh


            ---------------------------------------------------------------------
            To unsubscribe, e-mail: asp-unsubscribe@...
            For additional commands, e-mail: asp-help@...
          Your message has been successfully submitted and would be delivered to recipients shortly.